IRC channel logs

2023-06-25.log

back to list of logs

<AwesomeAdam54321>I figured out how to build pnet, but the problem is that the runtime(ilrun) segfaults
<AwesomeAdam54321>Here's the full GDB backtrace: https://paste.debian.net/1284073
<AwesomeAdam54321>*segfaults when I try to run it
<AwesomeAdam54321>it turns out I just needed to build pnet with libjit
<stikonas>is this for bootstrapping mono?
<AwesomeAdam54321>stikonas: yep
<muurkha>oh cool
<lanodan>So going to revive parts of dotGNU?
<muurkha>hmm, this Artistic-Licensed implementation of Smalltalk written in C is interesting: https://github.com/rcornwell/smalltalk
<muurkha>it doesn't require an implementation of Smalltalk to bootstrap it, the way Squeak does
<muurkha>I'm not sure if it's compatible enough with Squeak to be used to bootstrap Squeak
<muurkha> https://github.com/rcornwell/smalltalk/blob/master/parse.c
<stikonas[m]><DallasStrouseOro> "I see on https://bootstrappable..." <- you just need to build gazillion of intermediate versions to get to the latest
<stikonas[m]>once you have rust 1.54, there is nothing special in building latest
<stikonas[m]>e.g. on Gentoo I just use (lightly tweaked) Gentoo ebuilds
<stikonas[m]> https://gitlab.com/stikonas/gentoo-bootstrap/-/tree/master/dev-lang/rust
<stikonas[m]>and that projects.html is unfortunately somewhat outdated
<Christoph[m]>rust is already bootstrapped, isn't it? See https://guix.gnu.org/blog/2018/bootstrapping-rust/
<orowith2os[m]>Christoph[m]: oh, so it already works
<orowith2os[m]>good to know
<orowith2os[m]>I
<orowith2os[m]>bleh, misclick. I'll pass it along to the freedesktop-sdk folks
<orowith2os[m]><stikonas[m]> "https://gitlab.com/stikonas/..." <- poking at the README: "mrustc is ocasionally broken on some versions of GCC. Last tested with GCC 12.2.1." GCC 13 likes to complain about missing includes, I've already submitted some fixes upstream so it works fine: https://github.com/thepowersgang/mrustc/pull/305
<stikonas[m]>orowith2os[m]: I think free desktop sdk people know about mrustc
<stikonas[m]>But it's slow
<stikonas[m]>Especially going from 1.54 to 1.69
<orowith2os[m]>yeah, they don't like having to build one version after another
<orowith2os[m]>I want to see if I can make mrustc build just a bit faster, because right now it only builds on one core, which as you can imagine is.... pain
<orowith2os[m]>so at least cut out a good ~2 hours from the build process
<stikonas[m]>Memory usage of mrustc is bigger problem
<stikonas[m]>Or rather memory usage of GCC that is spawned by mrustc
<muurkha>GCC is usually not as bad as clang on that, so it's a bit surprising
<stikonas>well, it depends on the size of the C file
<stikonas>mrustc generates fairly large C files
<stikonas>basically the whole module is converted into one C file
<stikonas>and then compiled in one go
<muurkha>yeah
<orowith2os[m]>oh, well, that explains why it builds everything on one core, at least