IRC channel logs

2023-04-24.log

back to list of logs

<fossy>rickmasters: we do not require sysb any more - sysb was an assumption that the bootstrap kernel, when it existed, may not support hard drive, however, now that fiwix is being used there, that's no longer a problem
<stikonas>fossy: well, like I was discussing before, it's only partially true
<stikonas>fiwix will only support some devices
<stikonas>far less than what linux supports
<stikonas>so going via RAM into sysb might still be preferrable
<fossy>hm, what has the possibility of being used that Fiwix doesn't support? USB?
<fossy>i can't really think of anything other than USB, but USB might be a good enough reason..
<fossy>either way, if we move sysa to HDD, we are going to require a non-USB hard drive anyway, in which case, I don't really see the point of sysb
<fossy>rickmasters: in that case, I am alright with still including that, even if writing the disk takes 22 minutes
<fossy>*that=builder-hex0 writing a disk
<stikonas>fossy: I think USB is indeed not supported
<stikonas>so I think the options are either more limited storage media support but maybe more space for bootstrap
<stikonas>or more supported storage (whatever bios can read/write) but maybe limited sysa size
<fossy>personally I'm ok with more limited storage media support at least for the time being
<fossy>SATA is rather ubiquitous
<pabs3>ACTION thinks that the sysb assumption seems like one that brings more flexibility and thus is worth preserving
<fossy>pabs3: it is only useful if we keep sysa as an initramfs, which i do not really like, because it 1. removes most flexibility from sysa since we have to keep everything in RAM 2. makes RAM requirements for live-bootstrap nearly impossible to reduce
<rickmasters>fossy, stikonas: Now that I understand the role of sysb better, I have mixed feelings about the way forward.
<rickmasters>I wonder if I may have approached the kernel bootstrap differently if
<rickmasters>I had better understood the potential of storage device flexibility
<rickmasters>versus the challenges of staying in RAM until Linux was launched.
<rickmasters>Oh well, I'm not going to dwell on it because one overriding priority
<rickmasters>trumps all: just making a kernel bootstrap work, somehow.
<rickmasters>We'll be able to develop alternate paths in the future if someone wants it enough.
<rickmasters>For example, it is possible that tccboot might come back to the table someday.
<rickmasters>(To be clear, Fiwix is great and I've had fun working with it.)
<rickmasters>Anyway, I'll try not to foreclose future alternatives unless it really helps.
<rickmasters>Specifically, removing sysb is not on my list of priorities. Maybe it happens. Not sure.
<rickmasters>I'm going focus on a finding a way to boot Linux and go from there.
<rickmasters>stikonas: Thanks again for doing the work on the assembly macros.
<Mikaku>rickmasters: if you are now focusing on kexec Linux from Fiwix, I think you might want to see, unless you already know it, the code of the Limine bootloader: <https://github.com/limine-bootloader/limine/tree/trunk/common/protos>
<Mikaku>the directory protos/ contains the source of all the protocols supported by this bootloader: chainload, its own Limine protocol, multiboot 1 and 2, and of course, Linux
<Mikaku>since Limine is a relatively new bootloader, you might find its code easier to follow than GRUB
<rickmasters>Mikaku: Thanks! I was just looking at grub and it will be great to have another reference.
<Mikaku>I mean, perhaps Limine will help you better to understand what Linux kernel needs to boot
<Mikaku>rickmasters: yes, the more references the best
<stikonas[m]>rickmasters: and I think it's not too bad if builder-hex0 takes 22 minutes to load data... mes currently takes similar amount of time
<rickmasters>stikonas: It's not horrible but this is qemu on fast modern hardware. I'm a bit worried about real hardware performance.
<rickmasters>Just to clarify, its 22 minutes for builder-hex0 to write the hard drive image for Fiwix to boot from.
<rickmasters>I still need to explore creating a smaller partition, expanding it later. I think most of the current image is empty space needed later for the build.
<rickmasters>Mikaku: limine also has a much more permissive license (BSD-2) vs grub (GPL 3)
<rickmasters>Mikaku: ... except there is GPL-2 code copied from Linux. Fiwix has already included Linux code so no difference there.
<Mikaku>rickmasters: great! :-)
<river>this is kinda off topic for bootstrapping I guess but I blogged about my experience implementing an LSTM with Bard
<river>i have a view towards some LLM implementing a new improved version of its own code
<AwesomeAdam54321>river: just a question, why isn't it just LM since it isn't stated what Large is relative to?
<river>i think large is really getting at how certain capabilities only emerge at scale in these language models
<muurkha>river: cool!