IRC channel logs

2023-03-11.log

back to list of logs

<stikonas>rickmasters: I fixed that initramfs issue
<stikonas>actually I would suggest not reverting run2.sh but for now move bash 5 to sysc and rebuild bash 2 in sysa
<stikonas>medium term we probably will be able to upgrade to bash 4 in sysa, so there will be less refactoring of run.sh vs run2.sh
<nektro>doras, woah congrats :)
<muurkha>doras: that's wonderful! congratulations!
<fossy>oh, sorry about #259. that was a silly mistake with git from me :\
<fossy>rickmasters, stikonas[m]: i'm happy with rebuilding bash 2 instead.. i'll remake my branch to do that
<fossy>oh
<fossy>stikonas already did it haha thanks :D
<fossy>oh but not the actual bash 5 removal
<fossy>ok got it ill do that bit now
<stikonas[m]>fossy: no, I just patched automake
<stikonas[m]>Cherry picked your commit and fixed linter
<stikonas[m]>We still need to add bash 5 to sysc and rebuild bash 2 in sysa where bash 5 currently is
<stikonas[m]>OK, merged
<stikonas[m]>rickmasters: can you try tip of live-bootstrap now?
<gforce_de1977>current master fails:
<gforce_de1977> https://github.com/fosslinux/live-bootstrap/issues/261
<gforce_de1977>stikonas: question: are we downloading files during bootstrapping? is'nt it always prepared on sysa before qemu starts?
<gforce_de1977>stikonas: it other words - we need network access?
<fossy>gforce_de1977: that is the default to download distfiles, yes
<fossy>you can use --external-sources
<fossy>which uses the old behaviour of copying distfiles in externally
<fossy>this is not final behaviour by the way
<fossy>possibly subject to change at a later date
<gforce_de1977>fossy: thanks for making that clear - i was'nt aware of that
<gforce_de1977>wouldn't it be great to print the real checksum when in fails, e.g. in sysa/helpers.sh => src_checksum()
<stikonas>gforce_de1977: we have --update-checksum mode that ignores checksums
<stikonas>I don't think we can print real checksum when it fails
<stikonas>traps are broken in bash 2
<stikonas>fossy: I've now got strip: unable to copy file '/tmp/destdir/usr/lib/perl5/5.32.1/i386-linux/CORE/libperl.a'; reason: Permission denied
<stikonas>I'll retest but it's unlikely to be one-off
<AwesomeAdam54321>The stage0 bootstrap path achieves binary-source correspondence in bootstrapping by making the source correspond to the binary
<AwesomeAdam54321>Is it feasible for an alternate bootstrap path to achieve binary-source correspondence by making the binary correspond to the source?
<AwesomeAdam54321>For example, Lisp Machines that could directly run Lisp code
<gforce_de1977>AwesomeAdam54321: maybe not for all (early) steps, but may i ask: which step would a lisp-machine run at first? consider: https://github.com/fosslinux/live-bootstrap/blob/master/parts.rst - which parts can be thrown away/subsituted by a lisp machine?
<stikonas>well, you don't need early steps for those machines that can run source
<stikonas>though I guess any such hardware would be quite inefficient
<stikonas>which might be the reason why nobody is making it today
<stikonas>it's basically just moving compiler to hardware
<AwesomeAdam54321>gforce_de1977: Steps 1-13 can be skipped with a lisp machine, with mescc being the first step
<gforce_de1977>AwesomeAdam54321 - i theory there should be no differences with source and binary for "traditional" and "lisp-machine" bootstrap.
<gforce_de1977>nice experiment anyway, but IMHO there a little bit of fun (the early steps) missing 8-)
<gforce_de1977>AwesomeAdam54321 - do you HAVE a lisp machine?
<AwesomeAdam54321>gforce_de1977: No, it was just something I was thinking about
<gforce_de1977> https://github.com/ghosthamlet/awesome-lisp-machine
<gforce_de1977>but it must be a scheme machine, right?
<AwesomeAdam54321>definitely
<stikonas[m]>AwesomeAdam54321: is mescc even useful for lisp machine?
<stikonas[m]>That's C compiler
<rickmasters>fossy: Unfortunately, the bash 2 rebuild is failing on Fiwix.
<rickmasters>fossy: I get a couple page faults running configure and then compilation fails with a bison general protection fault.
<AwesomeAdam54321>stikonas[m]: It's useful if you want to build packages written in C
<stikonas[m]>rickmasters: hmm, that's a bit unfortunate :(
<AwesomeAdam54321>But mescc doesn't target the lisp machine so it is actually useless
<stikonas[m]>How does it work on fiwix is then...
<stikonas[m]>rickmasters: should we remove bash 2 rebuild then?
<stikonas[m]>I meant how does it work on fiwix os
<rickmasters>stikonas: I don't know. It may use a different bison.
<stikonas[m]>Oh maybe they don't run bison at all
<stikonas[m]>Still, we used bison quite a bit already
<stikonas[m]>rickmasters: can you comment out bash rebuild step?
<stikonas[m]>So that we can see if things after it work
<rickmasters>stikonas: sure
<rickmasters>stikonas: will the `exec env -i bash run2.sh` command still work at the end of run.sh?
<stikonas[m]>It should
<stikonas[m]>Even if we remove bash rebuild, we could keep that exec as future investigation placeholder
<avih>oriansj: so what do we do about strict hex0? do you want to drop it? maybe take only the revised definition of the current hex0? ("loose")
<avih>(i want to fix the shell script)
<rickmasters>stikonas: it works fine with bash 2 rebuild commented out.
<stikonas>all the way to Linux kernel?
<stikonas>ok, let's disable it for now
<stikonas>there is probably a way to workaround it but let's get fiwix work done first
<stikonas>(i.e. yacc that we built early in the bootstrap did manage to build bash's parser
<rickmasters>stikonas: yes it builds linux
<rickmasters>stikonas: I'm willing to look into the bison problem down the road a bit.
<stikonas>let's merge it first...
<rickmasters>stikonas: well, I've written the code to boot Fiwix off disk. Just need to make it work now.
<Guest34>janneke yeah, I mailed for subscription. As I'm a newbie can you tell where should I start from
<Arghadeep_Saha>Same here can anyone tell me where to start from
<stikonas>if you want to work on mes, janneke or ekaitz might tell you
<stikonas>though mes is not the simplest stuff to begin with
<Arghadeep_Saha>so could you suggest some simpler task to begin with
<stikonas>maybe just start by building mes
<stikonas>see if you can run it
<stikonas>(there are various ways to build it, you could build it using gcc, but if you want more bootstrappable type experience, you could first try to build M2-Planet and then use it to build mes
<stikonas>we do have everything automated (e.g. this repo https://github.com/fosslinux/live-bootstrap/blob/master/parts.rst builds mes), but you could try running some of the steps manually
<Guest34>stikonas: thanks for your reply. Will try to implement it. Since I still don't know much about it. Thus, will take some time to study it and get some understanding.
<Guest34>will documentation be a good start?
<stikonas>yes, reading README files is always a good start
<stikonas>but again, if you want to look at mes, wait for janneke for more detailed advice
<Arghadeep_Saha>yes sure, thank you for your advice.
<stikonas>readme file of mes has some further links too https://git.savannah.gnu.org/cgit/mes.git/tree/
<janneke>hmm, that was fast
<ekaitz>stikonas: I love the way you guys think I know what I'm doing :D