IRC channel logs

2023-03-10.log

back to list of logs

<stikonas>well, oriansj is worried about UTF-8 control characters
<avih>(because \r without \n becomes ambiguous. it could end a comment on some systems, but keep the comment running on others)
<stikonas>that can make source look strange
<stikonas>i.e. text direction swaps and stuff like that
<stikonas>this shouldn't have been in UTF-8 in the first place...
<avih>i think it should be allowed
<avih>like in a c comment
<avih>or any other language really
<mihi>but I guess if RTLO only happens after the # sign, they will not be able to escape
<stikonas>well, these days editors try to ingore it
<avih>mihi: you should be worried about embedded terminal escape sequences before unicode control chars :)
<stikonas>and also about similar looking characters
<mihi> https://paste.debian.net/1273535/ will render unicode control chars, but no terminal escape sequences :D Also we can easily exclude 00-1F except \r \n \t. :)
<avih>how so, if they're only allowed in a comment?
<avih>(similar looking)
<stikonas>oriansj: what would АВ СЕ compile to?
<stikonas>well, in the comment it's fine
<mihi>stikonas, to nothing :)
<stikonas>yeah...
<mihi>all cyrillic
<avih>excluding 00-1F (sans \r\t\n), including inside comments, would be fine with me
<avih>outside of comment it's disallowed "already" (by what we described so far)
<avih>but i don't think it's disallowed in other languages, so i tend to allow anything in a comment, except lone \r
<avih>oriansj: in this https://github.com/oriansj/bootstrap-seeds/blob/master/hex0-alternatives/hex0.c i see that comment (and the line) ends on either \r or \n. is this common to other implementations? if not, it could lead to different behavior, e.g. in this c-string source: "AB CD #comment\r12 34"
<avih>an implementation which considers only \n as EOL will not end the comment till EOF, while your c code will end the commend and then output two more bytes
<avih>comment*
<stikonas>avih: actual hex0 only looks at \n
<stikonas>see this function https://github.com/oriansj/stage0-posix-x86/blob/master/GAS/hex0_x86.S#L112
<avih>stikonas: not here https://github.com/oriansj/bootstrap-seeds/blob/master/hex0-alternatives/hex0.c#L47
<stikonas>no, not there
<stikonas>but C is high level language
<avih>so these implementations may produce different outputs for the same input
<stikonas>so it's qutie different
<stikonas>yes, C version would produce different output
<avih>well, the implementation is different, the behavior shouldn't be different
<avih>but that
<avih>but that's good that we're finding these issues.
<stikonas>well, I guess remove \r from hex0.c
<stikonas>even my UEFI version of hex0 ignores \r and only looks at \n
<avih>actually, i was thinking to allow \r as if it was \n everywhere
<stikonas>but that's extra check in small hex0 implementations
<avih>it's actually simpler to implement, and i think it's highly unlikely to find existing hex0 files with \r in them which, if replaced with \n, would produce different output
<stikonas>now we have
<stikonas>cmp al, 10
<stikonas>jne purge_comment
<stikonas>but if you allow both \r and \n
<stikonas>logic is much more complicated
<avih>i see
<stikonas>checking for one thing is much easier
<avih>i don't disagree
<stikonas>now it's 4 bytes
<avih>but for the strict case, it would have been easier to interpret \r as if it was \n. but since the reference hex0 doesn't do that (not looking at you, c code), the strict spec must also only consider EOL at \n
<stikonas>supporting both \n and \r is probably 8..
<stikonas>I personally find even two types of comments a bit overkill...
<avih>well, that ship has sailed
<stikonas>I guess...
<stikonas>though it's not hard to update files
<stikonas>well, on x86 2nd type of comments costs us 4 bytes
<avih>stikonas: of the existing hex0 files which you're familiar with, how many would break if a strict hex0 compiler is used? (comment only at end of the line, even number of hex digits per line outside of a comment)
<stikonas>none
<avih>good
<avih>and if only even number of hex digits per token is allowed?
<avih>(just for info, we did agree to allow it)
<avih>(agreed to allow odd, that is)
<stikonas>still none
<avih>interesting.
<stikonas>but we do need arbitrary whitespace
<stikonas>i.e. no AB CD EF, it could be ABCD EF
<avih>not sure i follow.
<avih>(the "but" part)
<stikonas>a lot of files would break if you insisted on separating pairs of bytes
<stikonas>but we agreed not to require that
<avih>nono, i meant if we only allowed tokens with even number of digits, e.g. 12 or 1234 or 123456 etc
<avih>but not 12 3 4
<stikonas>oh, this thing
<stikonas>probably knight stuff would break
<avih>right
<stikonas>maybe armv7l (though it's not done yet)
<avih>yeah. we did agree to allow 12 3456 7 8
<stikonas>but even number per line
<avih>yes
<avih>i'm really glad that we could come up with something which is considerably stricter for the purpose of detecting source errors, while still practical enough that the existing hex0 files are still valid in this mode.
<avih>stikonas: what does the non-c hex0 does with a dangling last nibble? ignores it?
<stikonas[m]>I think so
<stikonas[m]>It exits on EOF
<avih>right
<avih>is this about right spec for loose mode? https://0x0.st/Hia1.txt
<stikonas[m]>Yes, seems right
<avih>stikonas[m]: oriansj: https://0x0.st/HiaO.txt
<avih>added strict mode. loose remains the same text as the prev link. this can be refined, but i think it should be reasonably good
<avih>probably need to make it clearer that loose mode ignores a sole final digit for the whole file (not per line)
<avih>and s/odd even/odd/ :)
<oriansj>avih: replace 'a line can't have an odd even number of hex' with 'a line can't have an odd number of hex'
<oriansj>and I'll fix the .c code to conform to the clarified spec we have discussed today
<oriansj>in an odd twist https://archive.org/details/byte-magazine-1976-03 on page 55 they had an article on hand compiling one's assembly programs to hex
<oriansj>classic rules like: only 1 instruction per line; keeping track of label addresses and which address your instruction is on for hand calculating displacements.
<oriansj>oddly tracking the number of clock cycles each instruction takes (but I guess it mattered back then)
<oriansj>well for once in my life I am at a loss for words: https://lists.reproducible-builds.org/pipermail/rb-general/2023-March/002904.html
<oriansj>they actually think building a kernel on a POSIX system with TCC is the samething as bootstrapping TCC and their kernel and it is "source only"
<muurkha>perhaps they have different objectives; it isn't clear from that message what they are
<muurkha>they're vulnerable to a Karger–Thompson attack in the form of a malicious kernel; they may not have thought of this, possibly because they are not attempting to defend against a Karger–Thompson attack
<muurkha>Or maybe they think they can be sufficiently safe from such an attack by doing builds on multiple different kernels and comparing them?
<muurkha>I'm not sure what the advantage of that approach over diverse double-compiling is, though
<oriansj>good pointand in good faith I should seek clarification
<muurkha>Maybe it would be better if someone else sought it for you, since this person seems to be already very defensive toward you
<oriansj>possibly
<oriansj>I did think calling our work "misdirected efforts" quite rude
<muurkha>yeah, they probably activated defensiveness in you too
<oriansj>I definitely admit that is likely
<oriansj>but I know building a shared understanding is usually the better course of action as odds are other people probably know something you don't.
<oriansj>On the off chance, it is wasted effort on a troll or moron; I am not yet sure of a good heuristic to determine if it isn't worth the effort to better understand the other.
<muurkha>I've learned a lot trying to understand trolls and morons
<muurkha>usually without being very successful, of course
<muurkha>I mean Socrates was 100% troll, right?
<oriansj>I give Socrates a 30% troll rating based on what I read but that number could be completely off
<oriansj>and trolls do come in many diffferent varieties
<oriansj>some are helpful, some insightful and some really reduce stressin the environments in which they operate.
<oriansj>Others however are best ignored as they tend to work to kill collective action and non-zero sum benefits
<muurkha>well, nobody ever accused Socrates of reducing stress or increasing social cohesion
<muurkha>Today I discussed the potential of atmospheric hydrogen with a flamer troll
<oriansj>well Socratic method did bring some groups of people together but accused might be too strong of a word perhaps
<muurkha>she came up with the same quantitative conclusions I did (like 120 MJ/kg for hydrogen and 5-10 J/m³ for atmospheric hydrogen) but also called me a "simp pajero", a "chaval", and an "aplaudidor adulón"
<muurkha>this was on Fecebutt; our mutual "friend" blocked her after her insults got to be too much
<muurkha>I'm not sure how to translate these insults
<oriansj>interesting thought of collecting hydrogen from the atmosphere as an energy source; doesn't sound like it would have a good EROEI
<muurkha>well, it turns out that there's a large community of bacteria that can live this way, at least in spore form
<oriansj>neat
<muurkha>the paper we were discussing was about an enzyme newly isolated from Mycobacterium smegmatis
<muurkha>so we were discussing to what extent this could be a useful energy source
<oriansj>and at what scale for what EROEI
<muurkha>right
<oriansj>would be the points I would be most interested in
<muurkha>EROEI doesn't really matter for profitability unless it gets really close to 1
<muurkha>it turns out that the available power in this form is on the order of 200 gigawatts, so the business could be worth tens of billions of dollars a year
<muurkha>if people were doing it instead of soil bacteria
<oriansj>well industrial civilization as we know it doesn't do well with an EROEI ofless than 10
<muurkha>I'm skeptical of that claim
<muurkha>final energy consumption is less than half of primary marketed energy production (say 7 terawatts vs. 14 terawatts)
<muurkha>that is, we waste half the energy we produce already
<oriansj>fair enough
<oriansj>but I prefer to spend only a fraction of my time on collecting energy to allow me to spend more time on other civilization building activities
<muurkha>if you have a power plant complex that produces 100 megawatts of net output, does it matter if it's producing 101 megawatts of total output and using 1 megawatt internally, or 200 megawatts of total output and using 100 megawatt internally? it looks the same from the outside
<muurkha>but in the first case it has an EROEI of 100, and in the second case it has an EROEI of 2
<oriansj>and depletes the finite supply of energy a good deal faster
<muurkha>in fact it might be the same power plant analyzed at two different levels of abstraction
<muurkha>sure, if we're talking about a nonrenewable energy source like fossil fuels, but not in the case of wind, solar, fusion, or this speculative atmospheric hydrogen thing
<oriansj>Total EROEI vs steam EROEI; does one include the production of the plant and the energy uses of the workers paid by the plant etc
<muurkha>the picture starts to look very different if we're talking about an EROEI of 1.1 or 0.9 though
<oriansj>well if one wants to be pedantic no energy source is renewable as the sun too will eventually run out of fuel
<muurkha>sure, eventually we will run out of baryons to drop into black holes
<oriansj>it'll just take a *very* long period of time assuming we don't exceed super linear growth.
<muurkha>exceeding superlinear growth sounds impossible
<muurkha>I mean, any possible growth function is superlinear, unless it fails to exceed linear growth, right?
<oriansj>infinite growth exceeds superlinear
<muurkha>I think infinite growth would be superlinear
<muurkha>unless it's infinite linear growth or infinite sublinear growth such as O(√x)
<oriansj>or O(x/0)
<muurkha>that's not growth at all, that's just undefined
<oriansj>I think a good few people call that the singularity but yes in the more pure standard math sense, you are absolutely correct
<muurkha>a singularity is a point where a function is undefined, but that's a "function" that fails to be defined for any x except (conventionally) x = 0
<muurkha>or, well, a Landau symbol for one
<muurkha>a "pajero" is a vulgar term for a man who imposes his sexuality on women; by describing me as a "simp pajero" she was arguing that my giving our mutual "friend" any attention was merely flattery aimed at attempting to manipulate her (the mutual friend) into having sex with me
<muurkha>there are terms for "adulón" in English, but I forget most of them. It means someone who habitually offers disgustingly insincere flattery
<muurkha>it was really a very nasty attack on our mutual "friend", only insulting me peripherally
<muurkha>oh, and a "chaval" is a prepubescent
<oriansj>muurkha: well perhaps I missed some meaningful context but I don't how being the target of insincere flattery would be an insult
<oriansj>^how^see how^
<muurkha>well, the context was, "Pelaste la cartita de victima articulada y centrada ante los giles de pelambre de colores coleccionistas de trastornitos y ansiedades que tenes por adulones! Chavala... si el rasero de los aplaudidores adulones y simps pajeros que buscas para apuntalarte la autoestima son esos... esta claro que no estoy a la altura... ya sabes que botoncito tenes que clickear."
<muurkha>which, uh...
<muurkha>"You pulled out the card of articulate and centered victim in front of the idiots with multicolored long hair ...
<muurkha>those collectors of mental disorders and anxieties you have for bootlickers!
<muurkha>Little girl... if the standard of the applauding bootlickers and simps who just want to fuck you, if they're what you're looking for...
<muurkha>it's clear I'm not at their level... you already know what button you have to click."
<muurkha>oh, "to shore up your self-esteem"
<oriansj>sounds like a pretty vanilla "I'm better than you" shit talk
<muurkha>well, our mutual "friend" is indeed articulate, and certainly has lots of friends with mental disorders and multicolored hair, is conventionally pretty, and regularly performs at public events like poetry readings
<muurkha>and she does receive a lot of praise, because her work is good, and that's important to her
<muurkha>so the point of the attack is to make her doubt all that praise
<oriansj>well mental disorders is a pretty broad term; often used far beyond what medically would be classified as a mental disorder. Heck, Just last week I was called a retard and a "naive socialist" for spending my own money to help homeless people get a good meal.
<muurkha>an anarchist, I suppose, because a Communist would instead apply pressure on the state to feed them
<oriansj>well as a government employee, technically the state's money (my wage) is feeding them
<muurkha>haha
<oriansj>oh, they argued that homeless people didn't provide value to society so they deserved to "die as quickly as the market allows"
<muurkha>clearly this is a person working from a fundamentally different value system than I am
<muurkha>I mean, it's not that we have disagreements about the best way to achieve a basically compatible vision of a good society
<muurkha>I wonder if they assumed you were working from the same value system? If not, the accusation of mental disability makes no sense
<oriansj>I am an atheist and they were "deeply Christian" and I dared to suggest feeding the poor was the Jesus like thing to do.
<oriansj>^were^??are??^
<oriansj>^were^claim to be^
<muurkha>On the other hand, I don't know what kind of mentally disabled reasoning they would think could justify the course of action you were taking, starting from their values
<oriansj>I had a hard time figuring that out honestly. Their rant was so weird. It included a block were I was accused of being a homosexual (to which I just smiled and my wife openly laughed)
<oriansj>I was called a "nigger lover"; to which I expressed that my wife was multi-racial and such terms are generally impolite in conversation.
<muurkha>Maybe rather than reasoning they were just free-associating
<oriansj>it went on for like 40ish minutes; with very little responding on my behalf
<muurkha>Wow, that's a term I don't think I've ever heard of anyone using in real life before
<muurkha>Or even in fiction in the current millennium
<oriansj>Well the creator of TempleOS used it a few times but he was suffering from extreme mental illness
<muurkha>This person may have been as well
<oriansj>possibly, hard to tell sadly given the state of American politics
<oriansj>actually, let me revise that. hard to tell sadly given the current state of discourse that I have observed over the last 3 years; outside of healthy communication groups such as this one.
<muurkha>communicating is hard
<avih>oriansj: stikonas[m]: mihi: (and anyone else) loose and strict hex0 input specs, and rationale for strict. comments are welcome
<avih>oriansj: yeah, i noticed odd even too. maybe it's a thing!
<avih>right, and a link :) https://0x0.st/HiBA.txt
<avih> https://0x0.st/HiMa.txt <- fixed typo, added one rationale item. final for now. i'll be waiting for comments.
<AwesomeAdam54321>avih: It's great that hex0 input specs are documented, I didn't know that there's a strict and loose mode
<avih>AwesomeAdam54321: there's not. loose is what exists today. strict is whjat we're considering adding, and this is the draft desription of the current (loose) and strict modes
<AwesomeAdam54321>* documented as a draft, sorry
<AwesomeAdam54321>I don't have much to comment on since it looks good to me
<avih>thx
<avih>(that's the best possible comment! ;) )
<oriansj>avih: in the strict mode definition, I believe you mean '\n' insteadof '\r' for the line starting with: Outside of comments, only
<avih>no. i meant \r. note that each bullet here refers to one line after striping the final \n
<avih>"For each line, after removing the final '\n', if any: ..."
<oriansj>I thinking more of the case of \n\n\n where the programmer just opts for extra whitespace between blocks
<avih>oriansj: not sure i follow. is there anything specific you think should be changed at the draft?
<oriansj>avih: I was attempting to express not all \n will be at the end of line comments as there will belines with only the \n character or the \n and other whitespace but no hex digits
<avih>agreed. and you think the draft does not allow it?
<avih>i.e. i'm trying to grasp what you think is wrong or missing or should be changed at the draft. i don't quite get it
<avih>i think you mean that this implies there must be hex digits at the line? "The remaining sequence of hex digits is processed same as in Loose mode."
<avih>i can add "if any" if you think it's more appropriate, but in loose mode, where it's described in more details, it already says that
<rickmasters>fossy: qemu on the master branch is not working. The linux change mixed up sys/run.sh and sys/run2.sh.
<rickmasters>fossy: Were you planning on doing the bash 5 revert? Maybe you could address the linux issue at the same time?
<Guest34>Hi Everyone, I'm applying for GSoC 2023 and was searching through many projects. Thus, I came across GNU Mes which interested me a lot. I just want to know how can I start contributing to it and write my proposal for the same.
<muurkha>Awesome!
<oriansj>avih: fair enough
<oriansj>Guest34: The person you would find most helpful is janneke as he is the primary author and he probably has a few things he would like help on.
<janneke>Guest34: that would be awesome, you are welcome to write to bug-mes@gnu.org
<janneke>Guest34: before you start doing any work, plesae note that Mes has several feature branches as work in progress that need to be merged the coming months (wip, wip-x86_64, wip-riscv, wip-guile-module ...)
<janneke>*finished, tested thourougly(!) and merged, of course
<gforce_de1977>fossy: rickmasters: i think its this issue: https://github.com/fosslinux/live-bootstrap/issues/259 ("
<gforce_de1977>[linux-4.9.10] ./scripts/gen_initramfs_list.sh: line 313: gen_init_cpio: command not found
<doras>By the way, our latest release tag (freedesktop-sdk-22.08.9) was bootstrapped from live-bootstrap. It was pushed to production on Flathub two days ago :)
<gforce_de1977>doras: cooooooool!
<rickmasters>gforce_de1977: yes, same issue. The mod to change the get_init_cpio path should have been made to run2.sh.
<rickmasters>gforce_de1977: But there is another change pending to revert creating run2.sh so those issues are interconnected.
<gforce_de1977>fossy seems busy - maybe the weekend is better 8-) lets keep calm and drink a tea
<stikonas[m]>doras: nice! Though probably most people wouldn't spot that in release notes
<doras>stikonas: I guess that's true, especially considering we have the freedesktop-sdk-binary-seed project in-between the two. Our release notes aren't too useful in general though.
<doras>If I had a blog I'd write about it, but I don't. I may do a talk on this at Linux App Summit 2023, if my abstract is accepted.
<avih>oriansj: right. but i will add "if any" to make it clearer. thanks.
<avih>any comments on draft specification of the hex0 input format: loose (current spec) and strict (suggested new mode): https://0x0.st/Hi1F.txt
<avih>oriansj: updated ^
<doras>stikonas: maybe live-bootstrap (and its use by freedesktop-sdk) could have a mention at https://bootstrappable.org/projects.html
<stikonas[m]>Possibly
<stikonas[m]>Though I can't edit that page
<doras>It looks like its source code is here: https://git.savannah.gnu.org/cgit/guix/bootstrappable.git/
<avih>oriansj: fwiw, that's my C implementation for loose and strict modes https://0x0.st/Hijq.txt
<oriansj>stikonas: that would be rekado who can update that site
<avih> https://0x0.st/HijM.txt fixup in strict mode (detect odd hex digit at the final line without final \n)