IRC channel logs

2023-02-08.log

back to list of logs

<oriansj>Christoph[m]: looking at the uFork architecture, it looks like someone rediscovered the TI-990 architecture
<oriansj>but then again, it isn't surprising given its most common form was the TI-99/4A where they didn't even have an editor, assembler, or hardware technical information available...
<stikonas>such a strange bug... https://github.com/fosslinux/live-bootstrap/issues/239
<stikonas>somehow call to kaem ended in help2man
<oriansj>is perl guessing the shell based on running processes?
<stikonas>unlikely...
<stikonas>I was more thinking of accidentally reading the wrong file
<oriansj>and getting only the start of the line?
<stikonas>oriansj: start of the line is probably make
<stikonas>it only prints command that is being executed
<stikonas>e.g. if that line somehow ends in shebang
<stikonas>anyway, hard to tell without anybody actually reproducing that state and examining it
<stikonas>there enough information to tell what exactly might have happened
<stikonas>oriansj: so now that we have a changelog, maybe once you have enough spare time it's worth tagging new releases?
<oriansj>stikonas: probably a good idea
<stikonas>at least I haven't seen any serious issues recently
<stikonas>(there are some issues in AArch64 but they are not new regressions)
<stikonas>and x86 is extensively tested in live-bootstrap anyway
<stikonas>fossy: maybe try adding "-s" to LDFLAGS to reduce size?
<stikonas>or do we want to have some debug info?
<fossy>stikonas[m]: hmm let me give that a try
<fossy>stikonas[m]: hgue difference if we strip
<fossy>hmm, wonder if we should consider adding a stripping hook to the end of src_install?
<rickmasters>stikonas: I know the reason for the help2man bug
<rickmasters>stikonas: and I have a fix
<fossy>rickmasters: what's the cause? its very strange
<rickmasters>The help2man.PL file is extracted after help2man.1 from the tar file and
<rickmasters>if the seconds of the current time changes between the two, then make will trigger a rule which uses help2man
<rickmasters>but the shebang has not been fixed yet
<rickmasters>The solution is to add "touch help2man.1" before running make in help2man-1.36.4.sh
<rickmasters>I spent quite a while debugging that problem a few weeks ago.
<rickmasters>I was behind on reporting it. It was on my to-do list.
<rickmasters>It happened during Fiwix testing where it occurred much more frequently because I/O is a little slower.
<rickmasters>But recently I ran into it during a normal chroot build (without Fiwix).
<rickmasters>I ended up adding an "ls --full-time" before running make and noticed it only happens when the files in question have different seconds in their mod time
<rickmasters>I mean, that's how I eventually figured it out
<rickmasters>Another solution would be to modify the Makefile.in to fix the shebang at the end of the $(target) rule.
<rickmasters>Then, if the man page $(target).1 needs to be regenerated, then help2man will have a fixed shebang.
<rickmasters>Anyway, I'm signing off. I'll be around tomorrow and can provide more info if needed.
<fossy>oh, that is so strange
<fossy>very smart though
<stikonas[m]>fossy, you can try, just (of course conditionally on strip being installed)
<stikonas[m]>Though ldflags might be easier
<stikonas[m]>src_install would need automatic detection of files to strip
<rickmasters>fossy, stikonas: I provided a more detailed explanation of the help2man problem and a direction on how to fix it properly:
<rickmasters> https://github.com/fosslinux/live-bootstrap/issues/239#issuecomment-1422887205
<stikonas>thanks!
<rickmasters>You're welcome. I don't know enough about how perl was built to fix it properly, but the workaround has been solid for me.
<stikonas>rickmasters: I can try a proper fix, it might be just adding -Dstartperl='#!/my/shebang' to makefile (to CPPFLAGS) would fix it and remove the need for shebang fix
<rickmasters>Yes it's worth a try. I'm assuming you mean: -Dstartperl='#!/usr/bin/perl" -Dperlpath='/usr/bin/perl'
<rickmasters>stikonas: fixing the quotes: -Dstartperl='#!/usr/bin/perl' -Dperlpath='/usr/bin/perl'
<stikonas>yeah, I can try it later in the evening
<stikonas>should be easy to test, first remove the workaround, build should fail
<stikonas>then try to add those defines
<rickmasters>stikonas: I took the liberty of testing a makefile fix since I finally found the perl makefile
<rickmasters>stikonas: it didn't work so I dug deeper and finally found the right solution
<rickmasters>stikonas: the variables need to be defined in sysa/perl-5.6.2/files/config.sh
<stikonas>rickmasters: oh good
<stikonas>rickmasters: do you want to make a PR?
<stikonas>or should I finish it?
<stikonas>you already did most of the work, so I would hope it's not too much extra work to finalize it
<rickmasters>stikonas: I don't mind. There will be at least a couple checksum changes.
<stikonas>that's expected
<stikonas>at least perl and help2man
<stikonas>possibly more
<stikonas>but you can get most of them automatically with --update-checksums
<rickmasters>stikonas: yeah. Hopefully just those two. I also tested triggering the man page rule (with touch help2man.PL) and that worked.
<stikonas>that will ignore checksum checking and then at the end you can just run sha256sum in /usr/src/repo
<rickmasters>stikonas: ok
<rickmasters>My test included removing the shebang fix and all is well so far.
<stikonas>I think that's sufficient
<oriansj>rickmasters: great detective work