IRC channel logs

2023-01-26.log

back to list of logs

<stikonas>fossy: so python 3.11 seems to work fine as static build
<stikonas>though it does expose some missing dependencies that would be nice to have (shared build was also missing them)
<stikonas>i.e. we don't have readline
<stikonas>strictly speaking not required for bootstrap, but probably not hard to add
<fossy>stikonas[m]: how did you come up with the Setup.local file? it'd be good to comment at the top of the file how it was moddified
<nektro>is there a way to avoid programs from trying to call 'build-aux/git-version-gen: No such file or directory' ?
<stikonas[m]>fossy: I uncommented Setup file
<stikonas[m]>Left some stuff that we can't build yet commented out
<stikonas[m]>uuid had compiler error
<stikonas[m]>Either gcv or util-linux might be too old
<stikonas[m]>nektro: can you give more context
<fossy>stikonas[m]: alright
<doras>stikonas: Python modules are dlopen'd, I think. Or at least this was my impression at the time and one reason to add add musl with dynamic linking support to live-bootstrap.
<stikonas>doras: no, you can build them statically
<stikonas>I've already created a PR
<stikonas>and I was able to import modules of that build on glibc system
<doras>stikonas: so you link with all built-in modules statically?
<doras>I'm confused a bit
<stikonas>indeed
<doras>stikonas: I see some modules that are commented out. Does this mean that the static Python 3.11 is not feature-complete like the dynamic one?
<stikonas>no, it's just missing dependencies, dynamic modules were also missing those
<stikonas>at least in most cases (not sure about uuid)
<doras>We started relying on Python provided by live-boostrap a few days ago. I worry that this change could break something :s
<stikonas>doras: could you try to run a test on that branch?
<stikonas>we can wait before merging
<stikonas>though I did quite a few tests locally
<stikonas>didn't find any problems
<doras>stikonas: https://gitlab.com/freedesktop-sdk/freedesktop-sdk-binary-seed/-/merge_requests/26
<stikonas>ok, let's see
<stikonas>and hopefully there are no problems with live-bootstrap itself
<stikonas>I only built it once
<stikonas>need to re-run it to double check reproducibility
<doras>I guess we'll find out :)
<doras>It takes around ~4 hours to run live-bootstrap end-to-end in our CI.
<stikonas>my laptop is now maybe 2.5 hours
<doras>It highly depends on the load on the build machines.
<stikonas>(after all this python stuff was added)
<doras>We have a bunch of stuff being built in parallel on the same hardware, so CPU and IO resources for CI jobs are shared.
<doras>Our aarch64 build machine is much faster and far less loaded than our x86_64 build machine, by the way. It could most likely run live-bootstrap in less than 1 hour if it supported native bootstrap of an aarch64/arm system.
<doras>It completes a build of all of freedesktop-sdk in around 2.5 hours.