IRC channel logs

2023-01-11.log

back to list of logs

<fossy>doras, stikonas[m]: when i last touched sources, my primary goal was removing duplicates of the same information
<fossy>previously we had the source information in rootfs.py and in source files
<fossy>which made for 1. really annoying workflow 2. really easy to miss differences
<fossy>i am not really opposed to having some kind of manifest, or chaning up the representation of sources, but i don't want that to come at the expense of having duplicates of the same information
<fossy>regarding the separate issue of it being an implentation detail, i do think that it is a good idea to have a more general output such as from rootfs.py, even if it is just cat sys*/*/sourcesinternally, it helps for future expansion
<doras>Thanks fossy,, so I think we are aligned. I have no intention of duplication of course.
<stikonas[m]>fossy: before we merge Python stuff, maybe we should think about dependencies between packages?
<stikonas[m]>before shared libraries, all packages were self-contained
<stikonas[m]>now e.g. python would depend on musl
<stikonas[m]>and it's still possible to use it on random system, but it needs a bit of preparation
<stikonas[m]>so e.g. for python, you need to extract musl package, then prepare /usr/bin -> /bin and /usr/lib -> /lib symlinks, then unpack Python package and then you can run e.g.
<stikonas[m]>bwrap --bind /path/to/extracted/dir / python
<stikonas[m]>might be a bit nicer if we can remove symlinking step...
<stikonas[m]>(possibly by explicitely adding symlinks in musl package)
<stikonas[m]>and then it would be good to store dependency metadata somewhere (doesn't have to be in tar.bz2, it could be separate)
<stikonas>fossy: so one way in which python is not reproducible, it encodes kernel version
<stikonas>i.e. plat-linux5:lib-tk vs plat-linux4:lib-tk
<stikonas>diffoscope shows stuff like
<stikonas>│ │ │ - 0x080d6490 006c696e 75783500 322e302e 3100252e .linux5.2.0.1.%.
<stikonas>│ │ │ + 0x080d6490 006c696e 75783400 322e302e 3100252e .linux4.2.0.1.%.
<stikonas>this should be not too hard to fix