IRC channel logs

2023-01-07.log

back to list of logs

<stikonas>fossy: I saw some of your recent commits. Good that we have support for early preseed now
<stikonas>though maybe we also need to document some of that development workflow somewhere
<stikonas>(possibly outside the main readme file)
<fossy>stikonas[m]: yeah, i should add some documentation
<fossy>thanks for the reminder, too, i need to update parts.rst for python
<fossy>i'm really close to PR. just cleaning up patches, etc
<fossy>i'm not really sure what's going on with my linter setup. probably differing versions, but my shellcheck wasn't picking up on that change
<fossy>pylint and reuse were my bad :p
<stikonas[m]>good to hear that python PR is almost done
<fossy>ok, i have pushed (no parts.rst, qemu unvalidated)
<fossy>absolutely no rush with review. it is a MASSIVE pr
<stikonas>nice
<stikonas>+2700 in diffstat, so not super bad to review
<stikonas>I guess the hardest thing is reviewing pregenerated files
<stikonas>though can be easily missed
<stikonas>fossy: so on QEMU I've only got to Python 2.0.1 (#1, xx/xx/xx, xx:xx:xx)
<stikonas>oriansj: did you have any further thoughts what to do with string functions in M2libc?
<stikonas>oriansj: I'm looking at adding getenv() to M2libc but it's implementation might also need stuff like strlen
<stikonas>I could add a private copies like _strlen
<stikonas>but it's a bit ugly
<stikonas>I guess fundamentally that's because M2libc is used as source library, whereas other C libraries are usually compiled as a whole unit
<stikonas>fossy: and bwrap mode has different checksums for me too
<stikonas>so there is probably still something specific to your kernel
<stikonas>ok, just finished switching from Gitea to Forgejo, now I can go back to finishing getenv
<stikonas>fossy: https://stikonas.eu/files/bootstrap/Python-2.0.1_0.tar.bz2
<stikonas>might be useful for you if you want to find differences
<stikonas>ok, I've implemented getenv for x86, amd64, aarch64, riscv32 and riscv64.
<stikonas>oriansj: would you be willing to do it for knight? I think I've at least added enough, so that it compiles and rest of the stuff works
<stikonas>oriansj: https://github.com/oriansj/M2libc/pull/44/files
<stikonas>argh, setenv will also need a copy of strcpy