IRC channel logs

2022-11-25.log

back to list of logs

<oriansj>or do char[2]
<oriansj>or we can finally add int16 support to M2-Planet
<stikonas>I can indeed do char[2]
<stikonas>adding uint16_t is probably not hard but I doubt that we care about those fields
<stikonas>it's just for getting offsets of other struct elements right
<stikonas>I basically need to just get file size
<stikonas>which I need for lseek
<stikonas>which is a requirement for stdio.c
<oriansj>well if we don't care about the 16bit fields, then we can continue to ignore int16 and just use byte arrays to pad the space cheaply.
<stikonas>oriansj: lseek is not supposed to update FILE structure?
<stikonas>it's only fseek's responsibility
<stikonas>or am I misreading docs
<stikonas>I guess I'm right, at least POSIX version also doesn't touch FILE
<stikonas>and my hex2 is starting to work... Though I need to implement a bit more stuff
<stikonas>before I can push M2libc changes
<stikonas>for some reason stdout is completely broken
<stikonas>oh and stdout was just return on the wrong line
<stikonas>oriansj: https://github.com/oriansj/M2libc/pull/22
<stikonas>hmm, there is one last problem before amd64/bin/M1.efi can be built...
<stikonas>"amd64/bin/M1.efi can not be opened!"
<stikonas>I guess on file writes we should create parent directories...
<oriansj>well that would definitely be unique to UEFI
<oriansj>and merged
<stikonas>yes, but shouldn't be too hard to implement
<stikonas>I think mkdir in UEFI is just opening file"
<stikonas>so jus need to loop over all parents
<stikonas>indeed, creating a directory is just opening a file with EFI_FILE_DIRECTORY attribute: https://github.com/tianocore/edk2/blob/master/MdeModulePkg/Library/FileExplorerLib/FileExplorer.c#L1097
<stikonas>should be easily doable in M2libc and hidden from applications