IRC channel logs

2022-11-14.log

back to list of logs

<stikonas>even M2-Planet code with blood-elf footers is a bit hard to debug... I'll probably have to extract relavant bits of malloc/free code to a separate file buildable with gcc to debug remaining issues...
<stikonas>I guess one can improve M2/blood-elf to spit out more debug info but that's a much larger project
<stikonas>building with gcc was a useful exercise... Just compililng caught some bugs and things seems to be working better
<muurkha>great!
<oriansj>stikonas: well blood-elf was orginally a quick hack to create the bare minimal amount of debug information and that is where the improvements would be (unless they needed information from the C code itself in which case we would need to figure an information passing method between M2-Planet and Blood-elf that doesn't impact M1 or hex2)
<stikonas>oriansj: anyway, I think I now have a working free implementation
<oriansj>very nice
<stikonas>it's fairly simple and goes only part-way (for now it never reduced brk) but at least it reuses freed space
<stikonas>I'm not fully convinced yet that it is bug free
<stikonas>but stage0-posix seems to work
<stikonas>so might be good enough for review
<stikonas>I've used that very simple first fit free list, it migt not be as good as that buddy or slab allocator but very simple
<stikonas>even then I had to adapt quite a bit to M2 dialecct
<oriansj>well if you are worried about the free logic having bugs, we can always set a -D variable to disable that bit of logic
<stikonas>or in case of bugs we can debug them later. Still stage0-posix working means it's not fundamentally broken
<stikonas>we do have some free statements there
<stikonas> https://github.com/oriansj/M2libc/pull/19
<oriansj>I'd rather have your possibly broken code stikonas, than some of my coworker's "working code" as yours tends to have less bugs and problems
<oriansj>merged
<oriansj>I'll give it some testing later today to see if I can find some bugs in it
<stikonas>thanks
<oriansj>thank you for driving M2libc forward ^_^