IRC channel logs

2022-10-22.log

back to list of logs

<stikonas>oriansj: hmm, I think I might need some UEFI specific behaviour in cc_amd64 and M2-Planet
<stikonas>oh, actually this might be envp issue...
<stikonas>maybe if I push envp=NULL onto stack that will fix depth of local variables
<stikonas>yes, that does the trick
<stikonas>ok, "M2.efi --help" now works
<stikonas>I think I'm only missing fopen/fclose
<stikonas>though that is still quite a bit of work
<oriansj>depends entirely if you plan on dealing with UTF-16 files (probably not worth the trouble as we could write a simple UTF-16 to ASCII converter)
<Hagfish>getting to M2 sounds like a significant milestone, well done. i hope fopen/fclose goes smoothly so that the hard work can be even more appreciated
<stikonas[m]>oriansj: no utf-16 names...
<stikonas[m]>My converter for load options just removes every second zero
<stikonas[m]>And for fopen I guess I'll do reverse, insert zeroes between all chars
<stikonas[m]>Oh files themselves are ASCII too
<stikonas[m]>Don't think we need utf-16
<oriansj>good, it was a terrible encoding to choose anyway
<oriansj>and multi-string support in M2-Planet actually enables a new and rich possiblity for making better --help messages
<oriansj>eg: https://paste.debian.net/1257908/
<oriansj>(not in things needing to be built by cc_* but otherwise we should be able to put extra love in the user experience)
<stikonas[m]>oriansj: doesn't cc_* support multilinear strings too?
<stikonas[m]>At least asm blocks seem to use multi line strings
<mihi>stikonas[m], fossy: Anyone seen "sha256sum: WARNING: 1 computed checksum did NOT match
<mihi> | gc-8.0.4.tar.gz: FAILED" with live-bootstrap? This was running on GitHub CI, so I cannot inspect the actual files...
<mihi>I will probably rerun this later and see if it happens again.
<stikonas[m]>mihi: bad download? Maybe rerun and see if it is one off
<oriansj>stikonas: that is correct, that is only inside of asm for cc_* because assembly was easy to just dump into the output but gluing together strings in other cases is a good bit more complex
<oriansj>mihi: either bad download (very unlikely if running on GitHub CI) or the file changed (Possibly by GitHub messing around with compression)
<stikonas[m]>Compression shouldn't change upstream tarball
<stikonas[m]>That's not git archive package
<mihi>stikonas[m], seems to have been a one-time fluke (not only github servers to blame but also www.hboehm.info or anything in between). I now changed my CI job to upload distfiles as github artifact so I can examine the files if they ever have incorrect checksum again.
<mihi>However, I'm fighting a bit with how live-bootstrap propagates distfiles and repo-preseeded to sysc in chroot mode. Currently I patched helpers.sh sys_transfer so that it moves them over. But probably I broke something else that did it when trying to split it up into four steps of less than an hour each.
<stikonas[m]>mihi: repo-preseeded might be broken...
<stikonas[m]>I haven't tested it after fossy's changes
<stikonas[m]>Distfiles are only relevant in --external-sources mode, then they are copied in sys_transfer if I remember correctly