IRC channel logs

2022-10-19.log

back to list of logs

<oriansj>janneke: The way that is done in M2libc is: #define EOF 0xFFFFFFFF
<oriansj>as 32bit values are signed extended to 64bit on 64bit architectures
<oriansj>M2-Planet does support negative literals just fine; just #DEFINE in M2-Planet is a bit hacky
<oriansj>rickmasters: __M2__ is actually defined in M2-Planet and M2-Mesoplanet in the preprocessor to enable alternate code paths for GCC and M2-Planet (And other C compilers such as MesCC)
<oriansj>literally line 49 of cc.c
<oriansj>init_macro_env("__M2__", "42", "__INTERNAL_M2__", 0); /* Setup __M2__ */
<oriansj>we do similiar things in later lines; such that if one does --architecture riscv32; we get init_macro_env("__riscv", "1", "--architecture", env); and init_macro_env("__riscv_xlen", "32", "--architecture", env + 1);
<oriansj>enabling architecture specific behavior
<oriansj>clemens3: any more details about what commands were executed to bring it to exactly that state?
<janneke>oriansj: ok, thanks
<janneke>gus
<janneke>(oops)
<janneke>oriansj: i created some silly fixes to allow using m2-planet-1.10.0 with stage0-posix-1.4
<janneke>=> https://gitlab.com/janneke/stage0-posix/-/tree/v1.4
*janneke tried to upgrade to stage0-posix-1.5 in Guix, but couldn't get it to build at all
<clemens3>oriansj: ./configure && make
<clemens3>I can provide versions installed, if I know what to look for, or upload config/log files..
<oriansj>janneke: all I get is an infinite looping checking your browser prompt; so I guess I'll have to take a look when I get a minute later.
<oriansj>clemens3: ouch; I am guessing the guile version probably matters
<ekaitz>oriansj: I also have issues entering gitlab... it supports just few browsers and it's a pain in the ass
<muurkha>aggi: your connection is broken and you are flooding the channel with joins and quits
*muurkha /ignore aggi join quit
<stikonas[m]>and I'm getting HTTP 404 after signing in for that janneke's fork of stage0-posix
<stikonas>janneke: any chance you still have error from the latest stage0-posix?
<mihi>fossy, stikonas[m]: zlib update broke live-bootstrap: https://github.com/fosslinux/live-bootstrap/issues/209
***stikonas_ is now known as stikonas
<oriansj>janneke: and thanks for the reminder that I need to finish the stage0-posix port to armv7l
<vagrantc>i am ... a bit confused about the arm and arm64 status of mes ...
<vagrantc>i tried building the debian package on arm64, and i get: platform not supported: aarch64-linux-mes
<vagrantc>but the release announcement for 0.24.1 claims the ARM bootstrap uses aarch64?
<vagrantc>does the gcc build of mes not support it at all?
<vagrantc>janneke: could you help me wrap my head around that stuff? :)