IRC channel logs

2022-10-08.log

back to list of logs

<muurkha>agreed, that's the idea of the Cuneiform Tablets paper by Nguyen and Kay; have I not recommended it to you?
<oriansj>I have read it
<oriansj>the Chifir virtual machine is certainly something a possible host for stage0
<muurkha>yeah, it would work for that; its fatal flaws wouldn't come into play
<oriansj>but my thought was a CPU one could specify using only basic logic gates on a single sheet of paper (and a few pages explaining the basic logic gates)
<muurkha>I think the nand2tetris "Hack" CPU could probably fit on a single sheet of paper that way; have you seen https://nandgame.com/?
<muurkha>it guides you through 27 hardware design exercises, in each of which you build a component from more primitive components (either relays or something you'd already built)
<muurkha>none of them require assembling more than 8 components
<muurkha>you could imagine dividing an A4 sheet of paper into 35 blocks of 42 × 42 mm, each a diagram of one of the 27 levels (or blank)
<muurkha>the 26th level is "computer", with a CPU (levels 25 and 21) capable of executing instructions, and RAM and ROM
<muurkha>I think Chuck Thacker designed a 1-page CPU in Verilog for VPRI at some point
<stikonas>strange, still can't find out what's wrong with my cc_amd64.M1 Anyway, I pushed wip broken version for now...
<stikonas>hmm, looking at bytes, might be something wrong with type structures
<stikonas>especially negative offsets...
<stikonas>finally got cc_amd64 to work in UEFI
<stikonas>had "mov_rax,[rip+DWORD] %global_token" rather than "mov_rax,[rip+DWORD] %global_types" in one place
<stikonas>now it seems to be able to build M2-Planet
<stikonas>(for POSIX)
<stikonas>well, at least size of M2.M1 seems fine, I didn't check contents
<stikonas>oh, actually the size is still wrong I was a bit too quick... it's missing 40 KiB or so at the end...
<stikonas>so probably one more bug...
<stikonas>but should be easier to debug now
<stikonas>ok, now I think all fixed...
<stikonas>oriansj: so while debugging this, I've also created relocatable version of cc_amd64.M1 for posix
<stikonas>oriansj: are you interested in using it in stage0-posix or should we keep current version
<stikonas>(this new version that I have also has gas style defines)
<stikonas>oh, just found a bug in M2libc defines that somehow didn't break anything
<stikonas> https://github.com/oriansj/M2libc/blob/main/amd64/amd64_defs.M1#L48
<stikonas>this one is rdx, not r10
<stikonas>given that nothing is broken, I guess r10 is not needed