IRC channel logs

2022-09-28.log

back to list of logs

<stikonas>fossy, mihi: MAN_PAGE_DATE somehow is not working in live-bootstrap, though I'm completely lost why is that
<stikonas>it does seems to work if I run make command manually with MAN_PAGE_DATE set
<stikonas>so maybe some strange interaction with helpers.sh?
<stikonas>argh, figured it out... manpages were recreated during make install phase when I did not have MAN_PAGE_DATE set
<pabs3> https://niconiconi.neocities.org/posts/ken-thompson-really-did-launch-his-trusting-trust-trojan-attack-in-real-life/ https://news.ycombinator.com/item?id=33008519
<muurkha>thanks! I had misremembered some aspects
<lanodan>Looked a bit among distros and ports, is Guix the only one that actually bootstraps rust?
<sam_>(I wish we as in Gentoo did it, but no time yet. :()
<sam_>(same for openjdk, although stikonas has an overlay for that)
<lanodan>Well I'm trying to bootstrap it on gentoo and it's pain
<stikonas>well, my overlay has mrustc bootstrap too
<stikonas>though it might be currently a bit broken due to gcc bug
<stikonas>(probably fixed in 12.2.0 though)
<stikonas>lanodan: have you tried my overlay?
<stikonas>also rust ships with some pre-built binaries
<lanodan>Yeah, I'm looking into it, updating the recipe to 1.54.0 (mrustc-0.10) so I end up compiling less versions
<stikonas>that neither Guix builds, not I had time to remove
<lanodan>I have a tool to remove all binaries: https://hacktivis.me/projects/deblob
<stikonas>lanodan: yeah, I tried that at some point earlier but hit https://github.com/thepowersgang/mrustc/issues/266
<sam_>my gut is that a better bet is to do a huge rustc chain
<sam_>mrustc seems too new for now
<sam_>idk
<lanodan>Well should take less time to try a new one than to compile 10+ versions ^^
<sam_>yeah, fair point
<stikonas>sam_: huge rustc chain?
<stikonas>you mean from the very first versions not written in rust?
<sam_>yes
<stikonas>that chain is even worse
<stikonas>you would have to bootstrap ocaml too
<stikonas>which I think was done for one version (so might be doable)
<stikonas>but it takes ages to run
<sam_>oh, ocaml contains binaries?
<sam_>i didn't think it did
<stikonas>it might be byte code
<stikonas>I don't remember exactly
<sam_>understood anyway, I'll keep this possible issue in mind
<stikonas> https://github.com/Ekdohibs/camlboot
<sam_>you know far better than I on this matter
<stikonas>I haven't really looked much into ocaml
<stikonas>also on Gentoo building old rustc versions is really painful
<stikonas>as you don't have old dependencies anymore
<stikonas>(e.g. old versions of openssl)
<sam_>we could handle stuff like that if needed
<sam_>although ideally would be able to slot openssl properly
<stikonas>yeah, in principle this is solvable
<stikonas>but right now downgrading openssl would break everything
<sam_>(i guess we could really in theory slot it just enough to give a hint to rust, no need to make it workable with everything on system)
<stikonas>oh, and prebuilt files in rustc can be removed with this snipped https://git.stikonas.eu/andrius/gentoo-bootstrap/issues/2
<stikonas>though I still need to test it
<lanodan>Would need to make an openssl-compat with the headers, AFAIK that's not in the current ones and might be a bit broken if it doesn't properly uses pkg-config
<stikonas>and early versions of rust had to rebuild more frequently than once per release
<stikonas>you coulnd't build rust n+1 with rust n in early stages
<stikonas>lanodan: anyway, if you get 1.54 working, merge requests would be appreciated...
<sam_>lanodan: we could make it work as long as we had some way for Rust to find the headers/libraries
<sam_>lanodan: the nice thing is that we don't have to make sure everything works
<sam_>just Rust and maybe a handful of other things
<sam_>but yeah, pkg-config would be the way ofc
<stikonas>and possibly at some point gcc will also have rust frontend
<stikonas>so that might also be useful for building rustc
<sam_>I had a request from someone to poke at testing libgccjit with hppa but not had time yet
<sam_>it is a winter job as the machine is hot
<stikonas>though I'm not sure if they are targetting bootstrapping (it might still depend on cargo)
<sam_>i believe they are