IRC channel logs

2022-09-25.log

back to list of logs

***ChanServ sets mode: +o janneke
<stikonas>ok, finally figured out why M0.S UEFI prototype was not working
<stikonas>turns out I need to explicitely zero allocated memory
<oriansj>stikonas: sounds about right; M0 as written doesn't null terminate strings but lets the default null value do the termination.
<stikonas>anyway, it's just 5 lines of asm code to zero it out
<stikonas>there is even UEFI function to do that but I didn't bother and just zeroed it myself
<stikonas>oriansj: 16 MiB of memory should be enough for M0?
<stikonas>I guess the biggest thing we build is M2-Planet
<stikonas>well, M2-0-0.M1 in stage0-posix is 1.3 M
<stikonas>so I think with some overhead for other things, 16 MiB should be sufficient. And if not, I can always revisit it
<oriansj>well the amount of memory needed would be approximately 4x the size of the source code itself (so we have a big safety margin)
<oriansj>so yeah 16MB should be more than enough
<stikonas[m]>Well, for simplicity I just allocated single 16MiB block and "malloc" function then just keeps track of "malloc" pointer but does not actually do any request
<stikonas[m]>Otherwise, it gets hard to clean up after ourselves at the end if you request individually
<oriansj>completely fair
***Andrew is now known as haxcpu
<stikonas>ok, getting closer to autogen in live-bootstrap though there are 3 reproducibility issues that we need to solve (but I think I now understand all of them)
<stikonas>date in manpages, temp path in generated files and one constant (default timeout) in autogen depends on time needed to execute configure script.
<stikonas>fossy: I've opened draft PR https://github.com/fosslinux/live-bootstrap/pull/206
<fossy>:D
<fossy>i'll review tomorrow, i'll check autogen-bootstrapping a little more thouroughly (superficial checks revealed no problems)
<stikonas[m]>Well, I was going over compiled C files and looked at all includes
<stikonas[m]>So no issues were found
<stikonas[m]>At least in bootstrap stage
<stikonas[m]>Though, more thorough look at rebuild stage might be useful
<rickmasters>oriansj: thank you for fixing memcmp
<oriansj>rickmasters: I help when I can. (I really need to get better about tracking my backlog)
<mihi>stikonas, your answer did not arrive here before I sent mine. So you don't need to answer to my email again if you don't want to. But good to know that I seem to recall correctly :)
<stikonas>mihi: but I couldn't find an email, so it was probably somebody else who emailed Bruce Korb
<mihi>if you still have chatlogs, perhaps you have more luck finding the answer in there?
<mihi>if not you, then probably it was fossy :)
<stikonas>yes, probably fossy...
<stikonas>I don't have chatlogs locally
<stikonas>and in unrelated news, I'll soon have M0 for efi ready
<mihi>\o/
<stikonas>and then there are still 2 reproducibility issues in autogen...
<mihi>2 more ones, or the two you already wrote about in the issue?
<stikonas>mihi: no same ones...
<stikonas>I just didn't have time to look at it yet
<stikonas>was working on M0.efi
<mihi>me neither :)
<mihi>there will be a week after this one :)
<stikonas>so one should be sed'able
<stikonas>and the last one probably needs patch to configure.ac.pre
<mihi>yeah, wanted to write the same.