IRC channel logs

2022-09-22.log

back to list of logs

<oriansj>interesting, the same font in the same terminal with the exact same settings resulted in different behavior in regards to: ⚙
<oriansj>and it took 4 weeks of fuzzing but there was another segfault found in M2-Planet
<ekaitz>I have a set of patches that bring RISC-V support for Mes's fork of TinyCC, but when I build it with Mes it basically outputs broken files
<ekaitz>when it's built with GCC it works pretty well
<ekaitz>with broken files I mean: output files have no permissions (---), the architecture is not written properly... and so on
<ekaitz>any idea of what can it be?
<stikonas[m]>Libc issues?
<stikonas[m]>Something is #ifdefed and stub is used instead?
<muurkha>ekaitz: sounds like maybe a bug in Mes?
<ekaitz>stikonas[m]: good points!
<ekaitz>muurkha: I don't think it's a bug in mes, because this project is compiled with Mes too in other contexts and it works (without the riscv backend)
<ekaitz>maybe I'm loading the wrong libc?
<ekaitz>but that should have compilation errors, shouldn't it?
<muurkha>sometimes compiler bugs generate subtly wrong code in some contexts but not others
<ekaitz>muurkha: this is not subtle, it's everything broken :D
<muurkha>well, I meant "subtly wrong" in the sense that the executable is still a valid executable and it doesn't even crash with an illegal-instruction exception
<muurkha>the compiler executes successfully, its output executes successfully too, but it just does the wrong thing
<muurkha>it's possible that you're right that it's not a bug in mes too
<ekaitz>muurkha: I understand, now yeah