IRC channel logs

2022-09-06.log

back to list of logs

<stikonas>doras: I've very briefly looked at your PR, I think it looks good but I'll do a more thorough check later (once I'm back home). Could you also fix linter error. It's doesn't seem related to your commits (probably linter got upgraded) but it would be good to have green CI tick in that PR
<stikonas>anyway, nice work! And probably prerequisite for building GCC 10 or so...
<Hagfish>wow, we're thinking about gcc 10 already? that's so cool. at this rate of progress, people will soon be bootstrapping software that hasn't even been written yet :P
<stikonas[m]>New GCC is not hard to build once you have some GCC
<stikonas[m]>It's not like rustc or openjdk where all intermediate versions have to be built
<stikonas[m]>I guess because C/C++ actually have a standard implemented by multiple compilers
<muurkha>:D
<sam_>yeah, gcc doesn't raise that std very aggressively at all
<sam_>(the one itself is written in, anyway)
<sam_>until 12 iirc it was c++98
<oriansj>well Hagfish if we keep growing as a community at our current rate, we should be able to achieve some extremely ambitious bootstrapping goals in the next couple years.
<oriansj>at which point we will have designed our own hardware, bootstrapped all major Linux and *nix distros and had a working bootstrap path for all major programming languages.
<oriansj>but sustaining that growth rate seems unlikely
<oriansj>(but I definitely could be very very wrong)
<Hagfish>i look forward to the day that major tech companies routinely hire a "Chief Bootstrapping Officer", whose role involves periodically checking that their entire software stack can be bootstrapped from punchcards or similar
<Hagfish>well, that's a bit extreme, but i'd settle for big companies devoting a fraction of their hardware budget into helping to fund fabs that make open hardware
<Hagfish>that helps mitigate against monoculture, and AI risk, and the growing problem of society not understanding its own tools
<aggi>Hagfish: it's ordinary "system integration" work meeting "minimum acceptance criteria"
<aggi>including a reproducible bootstrapping path
<aggi>and, concerning recent gcc-versions (later than gcc47), it's rather challenging to _avoid_ those compilers and software components which locked against them
<aggi>such as linux kernel, which bumped compiler version requirements, and nowadays requires a c++-compiler (gcc49 or llvm)
<aggi>avoiding C11 is another such issue, because C11 seems only fully implemented by c++-compiler (compilers written in c++ with related issues of bootstrapping them)
<unmatched-paren>i think cproc implements c11
<unmatched-paren>mostly
<unmatched-paren>there are a few features blocked on QBE features (VLAs come to mind)
<aggi>unmatched-paren: noted. however, i am not aware of any free software system which can be fully compiled with such a compiler (toolchain)
<sam_> https://github.com/oasislinux/oasis :p
<aggi>besides, tcc-toolchain contains more components than the compiler: linker, assembler, ar-utility
<aggi>and with this tcc-toolchain, i already got 99% of the entire userspace compiled/linked
<aggi>except for libc and kernel
<aggi>gcc is only required for kernel still, and binutils for musl-libc
<aggi>and uboot-loader (aarch64) is a trouble source with it's build-time dependencies (python/swift/c++)
<aggi>this morning, i'll finally tag and archive both the gcc47 c-only toolchain system profile, and the tcc-toolchain devdrop build
<aggi>i am not sure yet, if i will proceed; in any case the _freeze_ and archival were necessary, i'll not dispose what i already got
<aggi>the libc and kernel issue are concerning, and so far i had not received any relevant feedback for contracting with anyone
<aggi>furthermore, a self-hosting system-integration excluding python/portage utilities is unavoidable
<aggi>because i consider python-bootstrapping (libffi assembly) troublesome
<aggi>the tcc-toolchain package set already does contain all necessary development utilities to proceed with a self-hosting system-integartion
<aggi>however, for this i need to re-implement/migrate the package-management from gentoo-portage to void-xbps or suckless slpm or similar
<aggi>before this, i would verify mes-libc bootstrapping, to compile/link a toybox userspace with
<aggi>can't proceed without appropriate contracting
<aggi>sam_: oasis contains some other interesting proposals, such as bearssl/bearssl-libtls, which i already integrated with my irc client for testing
<aggi>which is another todo, to fully replace libressl with bearssl
<rickmasters>markjenkinssksp: this looks somewhat related to your efforts, in case you hadn't seen it: https://c9x.me/yacc/
*acrow waves at vagrantc
*vagrantc waves
<Hagfish> https://www.sifive.com/press/nasa-selects-sifive-and-makes-risc-v-the-go-to-ecosystem "NASA Selects SiFive and Makes RISC-V the Go-to Ecosystem for Future Space Missions"
<Hagfish>i wonder which will be the first planet that only has bootstrappable Free Software on it :)
<Hagfish>it would be nice if the first supply ship that Elon sends to Mars has an open chip fab on it
<Hagfish>if he really wants his colony to be self-sufficient, he'll need that
<vagrantc>wow
<civodul>exciting