IRC channel logs

2022-09-05.log

back to list of logs

<oriansj>wait
<oriansj>find . -iname '*.[cpp|cxx|cc]' -print | less is finding .c files too
<sam_>let's see
<sam_>maybe i did regex wrong in find
<sam_>i only tested it a tiny bit, sorry :)
<sam_>(I tried out some C++ project, saw the -j1, and tested some C, which looked like it did -j$(nproc))
<oriansj>find . -iname '*.cc' -o -iname '*.cpp' -o -iname '*.cxx' -print | less seems to be working however
<oriansj>and there does seem to be exactly 1 .cc file for linux under scripts/kconfig/qconf.cc
<sam_>bit irked that regexy stuff doesn't work there
<sam_>not sure why that would be
<oriansj>bug in find?
<oriansj>the latest version: https://paste.debian.net/1252764/
<doras>stikonas, fossy: PR for binutils 2.38 and libtool 2.4.7: https://github.com/fosslinux/live-bootstrap/pull/191
<doras>Next maybe an attempt at musl shared library support.
<doras>But likely not soon.
<oriansj>thank you doras
<Hagfish>that commit message is like poetry, in that it's a joy to read (although fortunately not as ambiguous as poetry) :)
<Hagfish>what's the expression? "the test of whether you really understand something is if you can explain it to someone else"
<Hagfish>something like that (and i'm sure there are exceptions/limits to that heuristic)
<Hagfish>but yeah, i think that good documentation/comments are a force-multiplier, because they save other people from having to guess or assume things
<Christoph[m]><oriansj> "find . -iname '*.[cpp|cxx|cc..." <- find -iregex '.*\.\(cpp\|cxx\|cc\)'
<Christoph[m]>does the job.
<Christoph[m]>* find -iregex '.*\\.\\(cpp\\|cxx\\|cc\\)'
<Christoph[m]>does the job.
<Christoph[m]>There's (supposed to be) a single backslash to escape the second ., the (, the |, and the ).
<Christoph[m]>The unescaped . matches any character, and the \\. matches only the period.
<Christoph[m]>[acb] matches a, b or c, in regexp and in shell pattern, which is what -name and -iname use.
<Christoph[m]>In regexp, the star * allows zero or more repetitions of the match directly in front of it. In contrast, in shell patterns, * matches any string including the empty string. The shell pattern * is .* in regexp.
***AndrewYu is now known as Andrew
***Noisytoot_ is now known as Noisytoot
<oriansj>Christoph[m]: thank you for that ^_^
<markjenkinssksp>I haven't kept up with chat logs. I've made some headway with my wierd attempt to work around the yacc bootstrap licensing problem
<markjenkinssksp>I'm very close to being able to generate LR(0) automaton, a step before doing LALR(1), a snapshot is at https://gist.github.com/markjenkins/70b97f3fc25adcb647f02ce7e88f7af2
<markjenkinssksp>I don't know if anyone else will ever want to do bootstrap work in my sublox1 sub-variant of Lox, its the horrible marriage of javascript and lisp style linked lists as the only data structure
<markjenkinssksp>but I do very much like the idea of having a memory safe, imperitive, types at runtime kind of language
<markjenkinssksp>as early as possible in bootstrap
<markjenkinssksp>after I boostrap sublox1 variant and use it to solve the yacc licensing problem, my goal is to bootstrap sublox2 and eventually full Lox with extensions, and from there try porting other programs written in inperative style like M2-planet
<markjenkinssksp>but I get way away of myself, all of this will take a long time
<markjenkinssksp>or TCC, I'd like to port that to a language that's imperative, memory safe, doesn't deal with types at compile time, bytecode interpreted
<markjenkinssksp>and bootstrappable (of course)
<oriansj>markjenkinssksp: neat
<markjenkinssksp>oriansj, I'm trying to remember, was there a C++ compiler someone wrote that could compile some of GCC written in C++, wasn't bootstrapable, was perhaps using a yacc implementation of it's own as well in doing so
<markjenkinssksp>have looked through the bootstrappable wiki
<markjenkinssksp>and done too many web searches today
<oriansj>markjenkinssksp: I believe that would be the GCC C++ compiler written in C but I don't think I heard of anyone doing any more with yacc than the use of heirloom devtools in live-bootstrap
<markjenkinssksp>I'm thinking of something that was more of a hobby project that I thought was out there
<markjenkinssksp>I'll re-find it eventually and use github star next time
<oriansj>possibly, it is hard to keep track of everything even with notes
<oriansj>plus not everyone keeps people here updated on their progress until they do a big announce like the builder-hex0 work which literally came from left field and is looking like it will enable us to do kernel work with TCC.
<rickmasters>Hello from Left Field!
<rickmasters>I have just finished pushing my updates to github for the
<rickmasters>the boot2now and builder-hex0 kernel.
<rickmasters>The boot2now project assembles all the sources and feeds it to the builder-hex0 kernel
<rickmasters>in multiple stages to build (and run) tcc.
<rickmasters>Both projects are located at https://github/ironmeld.
<rickmasters>github.com I mean
<rickmasters>boot2now is the main project and uses builder-hex0, stage0-posix, and live-bootstrap as git submodules.
<oriansj>rickmasters: I think we now can officially state we are on a new level of bootstrapping thanks to you ^_^
<rickmasters>oriansj: yes, it's official. It took almost 2 weeks to clean up the commits but its all there now.
<oriansj>well worth the wait
<oriansj>and definitely worth being sent to the mailing list
<rickmasters>oriansj: I'll work on a mailing list announcement, but it might be a day or so.
<oriansj>completely fair
<rickmasters>I'm heading to the Mariners game soon for a night of R&R
<oriansj>sounds well deserved ^_^
<oriansj>have a great time
<rickmasters>Thanks, a beautiful 72 degree sunny Seattle day awaits
<Hagfish>i look forward to reading that mailing list post