IRC channel logs

2022-08-16.log

back to list of logs

<aggi>tried something: CC|LD|AR|AS=tcc, and all others NM|OBJDUMP|READELF=/bin/false
<aggi>and compiled/linked the entire package set... none required any additional from the binutils/elfutils
<aggi>meaning tcc can fully replace binutils(elfutils)/gcc and llvm
<aggi>tcc offers a sufficiently complete toolchain to maintain an entire linux distribution
<aggi>including it's cross-compiler capabilities, which is amazing
<Guest77>Hi! According to http://bootstrappable.org/projects/jvm-languages.html "Some preliminary work has already been done" regarding a Scala bootstrap. Where could I find the code? Or a better first question: What is actually the plan?
<Guest7785>Stupid web IRC client… I was Guest77 just before… :-|
<Guest7785>I was also thinking about how to bootstrap Scala as this would be a clean way to get it into Debian.
<Guest7785>The other (and much simpler and faster) option would be some "Psy-OPS": Just telling the Debian people that it would be OK to pull some more BLOBs, as everything else that is important is coming from BLOBs anyway. But maybe it would be time to break the circle.
<Guest7785>So if someone has put work into a Scala bootstrap I would be happy to hear their ideas.
<Guest7785>I would share mine.
<Guest7785>BTW: I'm a Scala developer, so I have no problem working with that code or the stuff around it.
<Guest7785>So could anybody tell me to whom I need to talk further?
<Guest7785>Thanks in advance for taking time to answer my questions! :-)
<Guest7785>I've searched the mail archive now also for info about Scala. But noop, nothing.
<Guest7731>I now also found and searched the IRC logs for anything regarding Scala. But again, noop, nothing useful. (I was Guest7785 before. Ultra crappy web IRC client, dies all every few minutes…)
<Guest7796>Oh, found something: https://bootstrapping.miraheze.org/wiki/Bootstrapping_Specific_Languages
<Guest7796>But the search facility on this site is broken. If you search for "scala" (or "scala") nothing appears…
<Guest7796>Let's see whether this makes any sense what this dude is doing.
<Guest7746>I've found this here: https://framagit.org/tyreunom/scabo
<Guest7746>But now I'm puzzled.
<Guest7746>The README says: "Our goal is not to have readable source, so the end result would be fine with us."
<Guest7746>WTF?!
<Guest7746>Isn't the whole point of bootstrapping that you have some sources that are auditable?
<Guest7746>And the next sentence makes also zero sense: "The issue is that .class files are the result of compilation... by the scala compiler."
<Guest7746>What "issue"?
<Guest7746>If the sources are readable there is no "issue".
<Guest7746>If the sources aren't readable, _that_ is an issue OTOH.
<Guest77>The only point I agree is that decompiling the Scala JARs doesn't work. I've also tried that. (The result is that you would to manually tweak thousands of .java files, which contain anyway very messy code).
<Guest77>The only point I agree is that decompiling the Scala JARs doesn't work. I've also tried that. (The result is that you would need to manually tweak thousands of .java files, which contain anyway very messy code).
<Guest77>But producing readable .java files form the original sources with the help of the original compiler _would be_ an viable way to get this off the ground, imho.
<Guest77>Would you accept something like that?
<Guest77>Or what would be the objectives?
<Guest77>At least I don't see any cause why something like that should get rejected.
<Guest77>What do you guys think?
<Guest77>But actually who cares. I don't see any interest here for that topic at all, so I think I'm leaving again.
<Guest77>Maybe the Debian dudes want to listen…
<oriansj>Guest77: well, not everyone is online all of the time.
<oriansj>that being said, progress on bootstrapping specific languages is always related to the individuals who choose to do that work. If they go off the rails, we can learn from their work but we can't use it as it isn't bootstrapping work.
<qyliss>oriansj: they're gone already :(
<oriansj>also looking at the scabo readme, the bit about readability seems to be related to generated .class files not the code itself
<oriansj>also it's last commit was in 2019 and it is in an unfinished state
<pabs3>IIRC the published scabo work isn't the latest either, the author has some newer stuff that isn't published
<pabs3>(the author is roptat, they are here occasionally)
<oriansj>fair, just I can only use code that people make publicly available. Otherwise how else could others build upon, audit or improve upon my work.
<oriansj>aka if the work isn't public and independently varified; the language isn't actually bootstrapped yet.
<pabs3>indeed. would be nice if roptat would work in public, at least on a draft branch
***mattx is now known as mateusz
<oriansj>heck, even a scratch_rebase branch which can be nuked at anytime for any reason would atleast give a hint that if someone else might need to pick up the work or if it is still moving smoothly forward.
<stikonas[m]>yes, it's better to publish something even if it is not fully working
<aggi>sam_: FYI ... slibtool related; slibtool calls a function slbt_archive_import_child
<aggi>this is not compatible with AR=arm-tcc-ar or AR=eu-ar, seems only supported by binutils-ar
<aggi>this problem is only hit when AR!=binutils-ar and prevents bootstrapping without binutils