IRC channel logs

2022-07-31.log

back to list of logs

<stikonas>Magnesium9117: now the website is HTTP 404
<stikonas>I guess guix is slowly bringing back their infrastructure
<Magnesium9117>nice
<stikonas>but you can probably learn more if you ask questions here rather than looking at website anyway
<stikonas>and I'm getting close to finishing kaem-optional.efi
<stikonas>still need to add a bit of code but it's mostly just linear stuff with no branches, so shouldn't be too hard
<oriansj>well the hardest thing to remember about UEFI seems to be make sure everything can be relocated in memory. So cc_* is gonna see a boatload of PC relative addressing being added. I'll probably have to figure out a clean way to do it in M2-Planet
<Spawns_Carpeting>I have a quick question, how would it be best to communicate to somebody that something isn't bootstrappable.org bootstrappable if it relies on auto generated C files that are not human readable
<pabs3>a pull request deleting the files and setting up a proper bootstrap :)
<Spawns_Carpeting>lol
<pabs3>which project is it?
<Magnesium9117>what is kaem-optional.efi?
<Spawns_Carpeting>gambit scheme, I am in their gitter channel thing and talking about bootstrapping gambit, but they are claiming that gambit is bootstrappable (but it relies on 100,000s of lines of generated C files)
<Spawns_Carpeting>i would consider massive amounts of autogenerated C source to not count as bootstrappable
<pabs3>its definitely not bootstrappable.org bootstrappable, but they might be using some other definition (such as "binaries of it can compile its own source code back to binaries of it")
<Spawns_Carpeting>i have showed them the website but i dont think they actually looked at it
<pabs3>maybe ask them how to make yoghurt like the site does :)
<smlckz>what would be an easy and simple bootstrapping to do?
<stikonas[m]>Magnesium9117: that's port of kaem-optional seed from POSIX (Linux) to UEFI
<stikonas[m]>smlckz: depends on what you already know and what you want to learn
<stikonas[m]>live-bootstrap is fairly easy to get in with just some bash skills
<stikonas[m]>stage0 stuff is good if you want to learn lower level stuff, e.g. writing simple compiler
<stikonas[m]>Magnesium9117: kaem-optional is kind of simple non-interactive shell that reads a file with list of commands and executes them
<stikonas[m]>smlckz: mes/mescc project is another option, it uses C and Scheme
<Irvise_>Spawns_Carpeting: I have read your conversation in the Gambit Gitter channel
<Irvise_>I think this is something you would like to take a look at https://irvise.xyz/Blog/scheme-implementation-comparison.html
<smlckz>what is kaem?
<Spawns_Carpeting>Irvise_: thanks for that link!
<Spawns_Carpeting>the main reason i am interested in gambit is for gerbil scheme
<Spawns_Carpeting>gerbil is more like a racket type of scheme than a scheme, it has many extensions and has kind of went off into its own thing
<Spawns_Carpeting>it seems to be fairly niche though so far
<Irvise_>I see. I just added Gerbil a few minutes ago. I had not added it because it was an Scheme built on top of anoher Scheme, so rather pointless for my list.
<Irvise_>Yup, it even says it speaks Lisp x)
<Spawns_Carpeting>this website is very handy
<Irvise_>That is why I built it :P
<Irvise_>theruran and I are looking into bootstrapping Ada.
<Irvise_>That was the motivation
<Spawns_Carpeting>thats a very interesting idea
<Spawns_Carpeting>the first step of that would be an ada compiler written in a scheme?
<Spawns_Carpeting>scheme seems like the ultimate language for bootstrapping purposes since it can be implemented in a small amount of code
<Irvise_>That is our initial idea. I added Jim's TCL and Lua too due to their small size too.
<stikonas[m]>smlckz: kaem is just a simple shell to run other commands and automate things
<stikonas[m]>There are actually two of them
<stikonas[m]>One is with more features, cross platform and written in C
<stikonas[m]>And the smaller version is written in hex0, so needs porting to each platform
<stikonas[m]>And together with hex0 it is one of the two binary seeds
<stikonas[m]>(And kaem is anagram of make)
<smlckz>ahh
***bauen1_ is now known as bauen1
<jackhill>Irvise_: *waves* I was talking with theruran in another channel the other day, and am also intersted in bootstrapping Ada (among other interests!)
<Irvise_>jackhill: he told me about it. It is always nice to see more people interested in what we want to do :)
<Irvise_>Though it is still in the drawing board...
<oriansj>Irvise_: but it is a beautiful drawing so far
<oriansj>and it is nice to see people pushing the current bootstrapping boundaries forward.
<muurkha>Spawns_Carpeting: yeah, normally "bootstrapping" means the opposite of what we're doing here