IRC channel logs

2022-07-29.log

back to list of logs

<oriansj>ah, that is much harder to spot in hex0
<stikonas>well, I spotted it while doing amd64...
<stikonas>so can fix it
<stikonas>well, it's also harder to find during testing
<stikonas>cause things run just fine
<stikonas>(even for commands with non-zero exit status)
<stikonas>it's only crashing binaries that would be affected
<stikonas>ok, kaem-optional is done for amd64, now need to fix x86 version
<stikonas>oriansj: https://github.com/oriansj/stage0-posix-amd64/pull/5
<stikonas>(i'll do bootstrap-seeds later, together with fixed x86 version)
<stikonas>also https://github.com/oriansj/stage0-posix-aarch64/pull/3 for typo fix
<stikonas>oriansj: oh actually x86 kaem was not broken... I don't know why I was thiking that...
<stikonas>and https://github.com/oriansj/bootstrap-seeds/pull/25
<oriansj>stikonas: all three have been merged
<stikonas>thanks
<oriansj>I'd *MUCH* rather you to think something was broken and it is working fine than for something to be broken and you think it is working fine
<stikonas>well, it was actually broken in nasm prototype
<stikonas>but not in M1 or hex0
<stikonas>hence my confusion
<stikonas>but moving stuff in nasm is trivial
<oriansj>to a degree, until you try to do something messy
<stikonas>anyway, I think I'm done with hex0/kaem-optional in stage0-posix and can start porting kaem-optional to efi tomorrow...
<stikonas>once that is done, rest of the stuff up to cc_amd64 should be relatively quick
<oriansj>ideally, then we have M2libc enhancements to do and see if there is anything else special needed for M2-Planet
<oriansj>muurkha: my routine rant about the problem with Java: https://paste.debian.net/1248683/
<Spawns_Carpeting>has anyone here had any experience with various schemes like racket, guile, gambit, gerbil, etc?
<oriansj>Spawns_Carpeting: well we bootstrapped Guile
<oriansj> https://github.com/schierlm/guile-psyntax-bootstrapping
<Spawns_Carpeting>is there any info or work done with gambit by chance? I am talking to Marc Feeley and it seems like gambit relies on C files generated from the gambit compiler which creates the classic bootstrapping loop problem
<oriansj>and people from the Guix community are here as well so yes.
<Spawns_Carpeting>is the normal build of guile not bootstrapped purely from source? I was under the impression it was
<Spawns_Carpeting>(but i didn't do much searching about it)
<oriansj>Spawns_Carpeting: it depended upon a generated file (psyntax.pp) and we thus had to solve that to enable it to be properly bootstrapped. This is the sort of thing we usually tend to find in schemes and Lisps
<Spawns_Carpeting>oh I see now, I didn't realize that it relied on that. lisps seem to be extra bad about bootstrapping don't they!
<oriansj>well good scheme and lisp programmers tend to not like working in C if they can get away with it.
<oriansj>that being said now that Guile is bootstrapped, you can convert the scheme that generates those files to run on Guile and you would have that solved.
<oriansj>(assuming of course that guile and gambit scheme are not too incompatible)
<Spawns_Carpeting>thanks for the work done on guile to whoever contributed for sure!
<Spawns_Carpeting>thats a big step
<Spawns_Carpeting>I think in gambits case they are too incompatible but I'm not totally sure really. Getting information about this from the various communities has been a little tricky because the term "bootstrapping" seems to mean different things to people who don't know about bootstrappable.org bootstrapping
<Spawns_Carpeting>in gambits case, the default build process uses a standard c compiler to build C file that were transpiled from scheme source files with the gambit compiler
<Spawns_Carpeting>since those transplied C files are not human readable I don't think that really counts as "bootstrappable" in this specific context
<oriansj>Spawns_Carpeting: well very few people worry about bootstrappable in general, they mostly want the software and generally tend to be happy with binary blobs. So just having a process in place to generate those C files from scheme source reproducibly would be a good step in the correct direction. Once you have that, (assuming the Turing core is standard enough) you then have a straight forward path to getting it bootstrapped from any
<oriansj>other scheme interpreter available.
***WaxCPU is now known as Andrew