IRC channel logs

2022-07-07.log

back to list of logs

<oriansj>or if we wanted to be really ironic: make the vm just be a subset of x86 and Linux syscalls
<oriansj>the link for when I get the rest of the wiki up: https://wiki.bootstrapping.world/
<oriansj>well, these html files are going to need a cleanup
<stikonas>hmm, looks like command line passing in UEFI might be simpler if we break compatibility with UEFI shell
<oriansj>well we can certainly do that after kaem is running
<stikonas>since command line arguments is just a string, so we can make hex0 a bit smaller if we skip e.g. app name from command line
<stikonas>yeah, once we have kaem, or actually simultaneously with writing kaem...
<stikonas>then tokenization can be just: read line, find first space, part 1 is loaded image name, part 2 is options
<oriansj>well does the extra simplicity justify the incompatibility?
<stikonas>and then we can even use normal ascii string rather than UEFI wide chars
<stikonas>that's the question... I'm ot sure yet. Perhaps
<stikonas>because if we want to keep uefi shell working, we need to read tokens from kaem.run and convert them to wide chars. Probably not too hard
<stikonas>but it's hex0 code...
<stikonas>and UEFI already brings some overhead, e.g. file i/o API is trickier to use than posix
<stikonas>well, we can experiment a bit with .c prototypes
<stikonas>those are easy to edit, it's not hex...
<oriansj>yeah, more experimentation needed
<oriansj>but looks interesting
<oriansj>ok, some links are still broken but the majority of content is now here: https://wiki.bootstrapping.world/ and the sources are currently located here: https://github.com/oriansj/bootstrapping-wiki (until we setup a git server)
<oriansj>I'm taking a break for a few hours. Please take a took and find what I screwed up (patches are super welcome anyone who makes a pull request can get commit access to that repo)
<Hagfish>"Cookies help us deliver our services. By using our services, you agree to our use of cookies."
<Hagfish>incorrect :)
<Hagfish>perhaps it should be changed to: "When you use our services, we will put cookies on your computer unless you stop us."
<oriansj>Hagfish: F5
<oriansj>no cookies and no JavaScript
<oriansj>as everything was submitted as CC-BY-SA-4.0 I made that the default license of the repo
<achaninja>Hagfish: well - it is your browser that you installed that remembers and retransmits the cookies
<achaninja>so maybe if you didn't want cookies you should tell your browser not to do that
<Hagfish>achaninja: i'm not complaining that the site tries to use cookies, i'm just complaining that it tried to falsely claim what i agreed to :)
<achaninja>I think you did agree when you installed a browser that uses cookies automatically
<achaninja>just my opinion
<Hagfish>i see what you mean
<achaninja>not that we have much choice
<Hagfish>even if my use of a browser accepts the existence of a cookie, it doesn't necessarily mean i agree to the site's use of it
<Hagfish>yeah, the circumstances under which i agree might be too complicated to express programmatically
<achaninja>but its like - browsers do cookies automatically, and you clicked on a link - it is kind of a given that the website can request a cookie
<achaninja>I dunno how that doesn't count as agreeing
<Hagfish>but i didn't know how the site will use the cookie until i visit it and read their policy
<Hagfish>unless the policy is stored on a separate domain that doesn't have cookies, i suppose
<achaninja>hmm
<achaninja>its all terrible
<achaninja>:P
<Hagfish>but they'd have no way of knowing that i had visited that other domain :)
<Hagfish>yup :P
<Andrew>i feel like accepting the cookie is somewhat agreeing to the use thereof
<Andrew>(personally i don't use cookies unless necessary; my usual browser doesn't have cookie supprt even)
<Hagfish>it's like walking into a shop, and going to a cashier to ask what the shop's policy is on having buckets of water thrown over customer, only to be told that their policy is that anyone who walks in should get drenched
<Hagfish>"well you should have worn a rain coat and umbrella if you didn't want to get soaked"
<achaninja>Hagfish: yeah but i think you could do that if you wanted to
<achaninja>you would just get publicly lambasted and maybe sued
<achaninja>if you damage something
<Andrew>Hagfish: It's your own choice to use a browser that accepts cookies
<achaninja>Hagfish: technically when you walk into a shop you are getting filmed on security camera
<achaninja>i think thats more similar
<achaninja>and most people know and agree to that
<achaninja>they don't need to sign a form before entering
<achaninja>there was a youtube channel called
<achaninja>security camera man
<achaninja>who just walked into public places and filmed people
<achaninja>it made them very uncomfortable
<achaninja>- even though most places already have security cameras :P
<achaninja>I guess theres some sort of implicit consent around reasonable use
<achaninja>like the security camera footage probably isn't being compiled and sold like cookie data - i dunno
<achaninja>though security camera man was selling his footage to advertisers via youtube
<Andrew>It's still a bit different IMO
<Andrew>I mean, you can just not accept cookies
<Andrew>But that's harder with securit cameras
<achaninja>btw
<achaninja>maybe this has been linked
<achaninja> https://speakerdeck.com/nineties/creating-a-language-using-only-assembly-language
<oriansj>I think I pulled that out
<oriansj>as it wasn't on the wiki but it did get mirror'd
<pabs3>oriansj: I see you didn't import the history of the existing bootstrapping wiki?
<pabs3>(via git-mediawiki)
<oriansj>pabs3: well, no. I just did a wget -m to get the current contents
<pabs3>I see
<pabs3>also why .world instead of the existing domain bootstrappable.org?
<oriansj>pabs3: because I don't have the ability to edit those DNS records
<oriansj>I believe rekado does but honestly I don't know exactly
<oriansj>So I got a domain I could create entries for to just get the needle moving in the correct direction
<pabs3>I see
<oriansj>if later we change things and wiki.bootstrappable.org is created and so on: ok but this work needs to be done so we can finally stop caring if the current wiki gets deleted every month
<oriansj>we will have our wiki on servers we control and a domain we control; so that as long as things get paid for, they stay up
<oriansj>I can pay for the servers and the domain is prepaid for the next 10 years so we have time to play with it
<oriansj>think of bootstrapping.world as a place where we can do some crazy shit and if it turns out to be a good idea it goes into bootstrappable.org
<oriansj>My goal at this second is to make failure cheap
<oriansj>extremely cheap for failure on bootstrapping.world web services
<oriansj>so cheap we can all learn some things together
<pabs3>ok. I wonder how the repro builds folks do this, they seem to have a more cohesive setup
<oriansj>pabs3: well from what I have seen in most successful projects is there is a core group of people who know each other personally and there is some offline coordination about how things are to be done. bootstrappable is very different. There is no core, no offline coordination.
<oriansj>I have never met anyone here in person and the most conversation I had with spoken words with a fellow bootstrapper is a 8 minute signal call I had with janneke enough years ago that even signal doesn't even remember it.
<oriansj>Bootstrapping seems to have always been a solo adventure of discovery but somehow two bootstrappers ran into each other around the start of their respective journeys and this is what grew out of that.
<oriansj>everyone here is a rare gem
<oriansj>every act of cooperation and working together more precious than gold
<oriansj>There is no one nor group of individuals in charge. Anyone can carve out something to control by just doing the work. For example siraben setup this IRC channel so can decide who gets ops. rekado setup the website and he controls that as far as I am aware. heck, I'll point the git.bootstrapping.world at anyone's server who is willing to do the work
<oriansj>if you want control or authority, it is easy: do the work and ideally in a fashion that makes it easiest for someone else to pick it up and move it forward.
<oriansj>heck, I'm even paying for a server that anyone can request admin right on to do that work.
<oriansj>Just showing up here, means you are rare
<Hagfish>it's maybe remarkable that, despite the community growing, there haven't been "turf wars" with competing hostile forks. everyone just sort of fits in around everyone else
<Hagfish>maybe it's only in the hundreds of active committers that that starts to happen
<unmatched-paren>does it? never seen that happen
<Hagfish>well i've seen it happen even in small companies :)
<Hagfish>but i'm sure there are some big hostile forks in the free software community
<Hagfish>xfree vs xorg, etc.
<Hagfish>or even xorg vs wayland?
<Hagfish>clashes of vision
<unmatched-paren>xorg vs wayland certainly isn't a fork, let alone a hostile one
<Hagfish>sure
<unmatched-paren>many of the xorg developers want xorg to die
<Hagfish>is it a fork of the community?
<unmatched-paren>and some of them work on it
<Hagfish>maybe there are some people who find this project, then read/lurk a bit and find that the one thing they wanted to work on has already been done or "taken" by someone else
<unmatched-paren>Okay, xfree vs xorg was. But I think that was a rare exception
<Hagfish>so there's a survivorship bias in what i'm seeing
<Hagfish>uh huh
<unmatched-paren>And that was a while ago :)
<Hagfish>well, upstart vs systemd was another example, slightly more recent?
<unmatched-paren>Was that particularly hostile though?
<Hagfish>i still have the scars! :P
<unmatched-paren>Not exactly a turf war, just different choices :)
<Hagfish>and there's all sorts of wheel-reinvention in the javascript world
<Hagfish>sure, not "hostile", but competing visions to be sure
<Hagfish>i think oriansj would welcome competing visions though, and this project is flexible enough to accept many bootstrap paths
<unmatched-paren>competing visions (non-hostile) is a good thing imo :)
<unmatched-paren>Sure, but javascript is javascript
<Hagfish>hmm, maybe i should be disappointed there isn't more disagreement over the best bootstrapping path then
<Hagfish>friendly rivalry?
<Hagfish>faster exploration of the solution space?
<unmatched-paren>The latter is an excellent way to put it :) And maybe one project can't even fit in the entire solution space, and we need other competing projects to fit other areas
<Hagfish>maybe i should register strapbooters.org in advance, ready for the inevitable conflict :)
<unmatched-paren>en garde!
<Hagfish>over my dead domain name!
<unmatched-paren>take no chroot prisoners!
<mihi>did anyone ever try to run gcc-2.95's autoconf scripts using only tools bootstrapped with meslibc (i.e. no musl, no gash-utils)? I think I have all the dependencies (except cmp, but as I see it, it is only used for checking whether config.cache changed, so a trivial implementation should suffice), yet I get incomplete gcc/Makefile (ending after the line "###cross overrides").
<mihi>Or alternatively, did anyone succeed to build glibc with tcc (built against meslibc) and then tcc to use that glibc?
<mihi>(again, using autoconf scripts, if possible)