IRC channel logs

2022-06-27.log

back to list of logs

<oriansj>well it would only take a little more logic to make a hex keyboard that buffers a nybble and pushes only bytes to the computer.
<stikonas>well, those historical front panels were basically 8-bit keyboards
<stikonas>where you could use switched to toggle bytes into memory
<oriansj>I believe it was octal for the press keyboards and the flip toggles were the word size (which could be 12,18 or even 36bits)
<outside_of_World>anyone home?
<outside_of_World>looking for some c code to text cc_x86 on
<outside_of_World>./bin]vm/vm --rom cc_x86/cc_x86 --tape_01 cc_test --tape_02 test_Cout --memory 48K
<outside_of_World>Invalid state reached after: 134 instructions
<outside_of_World>524308: Writeout bytes Address_1 is outside of World
<outside_of_World>currently trying to build m2-planet
<outside_of_World>./bin]vm/vm --rom cc_x86/cc_x86 --tape_01 stage3/M2-Planet_x86.c --tape_02 tape02]OUTS/out_M2 --memory 48K
<outside_of_World>Invalid state reached after: 1428 instructions
<outside_of_World>524308: Writeout bytes Address_1 is outside of World
<outside_of_World>lfs.master@lfsmasters-MacBook-Pro CCXK]DEV]0002 %
<outside_of_World>any help would be appreciated
<outside_of_World>really confused cause i got all the right hashes building from vm to cc_x86 "1b44b454b8e7beab41ecc4fb81220ef0a396bfeb954a3589861b6807dea0c313"
<stikonas[m]>Already left chat...
<stikonas[m]>outside_of_World: if you read logs, try POSIX version if cc_x86
<stikonas[m]>s/if/of/
<stikonas[m]>outside_of_World: have you tried POSIX versions of cc_x86?
<stikonas[m]>To confirm that those are working
<outside_of_World>i think i tried all of them ., is there a test smoll c program that would work, i will try again tho
<stikonas[m]>It might be a problem with VM or VM arguments
<outside_of_World>yes it seems like a vm issue
<stikonas[m]>There is no VM in POSIX version
<stikonas[m]>Hence that's my suggestion
<stikonas[m]>Get that working first
<stikonas[m]> https://github.com/oriansj/stage0-posix
<outside_of_World>yea i will def give it a try but i have no idea how to go about that
<outside_of_World>i do appreciate your suggestion though
<stikonas[m]>It just runs on x86/amd64 CPUs
<stikonas[m]>On Linux kernel
<outside_of_World>im using mac, think it will work?
<stikonas[m]>No
<stikonas[m]>Hmm
<outside_of_World>interesting. ok... what about bsd ?
<stikonas[m]>Possibly not sure
<outside_of_World>i may try to get it going on mac anyways...
<outside_of_World>unless you are 100% sure it wont work
<stikonas[m]>Depends if bsd syscall numbers are the same
<outside_of_World>ah.
<stikonas[m]>Marcos can't run Linux elf binaries
<stikonas[m]>So stage0-posix won't run
<outside_of_World>its a GCC only thing?
<stikonas[m]>No GCC here, it's kernel thing
<outside_of_World>i was really hoping to beable to compile it with clang. oh kernel huh
<stikonas[m]>Kernelspace and user space have to agree on syscall numbers
<stikonas[m]>There is no dependency on compiler
<stikonas[m]>Neither GCC nor clang
<outside_of_World>interesting... wonder what it would take to fix that . that sucks cuz my mac is really easy to work on , i was trying to build a bsd machine on it
<stikonas[m]>But maybe vm from stage0 does... Not sure if anybody tried it on mac
<outside_of_World>vm was going pretty good up untill i tried to compile something in "Cc_x86"
<outside_of_World>like everything compiled up untill then
<outside_of_World>the hashes are all good everything
<stikonas[m]>Wait for oriansj
<stikonas[m]>He might know more
<outside_of_World>ok will hang around thanks for your help
<stikonas[m]>But POSIX version won't run for you, you would gave to port it to Mac
<outside_of_World>i see... i'd be willing to do that if i knew where to start tbh.
<outside_of_World>i dont know much about the kernel but i dont mind learning
<stikonas[m]>Probably not too hard but you would have to learn a but of assembly
<outside_of_World>i really dont see why the vm wouldn't work though
<stikonas[m]>Syscalls is API between use space and kernel
<stikonas[m]>Yeah, VM should
<outside_of_World>im honestly; trying 2 get away from mac and into freebsd lol
<stikonas[m]>What if you give it more memory?
<outside_of_World>so maybe i wouldn't do that
<outside_of_World>yea maybe thats a good idea
<outside_of_World>ill try that
<outside_of_World>im going to bed soon but i will check back in tommorow
<outside_of_World>thanks again so much