IRC channel logs

2022-05-17.log

back to list of logs

<oriansj>rickmasters: my current task is to first create the tools for creating and reading a bootstrap filesystem in the M2-Planet C subset. Then to write a program to be the bootloader in the MBR. Then finally a kernel (assuming someone else doesn't decide to pick it up to help speed things along.
<oriansj>)
<oriansj>as for why mescc; it seemed far more logical than expecting janneke to write mes.c in hex and for me to write another C compiler capable of building TCC when mescc could do the job.
<oriansj>It might have not been the optimal solution and it was a great deal of work to get there but it works and until someone puts in time to do something that replaces it, it is what we have to work with.
<oriansj>dongcarl: https://logs.guix.gnu.org/bootstrappable/2022-05-15.log starting at: oh and if you are bribed (say in the terms of $$$ Millions) to subvert the bootstrap
<littlebobeep>stikonas: you find ASM easier than Scheme? XD
<stikonas>littlebobeep: I didn't say that...
<stikonas>but right now ASM is more familiar to me
<littlebobeep>Ohhh well I thought you worked on ASM code for example and you said you were not goot at scheme
<stikonas>that doesn't mean easier, just that I might have invested more time in learning it
<littlebobeep>I seeeee
<stikonas>I worked on riscv support (so asm code too) for stage0-posix
<stikonas>that's it...
<littlebobeep>ja I knew you did riscv but I didn't know if you contributed ARM or x86 work too
<stikonas>no
<oriansj>and asm is very easy to build a predictive model of in your mind
<littlebobeep>oriansj: is it? :P
<stikonas>and asm is somewhat close to C
<stikonas>you still have "functions" just you need to add some extra stack work before and after
<oriansj>littlebobeep: well how much do you know about assembly language programming?
<littlebobeep>oriansj: not as much as you ;)
<littlebobeep>I find it quite difficult to understand compared to high-level languages
<oriansj>but even without knowing that if I showed you load r0, [r1+next] could you guess what it would probably do?
<achaninja>if you have programmed a lot of C you can get by in assembly by just transliterating
<achaninja>give each variable a stack location, use call and leave + ret for functions
<achaninja>i guess that is sort of what happened with the high level prototypes included with stage0
<achaninja>w.r.t. zstd in that thread above, I can vouch it is very fast
<achaninja>far faster than xz for compression and decompression by something like an order of magnitude
<achaninja>its even comparable to lz4
<achaninja>in speed
<achaninja>with good compression ratios
***lukedashjr is now known as luke-jr
<bauen1>oriansj: being bribed sounds like getting funded :D
<unmatched-paren>precisely :) we were noting that it could be incredibly easy to _look_ like you're subverting stage0, but actually you're just taking the money :D
<fossy>stikonas[m]: not really any good reason for links in separate file
<stikonas[m]>fossy: I'll see if I can simplify it
<stikonas[m]>I have a fix for other issues
<stikonas[m]>Will make PR later
<oriansj>bauen1: well effectively it has to be, otherwise you wouldn't have the time/effort required to get it in a form that wouldn't be immediately flagged and cause everything you have ever done to be more deeply audited.
***furrymcg1e is now known as furrymcgee
***jjardon_ is now known as jjardon
***dnm_ is now known as dnm
<dongcarl>oriansj: haha that was a great read, not a bad way to exploit the handler's relative ignorance
<muurkha>achaninja: I didn't realize zstd was comparable to lz4!
***stikonas_ is now known as stikonas
<stikonas>fossy: I might have a way to sort out those symlinks in live-bootstrap packages
<stikonas>it's a bit of a hack but seems to work
<stikonas>or at least it worked till findutils was built and we switched to different tar command (which then crashed for me0