IRC channel logs

2022-04-08.log

back to list of logs

<oriansj>unmatched-paren: is that really a surprise? bootstrapping is a marathon and not a race
<oriansj>you can always pick up where someone else left off and drive it into new and exciting directions.
<vagrantc>bootstrapping off-road!
<oriansj>with a good history of releases and no malicious jumps (aka needing the functionaly of the release to build the release sort of crap); everything can be bootstrapped by just doing some history but at this point we now *KNOW* that is rarely the case
<oriansj>so I guess one could say it is mostly off-roading for bootstrapping.
<oriansj>The roads have all decayed to rubble and we have to fix them up and keep them in working order.
<muurkha>fortunately it only rains once every 20 years
<oriansj>muurkha: overly optimistic today I see
<stikonas>fossy: I'm getting a bit stuck with my /after->/sysa rename...
<stikonas>not sure why but perl-5.32 is not deterministic
<muurkha>heh
<stikonas>or probably just different for qemu vs chroot builds
<Hagfish>it would be annoying if it is non-deterministic, but at least the build environment hypothesis is a testable one
<stikonas>well, first of all I need to compare tarballs...
<stikonas>at least with qemu having disk image it's now easier to extract tarballs from qemu build
<markjenkinssksp>First sign of re-birth for my bootstrapping hobby in 2022. Resumed working through part III of Crafting Interpreters by Nystrom with a compiler written in minimal scheme and a bytecode interpreter intended to be buildable with both M2-Planet and gcc. https://github.com/markjenkins/lox_compiler_scheme/commit/b8d5cf5f0de262e862ee0528f542e81c2ea9a133
<markjenkinssksp>My public mainline doesn't show it, but I was actually active until end of December in a private branch which I just squash merged and made public. Got into big trouble where my gcc builds were showing serious signs of memory errors bugs, but my M2-Planet builds were not.
<markjenkinssksp>Frustration with that made the project easier to shelve in the face of competing personal and professional demands. But I always kind of knew in the back of my mind that Valgrind could probably show me where I went wrong. And yesterday it sure did, hence the above commit where I figured out my attempt to do pointer arithmatic in a manner that works for both gcc and M2-Planet was never correct for gcc.
<stikonas>markjenkinssksp: by the way, these days you can use slightly more features and still be compatible with M2-Planet
<oriansj>markjenkinssksp: also we now support #ifdef blocks in M2-Planet
<oriansj>so you can do #ifdef __M2__ CELL_SIZE = sizeof(Value) #else CELL_SIZE = 1 #endif
<stikonas>Hagfish: wow, the diff between chroot and qemu is really strange
<stikonas>a single space
<stikonas>after the comment in pod manpage
<stikonas>fossy: I've pushed my changes to https://github.com/stikonas/live-bootstrap/tree/sysa_rename
<stikonas>if you have any ideas
<stikonas>diff is here https://paste.debian.net/1237188/
<stikonas>so pod .file in chroot mode is identical to the one in source tarball
<stikonas>qemu install has an extra space
<oriansj>the line number is rather interesting for such a change to occur
<muurkha>markjenkinssksp: awesome!
<markjenkinssksp>cool to know there are new features. Will be interesting to see if my source as is has remained M2-Planet compatible
<markjenkinssksp>Nice to see variable dereferencing as well stikonas and oriansj, I have var[0] in a few places where *var would be more conventional https://github.com/markjenkins/lox_compiler_scheme/blob/fd235742ae860e3d56922d8e97a0501f373ad3e2/bytecode_interpreter/vm.c#L173
<Hagfish>lol, i've just seen the diff between chroot and qemu outputs. yeah, that is really cursed
<littlebobeep>I think this might be the coolest chat room I have ever found
<oriansj>markjenkinssksp: just a minor warning about *var = blah; it isn't fully ISO standard but it does work on the trivial case as it is compatible.
<stikonas>fossy: /after->/sysa rename is now ready for merge (I've just removed offending manpage) https://github.com/fosslinux/live-bootstrap/pull/146
<Hagfish>littlebobeep: it's even cooler now you're here :)
<oriansj>Hagfish: indeed