IRC channel logs

2022-02-12.log

back to list of logs

<fossy>today's learning
<fossy>find -exec does not error if any of the execd commands error
<fossy>which is real great (not)
<nimaje>how would it know if the filter errored or if it simply returned false?
<oriansj>fossy: it is almost as if planning for robust system state was not a design concern when it was written.
<stikonas[m]>fossy: use xargs?
<stikonas[m]>find -print0 | xargs should return non zero code on failed commands
<stikonas>fossy: how are you testing your live-bootstrap branch? I just keep getting checksum mismatch errors. So am I missing something or is something non-reproducible
***ChanServ sets mode: +o rekado_
<muurkha>xargs -0
<mihi>unmatched-paren: Pascal supports conformant arrays (at least most dialects do), which effectively pass a pointer to an array and its bounds as separate parameters. You cannot use those when allocating arrays on the stack, but you can use them with POINTER TO ... as well as with VAR parameters to PROCEDURES.
<mihi>So you can have a PROCEDURE DoSomethingWith(VAR list: ARRAY [min..max] OF INTEGER); which effectively gets three parameters passed, list, min and max.
<mihi>In Oberon, conformant arrays were replaced by open arrays (VAR list: ARRAY OF INTEGER) which still pass the bounds as parameters but do not make them accessible as parameters.