IRC channel logs

2022-02-01.log

back to list of logs

<Hagfish> https://groups.csail.mit.edu/mac/users/bob/sliding-blocks.pdf "let’s see how we might go about building computers out of sliding-block puzzles"
***ChanServ sets mode: +o oriansj
***ChanServ sets mode: +o janneke_
***attila_lendvai_ is now known as attila_lendvai
***robin__ is now known as robin
<unmatched-paren>rekado_: in case you don't know yet, i found out that those ghc .hc files are not human-written
<unmatched-paren>if you do `ghc --help` and look for information about the `-C` option, you can see:
<unmatched-paren>'-C stop after generating C (.hc output)
<unmatched-paren>'
<unmatched-paren>and also, in an example: '# compile Haskell-produced C (.hc) to assembly language:'
<unmatched-paren>so although it's not certain, it seems reasonably likely that .hc means 'C produced by GHC'
***ChanServ sets mode: +o rekado_
<rekado_>unmatched-paren: that’s possible, but they look really good for something that might have been generated.
<rekado_>I also think that building GHC with ~4000 lines of very readable generated code is many orders of magnitude better than taking a binary of GHC and calling it a day.
<unmatched-paren>rekado_: fair enough :)
<unmatched-paren>(i am making some progress with booting pascal, btw :))
<stikonas>unmatched-paren: I looked at those files and I don't think they are computer generated
<stikonas>yes, .hc files can be produced by ghc, but that does not mean that .hc file is produced by ghc
<stikonas>their commit history is also too nice
<stikonas>so I think if rekado_ can bootstrap ghc using those files than that's fine
<stikonas>e.g. see https://github.com/ghc/ghc/commits/5cd7cb62dcbdabac9f728208362e1a32d1b82c39/ghc/rts/Updates.hc
<stikonas>yes, commit titles might be better but that's probably an artifact of cvs to git conversion
<stikonas>in any case it's still non-trivial to build it
<stikonas>I tried with newer GCC and without Hugs and I wasn't able to
<stikonas>well, it was probably mostly Hugs... GCC issues seem to be easily patchable
<unmatched-paren>stikonas: ah, you're probably right... if we were unsure, we could just ask them if the files are generated :)
<rekado_>my current obstacle is -liberty and -bfd
<rekado_>gotta be something silly
<rekado_>I’m trying to build ghc/interpreter (it’s really just a slightly modified hugs), and that is linked with bfd and liberty
<rekado_>the linker complains about missing symbols that the bfd objects reference, but that are provided by liberty.