IRC channel logs

2022-01-05.log

back to list of logs

<oriansj>stikonas: minor correction. Hex0 is universal (behaves the same on *EVERY* platform/architecture); it is Hex1 and Hex2 which have architecture specific deviations.
<oriansj>bauen1: boot0 seems like an appropriate name for a hex0 subset that doesn't support line comments
<oriansj>probably should add that to the wiki
<bauen1>oriansj: boot0 or the comment above ?
<oriansj>bauen1: the boot0 subset of hex0
***ChanServ sets mode: +o janneke
<oriansj>M2-Mesoplanet now successfully compiles hello.c (for x86)
<oriansj>the remaining problem is that https://paste.debian.net/1225968/ seems to always include the x86 assembly rather than the correct architecture.
<oriansj>not sure why yet
<stikonas>oriansj: missing #endif?
<stikonas>probably not the cause though...
***bauen1_ is now known as bauen1
***iridium.libera.chat sets mode: +oo janneke ChanServ
***iridium.libera.chat sets mode: +o oriansj
***bauen1_ is now known as bauen1
<oriansj>stikonas: you mean in M2libc? always possible
<stikonas>oriansj: no, I meant in your paste
<stikonas> https://paste.debian.net/1225968/
<stikonas>there is unclosed #if block
<stikonas>but it's not the cause of your problem
<stikonas>I haven't looked deeper into it though
<stikonas>oriansj: although, something is probably wrong in M2libc
<stikonas>since stage0-posix build segfaults
<stikonas>let me update it to the latest M2-Mesoplanet
<stikonas>ok, pushed
<oriansj>ok, I've revised the test to be https://paste.debian.net/1226067/ and just put #define foo ## in each of the files
<oriansj>So I'll need to do digging to find a smaller test
<oriansj>export ARCHITECTURE_OVERRIDE=x86 can be used to force it to build for x86 and it will produce working binaries if one does M2-Mesoplanet -f foo.c -o foo
***pgreco_ is now known as pgreco
<oriansj>ok figured a minimal test using the previous revised test
<oriansj>in the contents of foo1 put: https://paste.debian.net/1226068/
<oriansj>repeat for foo2-foo6 changing the #define of foo to match the number (foo2 -> 2, foo6 -> 6)
<oriansj>now it always returns 1; regardless what ARCHITECTURE_OVERRIDE you use