IRC channel logs

2021-12-04.log

back to list of logs

<stikonas>hmm, I think struct siginfo_t is incorrect, that's why kaem fails to get non-zero exit codes
<stikonas>oriansj: https://github.com/oriansj/M2libc/pull/12 (this fixes kaem not reporting non-zero exit codes)
<oriansj>stikonas: M2libc merged
<stikonas>thanks
<stikonas>hex2 lseek is fixed now too, I'll fix hex1 tomorrow
<stikonas>and that should be it for riscv32
<stikonas>oriansj: I have a couple of small PRs: https://github.com/oriansj/M2libc/pull/13 and https://github.com/oriansj/bootstrap-seeds/pull/14
<oriansj>M2libc merged
<oriansj>and bootstrap-seeds merged
<stikonas>ok, I've pushed them to stage0-posix now
<stikonas>so that should be it for riscv32...
<oriansj>well make test-riscv32 seems to die at the first step
<stikonas>hmm, let me retry
<stikonas>hmm, indeed, must be something wrong in bootstrap seed
<stikonas>strange
<stikonas>bootstrap-seeds/POSIX/riscv32/kaem-optional-seed kaem.riscv32 does work
<stikonas>oh, I think I know what's wrong
<stikonas>missed one jump in hex0 encoding
<stikonas>should be easy to fix, just need to move that initialization up in the file
<stikonas>yes, that fixes it...
<stikonas>sorry... Will update bootstrap-seeds then
<stikonas>oriansj: https://github.com/oriansj/bootstrap-seeds/pull/15
<stikonas>ok, also fixed it in hex2 and M1 prototypes...
<stikonas>GAS prototype is missing for kaem-minimal... Not sure if we need it now
<stikonas>shouldn't be too hard to make it but right now I don't have riscv32 toolchain...
<stikonas>(except for M2-Planet, M1 and hex2)
<oriansj>bootstrap-seeds merged
<stikonas>ok, let me update stage0-posix
<stikonas>oriansj: ok, done
<stikonas>make test-riscv32 works now
<stikonas>would be good to have this tested on HW...
<stikonas>but at least in terms of registers we should be all initialized now
<oriansj>looks good
<stikonas>ok
<stikonas>oh, I think there is another thing missing. error message in M2-Planet needs updating
<stikonas>oriansj: https://github.com/oriansj/M2-Planet/pull/39
<stikonas>wait, need to update tests...
<stikonas>ok, pushed
<stikonas>hmm, probably intermittent error but I got the following
<stikonas> +> ./AArch64/artifact/M0 ./AArch64/artifact/M2-0.M1 ./AArch64/artifact/M2.hex2
<stikonas>qemu: uncaught target signal 11 (Segmentation fault) - core dumped
<stikonas>oh, it's only reproducible in qemu, works fine on real HW, probably caused by high memory usage
<stikonas>I've seen this in risc-v too but then https://github.com/oriansj/stage0-posix/commit/d203bcc811afd0490013f973520885b353aaee4c fixed it
<stikonas>because M2-Planet has gotten bigger, we probably started hitting it more often in qemu now
<oriansj>M2-Planet merged
<stikonas>and stage0-posix updated too
<stikonas>also updated stage-posix in live-bootstrap