IRC channel logs

2021-11-28.log

back to list of logs

<stikonas>and PR is now up: https://github.com/oriansj/M2-Mesoplanet/pull/2
<oriansj>stikonas: nicely done
<stikonas>well, that was probably the easiest way to deal with whitespaces without breaking everything
<stikonas>basically whitespace by default should work more or less the same way as before
<stikonas>oriansj: regarding line numbers in M2-Planet
<oriansj>well I was wondering if comments should pass through unmodified; So that the output will be easier to do a diff against the original
<stikonas>do we actually need to do anything?
<stikonas>oh, maybe that's true
<stikonas>oh, maybe we do when we have ifndef...
<oriansj>stikonas: well yes, because now M2-Planet is only going to see a single file
<stikonas>oh right...
<stikonas>yeah, it only works fine as long as you build a single file...
<oriansj>so I was thinking something like // FILENAME $name $number
<stikonas>well, it's just that // comments often break things...
<oriansj>and M2-Mesoplanet could embed those comments in the token output string at the start of a file and after the end of an include
<stikonas>right now Mesoplanet does not deal with them at all
<stikonas>or maybe incorrectly deals with themn
<stikonas>when I run ./bin/M2-Mesoplanet -E -f ../mes/include/mes/macros.h
<oriansj>and I could add a function to M2-Planet's cc_reader to check for a matching token and update filename and line number accordingly
<stikonas>I get the following error: ../mes/include/mes/macros.h:81:newline expected at end of macro directive\
<stikonas>found: '__MES_MACROS_H'
<stikonas>and the last line in that file is #endif //__MES_MACROS_H
***mab is now known as bandali
<oriansj>sounds like a require
<oriansj>923
<stikonas>yes, it's that one
<oriansj>we might not even need that block
<oriansj>I forget why it was originally added
<oriansj>commit 1ac5bb6e
<oriansj>looks like something bulk imported from M2-Planet
<oriansj>M2-Planet commit 0ab7cb78
<oriansj>correction 46cf81af
<oriansj>nope even older
<stikonas>indeed, it might just work if we remove it
<oriansj>commit 0ab7cb78eb5d1bcc970887cf7c6a18e780d624d9
<oriansj>correction: 63bb59404de9d84f0ea4f837fabab53216ab21d1
<oriansj>we just simply assumed a newline was required at the end of a #define and used that block to catch it
<stikonas>well, that's not true if comments are kept...
<oriansj>indeed
<stikonas>although, it does catch other random rubbish
<stikonas>like #endif a
<stikonas>gbrlwck: I just tried mescc and crt1.c builds fine
<stikonas>maybe you have not set up all env variables (MES_PREFIX, GUILE_LOAD_PATH=${MES_PREFIX}/mes/module:${MES_PREFIX}/module:../nyacc/module, MES_ARENA=20000000, MES_MAX_ARENA=20000000, MES_STACK=6000000)
<stikonas>or maybe nyacc is at wrong version
<oriansj>stikonas: we really just need to do a sanity checker script for mes-m2
<oriansj>that will download the correct versions if they don't exist already locally and prompt to export the correct enviroment variables
<stikonas>we kind of already have live-bootstrap...
<stikonas>just need to update stage0-posix and mes-m2
<stikonas>if one wants to test newst versions
<stikonas[m]>But maybe something simpler also makes sense
***bandali is now known as mab
***stikonas_ is now known as stikonas
<stikonas>oriansj: https://github.com/oriansj/bootstrap-seeds/pull/13
<oriansj>stikonas: merged
<stikonas>ok, I'll update submodule in stage0-posix, but I can do it myself there
<stikonas>also need to add actual kaem scripts (although they wouldn't run till the end as port is only done until cc_riscv32)
<oriansj>and we have M2libc and M2-Planet porting work to do as well
<stikonas>yeah, that's what's left now...
<stikonas>just pushed the scripts
<stikonas>builds fine up to cc_riscv32
<stikonas>then fails on M2-Planet as expected
<stikonas>M2libc and M2-Planet should be quite simple (maybe with the exception of waitpid/wait4, need to implement it using waitid)