IRC channel logs

2021-11-20.log

back to list of logs

<oriansj>stikonas: hmm why not just #define M2_CELL_SIZE 3*sizeof(long)
<stikonas[m]>We can try...
<stikonas[m]>Unless it fails due to operator priority
<stikonas[m]>(And my code is pushed to https://github.com/stikonas/M2-Planet/commits/macro_functions )
<oriansj>could we ban #define foo(x) \n so no \n after ) and thus in that case we interpret it as #define foo (x)
<oriansj>or do you think we need to modify the tokenizer to preserve whitespace characters as well and then strip them after preprocessing?
<stikonas[m]>Hmm, maybe that will work...
<stikonas[m]>But any of those options would need some adjustments
<stikonas[m]>But I did think a bit about option 2...
<stikonas[m]>It doesn't sound super hard either...
<oriansj>and then your work should be much easier
<oriansj>here is the code needed for the reader and cc.c: https://paste.debian.net/1220147/
<oriansj>it produces a bug in the macro preprocessor but I assume you are working on that
<oriansj>now just to get the preprocessor to become whitespace aware
<oriansj>and then we can do proper whitespace logic for the macros
<oriansj>thank you stikonas for helping me reason to this change. hopefully the diff helps you out
<pabs3>can someone add https://github.com/ebourg/kotlin-bootstrapping to https://bootstrappable.org/projects/jvm-languages.html ?
<stikonas[m]>pabs3: if you can, make a patch to git repo and submit it
<stikonas>oriansj: https://github.com/oriansj/stage0-posix/pull/70 (I did riscv64->riscv32 conversion)
<stikonas>fairly simple...
<stikonas>although I haven't tested it beyond confirming that it compiles
<oriansj>stikonas: merged
<oriansj>and figured you would be changing the M1 strings later after we add support for RISC-V 32bit in M2-Planet and M2libc
<stikonas>maybe eventually if nobody does it first...
<stikonas>oriansj: you meant M1 strings for M2-Planet?
<stikonas>or which ones?
<stikonas>cc_riscv32 should already have good M1 strings
<stikonas>unless I missed something
<oriansj>stikonas: the strings in cc_riscv32 that are output as the result of processing C code. As I do not know if any changes will need to be made as you have not shared if you did any testing of running the resulting output. And from your testing are there any changes from RISC-V 64bit to RISC-V 32bit that need to be encoded in hex2, M1 or blood-elf or can we simplify to just riscv for them?
<stikonas[m]>I didn't test output but I adjusted output strings, e.g. LD->LW, pointer sizes, etc
<stikonas[m]>No changes needed for hex2 M1 or blood elf
<stikonas[m]>Biggest missing pieces are now M2libc and kaem-minimal
<stikonas[m]>But I didn't test output yet...