IRC channel logs

2021-11-15.log

back to list of logs

<stikonas>oriansj: can you please merge https://github.com/oriansj/M2libc/pull/7
<stikonas>everything seems to work on x86 too now
<stikonas>I just need to add bootstrap mode check
<stikonas>oh, there is a nice helper maybe_bootstrap_error that I can use
<stikonas>I've also updated https://github.com/oriansj/M2-Planet/pull/34 but it still needs M2libc submodule update
<stikonas>at least it's now down. That was harder than I initially expected...
<stikonas>s/down/done/
<oriansj>0FBE1B wouldn't fully sign-extend the byte
<stikonas>hmm
<stikonas>checking
<oriansj>I believe the correct one is: 480FBE1B
<stikonas>for LOAD_BYTE_rbx ?
<oriansj>yes
<stikonas>but what about LOAD_BYTE itself?
<oriansj>although we haven been using 0FBE00 for eax;
<stikonas>hmm, maybe that one also needs fixing then
<stikonas>LOAD_BYTE is movsx eax, byte [rax]
<oriansj>possibly
<stikonas>according to rasm2
<stikonas>ok, I can update both of them then
<oriansj>I wonder if its behavior is correct
<oriansj>perhaps I need to do some gdb testing
<oriansj>as 480FBE00 would be the 64bit encoding
<stikonas>yes, for LOAD_BYTE
<stikonas>I'll try to rebuild stage0-posix with it
<stikonas>btw, should I push sha256sum changes that I have (to use compound assignments) ?
<stikonas>I did it as a test
<oriansj> https://www.felixcloutier.com/x86/movsx:movsxd
<stikonas>but then we might as well switch to it
<stikonas>oriansj: test failed...
<stikonas>with 480FBE1B
<stikonas>or maybe not
<stikonas>let me rebuild checksum
<stikonas>I forgot that we expect checksums to change...
<oriansj>I think you helped me discover a bug in AMD64 stikonas
<oriansj>thank you
<stikonas>no problem :)
<stikonas>that's what reviews are for
<stikonas>sometimes while reviewing you can spot something else
<stikonas>so stage0-posix builds fine now
<stikonas>with that change
<stikonas>ok, let me update PR then
<stikonas>updated : https://github.com/oriansj/M2libc/pull/7
<oriansj>and merged
<stikonas>and https://github.com/oriansj/M2-Planet/pull/34 updated
<stikonas>and this is what I was using for testing: https://github.com/oriansj/mescc-tools-extra/pull/8
<oriansj>merged
<stikonas>thanks
<oriansj>and merged
***ChanServ sets mode: +o rekado
<rekado>hey, do we want to keep the bootstrappable.org website? It’s up for renewal soon.
<stikonas>oriansj: ^^
<fossy>I think we should, it's a pretty good landing page that quite a lot of people go through to see what exactly bootstrappable is
<gbrlwck>fossy: +1