IRC channel logs

2021-10-13.log

back to list of logs

<fossy>stikonas: ? did you test using chroot or qemu mode
<fossy>the checksum is correct
<fossy>but for chroot mode it should discount the /usr/bin/guile checksum
<fossy>because its not deterministic in chroot mode (some kernel difference)
<xentrac>aw :(
<stikonas>fossy: well, there is merge conflict
<stikonas>you merged my autoconf commit
<stikonas>and autoconf changes checksum
<stikonas>my checksum is I think from chroot mode
<stikonas>but we still need to calculate the correct one now
<fossy>ohh yeah
<fossy>right
<stikonas>oh, I still need to do my PRs...
<stikonas>fossy, oriansj: https://github.com/oriansj/mescc-tools-extra/pull/5
<fossy>the match code has not been committed..
<fossy>oh there it is
<stikonas>yes, already noticed...
<fossy>yeah that looks good
<stikonas>it's really trivial in terms of code
<stikonas>but I think that should now let us do things like if match $ARCH x86; then
<oriansj>stikonas: your mescc-tools-extra patch has been merged.
<oriansj>stikonas, fossy: are there any cases where we actually do kaem -f file1 -f file2 -f file 3 ?
<fossy>Not afaik
***ericonr- is now known as ericonr
***theruran_ is now known as theruran
<oriansj>vagrantc: thanks you for the patch for mescc-tools. sorry for taking so long to notice it
<vagrantc>i'm used to things taking 3-12 months or more in other projects, this seems like fine turnaround :)
<oriansj>fossy: ok, because I am trying to figure out a correct solution to: https://github.com/oriansj/mescc-tools/issues/21
<oriansj>vagrantc: messaging me here, would have gotten same day review and merge ^_^
<vagrantc>hah
<stikonas[m]>Kaem has a return code bug... Will make PR later too
<stikonas[m]>wstatus from waitpid does not return exit code
<stikonas[m]>It's encoded in some of its bits
<stikonas[m]>So need to extract it
<stikonas[m]>Same issue is in most kaem-minimals
<stikonas[m]>Except for riscv
<stikonas[m]>But it's less critical there since we always want 0 return code there
<ruffni>there=riscv?
<stikonas[m]>No kaem-mininal
<stikonas[m]>Well, full kaem now has conditionals, so return code became more important
<stikonas_>oriansj: https://github.com/oriansj/mescc-tools/pull/32
***stikonas_ is now known as stikonas
<stikonas>fossy: I pushed your PR too
<stikonas>with updated checksum for /usr/bin/guile
<Hagfish>is the intention for live-bootstrap to continue by preparing the other requirements for guix, or should that be a separate project/module?
<stikonas>Hagfish: it's not necesserily guix
<stikonas>it's distro-agnostic
<stikonas>any distro should be able to get those built binaries and use them to bootstrap itself
<stikonas>it can be made as a hook
<stikonas>just as live-bootstrap takes over after stage0-posix
<stikonas>so you can have different distro plugins
<stikonas>(not sure if they should live in the same repo)
<fossy>^ this
<fossy>so the answer to that Hagfish is no, first i want a complete GCC toolchain, and then we can build Guix (and Debian, and Fedora, etc) off of that
<stikonas>well, we just need to get newer GCC toolchain
<stikonas>we already have GCC toolchain
<stikonas>I guess main obstacle is now autogen...
<fossy>s/complete/complete and up-to-date
<stikonas>fossy: by the way, kernel is not checksumed?
<stikonas>I guess it includes initramfs and timestamps
<fossy>oh? that was by accident
<stikonas>yeah, you didn't add any checksum file where linux is built
<stikonas>although, getting checksum is a bit annoying
<stikonas>you can't get it in chroot mode
<stikonas>unless we build kernel there
<fossy>i think i'll just sha256sum it and just take the output of that in the console..
<fossy>like just temp add it to the script
<stikonas>yeah, but if initramfs is checksumed, that will fail
<stikonas>as that has timestamps
<fossy>i don't think we want initramfs to be checksummed
<stikonas>hmm, kernel does not include initramfs in it's image?
<fossy>no, bc linux 4.9
<fossy>that was a 2.6 thing
<stikonas>oh ok
<stikonas>fossy: also kaem patch is up for review: https://github.com/oriansj/mescc-tools/pull/32/files
<fossy>ooh, that is an old bug
<fossy>how did you figure out how to fix that
<stikonas>cause I wrote it correctly in kaem-minimal for risc-v
<stikonas>so when I saw this, I realized that it's wrong
<fossy>how do you know that its & 0xff00 and >> 8?
<stikonas>checked WIFEXITSTATUS define in musl
<fossy>i see
<stikonas>WEXITSTATUS actually
<stikonas>mixed it up and combined with WIFEXITED...
<fossy>also, we probably do want glibc in live-bootstrap before we are "done"
<stikonas> https://github.com/runtimejs/musl-libc/blob/master/include/sys/wait.h#L47
<fossy>will make it much easier to bootstrap most distributions which will need glibc
<stikonas>hmm, possibly, although it shouldn't really matter
<fossy>it does
<stikonas>they should build into another chroot
<stikonas>hmm
<fossy>yes, but bootstrapping glibc distributions from musl will be more of a pain than it is worth
<stikonas>hmm, ok
<stikonas>this is what kaem-minimal does in risc-v https://github.com/oriansj/bootstrap-seeds/blob/master/POSIX/riscv64/kaem-minimal.hex0#L171
<fossy>ooh, i see
<stikonas>I also checked WTERMSIG(s) ((s) & 0x7f)
<fossy>oh, this would not be too painful to move to glibc, because we are still using static binaries
<fossy>that is good
<stikonas>well, partially that's true
<stikonas>but we have libraries
<stikonas>like gmp
<stikonas>those need to be rebuilt
<fossy>true
<fossy>i think i will look at autogen for now
<stikonas>oh also those bits and shifts for exit status are defined in man 2 waitpid
<stikonas>which version are you looking at?
<stikonas>not sure how we can run it with guile 3...
<fossy>stikonas: i'm just looking at any potential bootstrap path
<stikonas>yeah, it's all very messed up there
<oriansj>stikonas: merged your mescc-tools patch for kaem
<stikonas>oriansj: thanks, it should now work with at least match executable
<stikonas>I just realised that other exit codes might still be broken when kaem is built with M2-Planet
<stikonas>(due to handling of ! with non 0 or 1)
<stikonas>but I think "match ${ARCH} ..." might be the main use-case
<stikonas>I might update stage0-posix with those new checkouts...
<stikonas>oriansj: and updated submodules in stage0-posix https://github.com/oriansj/stage0-posix/pull/57