IRC channel logs

2021-10-11.log

back to list of logs

<fossy>good news, the gawk works, and it is *significantly* faster
<stikonas>that's good
<stikonas>so most of the rough edges after kernel landed seem to be getting resolved now
<fossy>yeah
<stikonas>although, I'm still a bit confused why kexec doesn't work with 64-bit kernel. From what I saw online, theoretically it should work
<stikonas>or maybe because kexec architectrure has to match kernel architecture...
<stikonas>i.e. 64 bit kexec is needed for 64 bit kernel...
<fossy>yes, that is the case
<fossy>if you look through kexec code, you will notice the syscall structure, the jumps, etc are all different for different archs, including x86 -> x86_64
<stikonas>I see
<stikonas>hmm, live-bootstrap is starred by quite a lot of people...
<stikonas>122...
<stikonas>although where are all the PRs from them...
<fossy>LOL
<fossy>i think that's probably from hn and other such publicity
<stikonas>ok, I'll try gawk once you push it
<stikonas>sed got oomkilled
<fossy>yeah, same for me
<fossy>using your kernel
<oriansj>stikonas: far fewer people contribute than will use starring to mark they think progress on something is interesting.
<pabs3>starring is used as bookmarks by many folks, so isn't particularly meaningful
<oriansj>hence why stage0 has 507 stars but only 564 commits 522 done by me (92%)
<oriansj>the majority of commits not done by me are fixing typos (thank you for that stikonas) or someone wanting to fix something (thank you markjenkins and siraben) or making stage0 more MesCC friendly (thank you janneke)
<oriansj>stage0-posix on the other hand only got 32 stars but has 251 commits; only 105 are done by me.
<oriansj>stikonas has 62 for RISC-V support, janneke has 28 commits getting it all started, yt has 27 for AArch64 support and 8 other people contributing to make it all possible.
<oriansj>By github standards stage0 is a success but stage0-posix is invisible. However by cooperation standards, stage0-posix has been considerably much more successful than stage0
<stikonas[m]>Well, number of commits is somewhat poor metric. I tend to use smaller commits
<fossy>^
<fossy>this is rather disappointing... gawk seems to not really work.. even with my system gawk, it gives a bunch of "did not change, something is wrong" messages
<stikonas[m]>Hmm
<fossy>i'm trying newer scripts, maybe fixed
<fossy>nope
<fossy>i don't think we can use gawk :\
<fossy>Ok, now looking at the code for deblob in more detial, there seems to be a hidden option where we can just force a hard wipe + delete of all files with blobs, which is ok for our use case, rather than going through and extracting + removing them
<stikonas>fossy, oriansj: another cheap feature that we can add to kaem: https://github.com/oriansj/mescc-tools/pull/31
<stikonas>(terminate commands on semicolon)
<fossy>Yeah that looks reasonable to me
<fossy>oops, may have used wrong merge strategy, looking at commit history
<fossy>my bad if that is the case, oriansj
<stikonas>yeah, I think mescc-tools usually doesn't include merge commit
<stikonas>fossy: I also briefly checked if it's possible to move flex 2.5.11 after musl (to reduce gap between heirloom-tools and musl). The answer is: in principle yes, but heirloom-tools need to be rebuild with musl too, so in practice it's easier to move both at the same time
<stikonas>which basically means if we get something else to run bash scripts, e.g. gash, then we just simply replace heirloom->bash->flex->musl with musl->heirloom->bash->flex
<oriansj>fossy: it is fine and it looks simple enough to be worth adding.