IRC channel logs

2021-09-30.log

back to list of logs

<attila_lendvai>is anyone here by any chance familiar with the updating of the bootstrap binary guile in guix? it's very old (2.0.9), and it lacks something i wanted to use. if it's simple enough, i'd appreciate if someone would do it. details in: http://issues.guix.gnu.org/50878#4
<civodul>hi attila_lendvai! it's probably best to ask on #guix
<civodul>but basically, we rarely (if ever) change bootstrap binaries
<civodul>eventually we'll replace Guile with Mes
<civodul>but that means there are pieces of code that must not rely on fancy Guile features
<civodul>(not that stable-sort is super fancy, but you get the idea ;-))
<attila_lendvai>civodul, hi! ok, will move it there. i thought it's more magic, but seems like it's not so much
<oriansj>attila_lendvai: magic is one thing we try to eliminate from our need list.
<markjenkinssksp>I've taken one of my three bootstrap related toy projects out of stealth mode https://github.com/markjenkins/lox_compiler_scheme
<markjenkinssksp>working through https://craftinginterpreters.com/, working my minimalist scheme skills, compiling the book's toy lang lox to bytecode
<markjenkinssksp>interpreting said bytecode in M2-Planet C variant
<oriansj>markjenkinssksp: nice
<markjenkinssksp>very much still useless, I'm only doing simple arithmetic exprs right now. I try to keep half-baked stuff in stealth, but I figured it would be good to show the world M2-Planet doing a different kind of task, we'll see if M2-Planet or my limited Scheme skills hold me back
<oriansj>the macros is the bit that catches most people
<markjenkinssksp>yep, and Nystrom sure likes them! Fortunately I'd already caught the vibe here
<markjenkinssksp>M2-Planet error output also did a good job of stopping me from doing ones I thought were simple, thanks oriansj!
<siraben>markjenkinssksp: nice project!
<stikonas>hmm, I have (only a semi-working) port of M2-Planet to riscv
<stikonas>semi-working is a bit unfortunate :(. There must be some bugs left
<oriansj>stikonas: semi-working is a world better than not working at no support at all. Also test-1000 is a self-bootstrap test which you will need to update the checksum after you verify the build binary works.
<stikonas>well, self-bootstrap would probably fail right now
<stikonas>so at the moment I'm building M2-Planet with gcc and trying to build blood-elf
<stikonas>blood elf kind of seems to work but output is a slightly mangled (there are nulls instead of spaces in someplaces, hence making file binary)
<stikonas>but other than that contents seem alright
<stikonas>not sure what might cause this...
<stikonas>although, I know for sure that I need to fix large immediates
<stikonas>at the moment the largest number I can set is 2147481599
<stikonas>which is (bits 0 to 31 set except for bit 11)
<stikonas>(this might also be a bug in M1...)
<oriansj>hopefully you got the lowest numbered tests to pass thus far
<stikonas>haven't tried M2-Planet tests yet, just tried some of my test functions, they seemed to work, I can try M2 tests now
<stikonas>oriansj: how do I run those tests? "make test" somehow errors out and it seems unrelated to my changes
<stikonas>it tries running bin/M2-Planet --architecture aarch64 -f M2libc/aarch64/Linux/unistd.h -f M2libc/stdlib.c -f M2libc/aarch64/Linux/fcntl.h -f M2libc/stdio.c -f test/test0001/library_call.c -o test/test0001/tmp-aarch64/library_call.M1
<stikonas>and I get Unknown type size_t