IRC channel logs

2021-08-28.log

back to list of logs

<stikonas>M0 seems quite easy to write (at least compared to e.g. hex1)
<stikonas>a lot of functions can be taken from previous programs
<stikonas>and remaining are much easier to debug, since output of M0 is more readable
<stikonas>than output of e.g. hex programs
<stikonas>still need to implement risc-v's Eval_Immediates but shouldn't be too hard
<stikonas>but it will have to wait for 2 weeks or so
<stikonas>of course writing it for the first arch (x86) must have been much harder
<oriansj>stikonas: technically this was the hardest to think up when doing M0 https://github.com/oriansj/stage0-posix/blob/master/x86/Development/M0_x86.M1#L834
<stikonas[m]>Yeah, that piece is nicely written
<oriansj>and with minor tweaks it becomes big endian too: https://github.com/oriansj/stage0/blob/master/stage2/cc_knight-native.s#L1099
<stikonas[m]>I have hex8 to hex1 done for now
<oriansj>when you get to cc_* for RISC-V, perhaps these will be much easier to understand and prototype with before implementation: https://github.com/oriansj/stage0/tree/master/stage2/High_level_prototypes/cc_x86
***pgreco_ is now known as pgreco