IRC channel logs

2021-08-20.log

back to list of logs

<oriansj>pabs3: thank you for that clarification. git archive tends to not be slightly less deterministic than: https://paste.debian.net/1208296/
<pabs3>I think it would be a good idea to make `git archive` deterministic by default if it isn't already (I thought it was TBH)
<oriansj>right now When you use more advanced filtering options, the timestamp is set to the current time; not the time of the commit
<pabs3>ah, that sounds like a bug
<oriansj>So if one does no filtering, you can get the commit's timestamp but that isn't what anyone actually does (especially github and gitlab)
<oriansj>or as they say "working as intended"
<oriansj>the general suggestion is to use faketime or don't use git-archive to make archives.
<pabs3>hmm, I'm surprised people do filtering, I thought that would be rare
<pabs3>and surprised this is "working as intended"
<oriansj>pabs3: look at the contents of any github tarball and compare it to a bare git-archive result
<oriansj>now things might have improved since I last looked thanks to reproducible builds
<stikonas>ok, got hex2_riscv GAS prototype working
<oriansj>but right now the ability to reproduce tarballs is an essential step in ensuring that one isn't playing games with release tarballs or inserting malicious functionality that isn't an auditable build tree (like a git repo)
<oriansj>stikonas: very nice. did you figure out what was wrong with . ?
<stikonas>oriansj: yeah, was missing one instruction
<stikonas>I thought I had it
<stikonas>but it was the other branch
<oriansj>stikonas: I am glad you figured it out. I'd hate to waste more of your time on my programming bugs.
<stikonas>oriansj: no, it was my bug, not your bug
<stikonas>in C you can see branches much easier due to indentation...
<oriansj>stikonas: Hopefully M1 is making your happy and did you think more about the I-format question?
<stikonas>oriansj: so far I haven't...
<stikonas>was it not for R-format?
<stikonas>for shifts
<oriansj>stikonas: you are right my bad
<stikonas>that's something to think after hex2...
<stikonas>in general, I found hex1->hex2 step fairly easy
<oriansj>stikonas: fair as you would have to deal with it in M0 if you selected to do that.
<stikonas>maybe because hex1 for riscv was already fairly big
<oriansj>stikonas: and you might want to consider < for hex2 to save you from having to count bytes in strings.
<oriansj>sort of :label "my string" < :label2 "next string" < sort of pattern
<stikonas>oh , I haven't added that yet
<stikonas>yeah, maybe I should add it first
<stikonas>right now I had label>label, long labels, dots and %, & pointers
<oriansj>nice
<stikonas>^ is probably not needed for riscv
<stikonas>seems mostly arm related
<oriansj>stikonas: that and PowerPC but yeah, it doesn't look like ^ is needed in RISC-V
<xentrac>thank goodness for small favors