IRC channel logs

2021-08-03.log

back to list of logs

<stikonas>or am I only supposed ot use them with labels?
<stikonas>and not numbers like 8
<stikonas>which would make more sense since 8 can be encoded inside M1
<stikonas>but then I'm confused why hex2 needs to know about I-type
<stikonas>oh, I see...
<stikonas>that's for loading label addresses in la instruction
<stikonas>ok, makes sense now
<stikonas>ok, kaem-minimal.M1 should be "ready" https://github.com/oriansj/stage0-posix/pull/30
<stikonas>it's not tested yet since we don't yet have riscv64 capable M1
<stikonas>so two more steps left .M1-> .hex2 -
<stikonas>and then to kaem-minimal.hex0
<NieDzejkob_>just noticed this on lobste.rs, might be useful: https://github.com/vvaltchev/tilck
<fossy>NieDzejkob_: this will be amazing if it is very small
<stikonas>NieDzejkob_: that might indeed be useful (for POSIX bootstrap)
<fossy>after 10 mins of tinkering (and i think we can get it smaller)
<fossy>➜ du -sh ./build/tilck
<fossy>380K ./build/tilck
<oriansj>stikonas[m]: yeah in hex2 only labels come after !@$~%&, only in M1 would numbers follow !@$~%&
<oriansj>plasma41: that step 1 is wrong. The correct step 1 is: be a badass bootstrapper who isn't afraid to rip some shit.
<plasma41>oriansj: Fair enough. In that case, Step 2: Grab a hairbrush rip the tangles out of that hairball.
<oriansj>plasma41: scissors work better
<oriansj>buzz cut it to stubble and just sweep up the mess left after.
<oriansj>it'll be ugly but it'll clear up th mess real fast.
<plasma41>oriansj: Reminds me of the "untying" of the Gordian Knot with a sword.
<oriansj>plasma41: we don't have to play by the rules or care about preserving features. The only thing that matters is can it be properly bootstrapped and can it be used to do the next bootstrapping step. Everything else better stay out of our way.
<oriansj>like an EMT trying to revive a heart attack victim. Gentle isn't going to save anything at this point. Crack a rip if you need to but get that heart (bootstrap chain) beating again.
<plasma41>Hack through that dense forest with a machete! :-D
<oriansj>a 400 step ugly bootstrap path beats the shit out of unbootstrappable.
<oriansj>we can always go back and clean up the mess leter.
<oriansj>every bootstrap chain buys us time.
<oriansj>It doesn't matter how messy and complicated, because we can just have guix or Nix do all of the work for us until someone gets some time to clean it up.
<fossy>plasma41: where the loop in that?
<fossy>/loops
<siraben>plasma41: lol rip kubernetes bootstrapping
<siraben>NieDzejkob_: you might be interested https://crypto.stanford.edu/~blynn/compiler/quest.html
<plasma41>fossy: Ok, in fairness, the main issues with Kubernetes have more to do with the amount of overall complexity and vendored code than they do with bootstrapping.
*pabs3 sighs at Debian just accepting all that Kubernetes vendoring https://lists.debian.org/msgid-search/87sg0gvghj.fsf@melete.silentflame.com
<drakonis>pabs3: golang is hell
<pabs3>I don't understand why they do vendoring, since Golang has module/dependency stuff
***V__ is now known as V
<fossy>fossy: Ok, in fairness, the main issues with Kubernetes have more to do with the amount of overall complexity and vendored code than they do with bootstrapping.
<fossy>agreed, which is also a large problem
<Hagfish> https://github.com/riicchhaarrd/ocean " Programming language that compiles into a x86 ELF executable. "
<Hagfish>another interesting project found on HN
<stikonas>M2-Planet is probably way more advanced
<stikonas>oriansj: found what was confusing me with hex2... I think there is a missing call to consume_token https://github.com/oriansj/mescc-tools/pull/18
***jackhill is now known as KM4MBG