IRC channel logs

2021-07-21.log

back to list of logs

<oriansj>stikonas[m]: not a stupid question at all. See in assembly EOF doesn't actually exist and the implementation of READ needs to have some consistent way to know you reached the end of the file. As the Kernel only will inform you of how many bytes it retrieved for you (zero in the case of you hit End of File or the file is empty)
<oriansj>So I picked the value -4 because I liked it but any value greater than 7bits in lengt will work for hex1 (or 8 bits if you want to not have the file truncate at 0xFF or something like that) but I could have also set some global value to anything I wanted to indicate EOF.
<xentrac>traditional stdio eof is -1 fwiw
<xentrac>which is why getc() and getchar() return int
<plasma41>Discovered this tonight: Up-to-date BusyBox/Linux on a single floppy https://bits.p1x.in/floppinux-an-embedded-linux-on-a-single-floppy/ Nice!
<fossy>hell yes
<fossy>hm
***attila_lendvai_ is now known as attila_lendvai
<stikonas>oriansj: fyi, High Level Prototypes/hex1.c and hex2.c seems to be a bit broken. Not yet sure what exactly is wrong but I think something is incorrect with pointer address calculation, hex0.c seems to work fine