IRC channel logs

2021-07-05.log

back to list of logs

<fossy><stikonas[m]> I mean he bootstrapped it once (I guess first autogen didn't have those circular deps)
<fossy>yeah ofc
<fossy><@oriansj> stikonas: the reason usually for why those circular dependencies are inserted secretly is usually shame in regards to how they were implemented and the aurthor not wanting that sort of mess to be associated with them. So they destroy the transistion code needed and we end up having to pull another bison bootstrap.
<fossy>I do not think thats always the case.. sometimes its the easiest option
<fossy>easiest is not a good thing sometimes, however
<stikonas>fossy: I suspect the easiest option is actually
<stikonas>forget top level makefile and build g++ anyway
<fossy>I tend to agree with you after looking into autogen
<fossy>clang would be a massive pita
<fossy>for linux kernel particularly
<stikonas>so I played with it a tiny bit
<stikonas>g++ is actually very easy to build, it's just --enable-languages=c,c++. What will be harder is libstdc++
<stikonas>some musl problems
<stikonas>but maybe it's finally time to build glibc
<fossy>glibc is logical next step. should we do glibc before or after g++?
<stikonas>probably before
<stikonas>glibc gets a bit grumpy if we have g++ without libstdc++
<stikonas>and regarding autogen we can still email author...
<stikonas>and ask, there is no harm in that...
<fossy>well yeah theyre kinda codependent (g++/libstdc++)
<fossy>ofc, I did that with tinycc
<stikonas>did what with tinycc?
<stikonas>so I'm not sure what to do with guile then...
<stikonas>it's not harmful but it's not immediately useful
<stikonas>unless some other project wants to use it (e.g. guix)
<fossy>asked fabrice bellard about the history of tinycc and its selfhosting nature (when did it originally become selfhosting) in the pre-mes-m2 working era
<stikonas>oh I see...
<stikonas>well, I guess initially gcc was used to build it
<stikonas>also what should we do with CI?
<stikonas>CI run step on public CI executors is probably too long by now
<stikonas>with all these GCC versions it's already way longer than anybody would allow
<stikonas>should we just disable it and leave only linters?
<fossy>yes, for now at least
<fossy>I am thinking of running an asychronous CI bot on my personal computer (which is not on 24/7) which posts results to github using a bot
<fossy>but I am not sure if software exists to accomplish this
<stikonas>there is definitely software for this
<stikonas>but not sure if there is something that is not overkill
<stikonas>I know that Jenkins can definitely update github CI status
<fossy>I think Jenkins has that but Jenkins is a bit over the top
<stikonas>indeed
<fossy>lol
<fossy>it dosent even have to have the green check mark on CI. Could just be a github comment
<stikonas>well, github api for that is probably not even that complicated
<fossy>no, probably not. github has sane apis
<stikonas>should we pull in GCC 4.7.4 though?
<stikonas>into live-bootstrap
<stikonas>I think that's still useful
<stikonas>it's the last GCC that does not need C++
<fossy>yes, keep gcc 4.7.4
<fossy>we could add guile or push it back to later, up to you, I dont really mind either way (even if it isnt strictly relevant rn)
<fossy>we will probably need it in the foreseeable future though
<stikonas>hmm, guile works but it is really slow to build
<fossy>yeah cause of the *.go files right?
<stikonas>well, maybe let's keep it in the branch...
<stikonas>yeah, those *.go take almost an hour
<fossy>Holy crap
<stikonas>it doubles build time
<fossy>they only took like 15 mins when I compiled locally outside of live bootstrap
<stikonas>well, maybe -j$(nproc) outside live-bootstrap
<stikonas>potentially we should start parallelizing build...
<stikonas>fossy: btw, this is the error from libstdc++ https://paste.debian.net/1203412/
<fossy>how odd
<fossy>I cannot make sense of that
<oriansj>well it looks like /after/gcc-4.7.4/build/gcc-4.7.4/build/libstdc++v3/include/bits/os_defines.h on line 45 was mangled by libtool
<Hagfish>libtroll
***cadmium.libera.chat sets mode: +o ChanServ
***cadmium.libera.chat sets mode: +ooo ChanServ oriansj janneke
<stikonas>fossy: would you mind if I only changed tripplet from 4.7.4 onwards?
<stikonas>and keep older ones i386-unknown-linux-gnu for now
<stikonas>I mean from GCC 4.7.4