IRC channel logs

2021-06-24.log

back to list of logs

<oriansj>Melg8[m]: looks like I solve the Global buffer overflow in collect_weird_string and only have 1 left to go (assuming the other 2 are good)
<oriansj>Melg8[m]: I have slightly diffferent results https://paste.debian.net/1202197/ when trying https://github.com/oriansj/M2-Planet/issues/20
<stikonas>oriansj: you probably want to close solved issues...
<stikonas>or are you waiting for Melg8[m] to confirm...
<oriansj>stikonas: I try to confirm if possible before closing issues as I believe issues need to be fully addressed. The only time I close an issue without discussing it first is if they don't respond within a reasonable amount of time (6months usually)
<oriansj>Although without the -fsanitize=address it does show such memory leaks but honestly some of them don't seem valid like: by 0x10A466: new_primitive (cc_types.c:60) (which is allocating a type node found in the global types list) unless I am supposed to allocate more than just the size of the struct???
<pabs3>LWN quoted the bottom turtle post: https://lwn.net/Articles/860273/
<Melg8[m]>oriansj: valgrind and sanitizers doesn't work together, so it meant to be one or another - without address sanitizer but with valgrind, or compile with sanitizer, but run without valgrind. Usually they report mem leaks if something were allocated with malloc/calloc - call, but never got deallocated with free until the end of program.
<oriansj>Melg8[m]: ok, that makes sense
<oriansj>in which case, we absolutely do not free anything in M2-Planet because everything allocated into memory *might* be needed for introspection or absolutely *is needed* for basic function of the compiler.
<oriansj>and going through the trouble of freeing everything right before an exit doesn't seem that useful.
***ChanServ sets mode: +o oriansj