IRC channel logs

2021-06-03.log

back to list of logs

<Melg8>right now i try to strictly reproduce versions/repositories used by live-bootstrap - so i can double-check that i rebuild all with same hashes, but if i decide to update - M2libc will now contain this .M1 files?
<stikonas>Melg8: don't forget that building GCC involves more than C compiler
<stikonas>your also need e.g. bison
<stikonas>maybe M2-Planet -> TCC would make more sense than GCC directly
<Melg8[m]>i don't like tcc because it supports only x86
<Melg8[m]>or am i wrong?
<stikonas>Melg8[m]: you are wrong, TCC supports more arches
<stikonas>at least arm as well
<stikonas>maybe unreleased tcc from git supports other arches too, but that support will have to be ported to older tcc as well
<stikonas>we won't be able to build it directly anyway unless we improve m2libc (or meslibc)
<stikonas>at the moment latest tcc snapshot can only be built after musl (although we don't build unreleased tcc shapshot)
<oriansj>Melg8: if you really don't like TCC perhaps you would be interested in 2 of our existing proposals: 1) extend MesCC to be able to Compile GCC 2) M3
<stikonas>but both are probably harder than improving TCC...
<oriansj>stikonas: no disagreement there but then again we don't know but odds are which ever gets done first probably was easier in the first place.
<oriansj>like the previous argument of which is easier: writing a C compiler in assembly and then compile a scheme in C or just writing a scheme interpreter in assembly.
<oriansj>Turns out sometimes the harder problem is faster and easier but sometimes it looks harder because it actually is harder.
<oriansj>So we leave it up to the developers who choose to do work to do what they think will be fun and interesting rather than what *might* be the more efficient use of resources.
<oriansj>as we already spent 5+ years bootstrapping and it'll never actually be unquestionably "done" because there will be new languages, challenges and ideas to solve. Make your time spent something you enjoy doing rather than making my mistake of chasing something that seemed close but was never fun to work on. (those bits just end up frustrating me and remain in eternal limbo)
***terpri is now known as robin
<oriansj>and sha256sum in mescc-tools-extra now works correctly when built by M2-Planet for 64bit targets.
<oriansj>a nice little 22line delta
<oriansj>now just to finish the wiring into stage0-posix and then live-bootstrap will have everything they could want right out of the gate; a shell written in C (kaem), a C compiler (MesCC), a scheme interpreter (mes-m2), an assembler (M1), a linker (hex2), the ability to make debuggable binaries (blood-elf), the ability to know what your host is (get_machine), the ability to combine files (catm), the ability to change file permissions (
<oriansj>chmod), the ability to copy the contents of files (cp), the ability to know a binary is a perfect match (sha256sum), the ability to extract a compressed file (ungz) and the ability to unpack an archive (untar). (even have a bonus checksum sha3sum too)
<oriansj>(oh an a fallback C compiler too [M2-Planet])
<oriansj>^an^and^
***ChanServ sets mode: +o oriansj
***ChanServ sets mode: +o janneke
<siraben>stikonas: yeah it wasn't an emulated build
<Melg8[m]>oriansj: that's really great! but can you make a directory?) or cp -r?
<stikonas[m]>cp -r is not strictly needed early on
<siraben>oriansj: amazing
***nimaje1 is now known as nimaje
***platinum.libera.chat sets mode: +o janneke
<Melg8[m]>@stikonas i mean that two is essential for things nix do by default - you need to create folder ${out} and you need cp -r because if you don't - all sources would be in /nix/store and not in build folder - and than you need to fix all build scripts to use /nix/store/sha256hash-name-of-packet. Which is... fun but, not really))
***sm2n_ is now known as sm2n
<Melg8[m]>can gnu mes build gash? (https://savannah.nongnu.org/projects/gash/) or it's not enough?
***Server sets mode: +cnt
<Melg8>janneke thanks!
<fossy><siraben> fossy: Wed 02 Jun 2021 15:05:10 PM UTC to 15:59 UTC
<fossy>Wtf without kvm
<fossy>Thats like my times with kvm