IRC channel logs

2021-03-25.log

back to list of logs

<fossy>stikonas: I dont care about speed too much right now
<fossy>keep -O2
<stikonas[m]>Ok
<stikonas[m]>OK...
<fossy>reasoning for O2 being that compiling with O0 often makes generated programs slower and also some programs wont operate correctly
<fossy>Also if we compile gcc with O0 it will take shorter to compile but the produced gcc will be slow
<fossy>And gcc is meant to build with O2
<dannym>janneke: https://git.radicallyopensecurity.com/ros/off-nlnet-ngip-gnumes/-/issues?state=opened
<dannym>janneke: Especially https://git.radicallyopensecurity.com/ros/off-nlnet-ngip-gnumes/-/issues/23 O_O
<janneke>dannym: /me looks
<dannym>(am in meeting with security guy right now)
<janneke>(me is in another meeting)
<bauen1>dannym: what are those issues you've posted ? (they're behind a login i don't have but the name sounds interesting)
<pder>stikonas, fossy: I pushed a branch called overlay that you might find useful for saving time. I basically ran a built up to and including the tcc build and then created a tarball of all the generated files from the build up to that point. rootfs.sh extracts this overlay tarball on top of tmp, and base.kaem.run and after.kaem.run are commented out up to the point of the tar. The result is
<pder>the build skips the slow mes and tcc build steps
<pder>You can cherry-pick that commit into your branch and the build will start right after the tcc step
<stikonas_>pder: oh thanks, that can be helpful for development
***stikonas_ is now known as stikonas
<stikonas>pder: I think I also know how to proceed with autotools, I'll try in the evening
<stikonas>adding use File::Glob; to aclocal-1.10 fixes it with our perl
<stikonas>I might be able to finish autotools then
<stikonas>(and that should unlock more stuff, in particular xz and probably newer gcc)
<pder>stikonas: very nice
***darius_ is now known as Darius
<OriansJ>fossy: well we should have a few guix people here who might be able to help create those packages
***Server sets mode: +cnt
***nore is now known as Guest73201
***jelle is now known as Guest43856
***Noisytoot_ is now known as Noisytoot
***Noisytoot is now known as Noisytoot__
***Noisytoot__ is now known as Noisytoot
***sbp_ is now known as sbp
***nckx[2] is now known as nckx
***Guest73201 is now known as nore
***Server sets mode: +cnt
***ba is now known as bandali
***cbaines_ is now known as cbaines
***bauen1_ is now known as bauen1
<stikonas>pder: fossy: by the way, should we build gcc with a single pass or --with-enable-bootstrap I think at the moment gcc that we built hasn't reached stable point yet. On the other hand it's probably not too important
<fossy>stikonas: its probably better to do the full three-stage bootstrap for now. should iron out a number of residual problems from tcc; let me check what guix does
<fossy>stikonas: on another note, can your remind me how the tcc -ar cr lots of .a issue was worked around for musl?
<stikonas>yeah, I think the reason why we are not stable
<stikonas>is that gcc was rebuilt against latest musl
<stikonas>probably nothing to do with tcc...
<stikonas>so I guess it somehow needs 2 rebuilds
<stikonas>in any case, we did 2 builds of gcc (just separately, not in one go)
<stikonas>and I'm preparing PR for xz now
<stikonas>it's not the newest xz, but I think it makes sense to get it as soon as possible, and finish autotools later...
<stikonas>xz compression is so much better
<fossy>yeah, sounds good
<stikonas>so 2 different xz versions + autotools xz tarballs will be much smaller than 1 xz + autotools bzip2/gzip tarballs
<stikonas>fossy: and regarding tcc -ar
<stikonas>we patched mes libc
<fossy>oh, yeah, i remember now
<stikonas>so that it has support for more than 256 arguments
<stikonas>or something like that
<stikonas>there was also an issue with weak symbols
<stikonas>that was much hackier :(
<stikonas>fossy: did you hit it with kernel?
<fossy>stikonas: well i was trying to remember if i needed to do anything to fix it with kernel, yes