IRC channel logs

2021-03-09.log

back to list of logs

***scs is now known as Guest81063
***scs is now known as Guest13375
***scs is now known as Guest28582
***scs is now known as Guest91961
***scs is now known as Guest53508
<fossy>132K patches later, kexec-tools is done
<fossy>well
<fossy>it compiles
<fossy>that dosen't mean it runs
<fossy>only 2k loc patches tho, that's not too bad
<Hagfish>fossy: yeah, that's pretty good
<Hagfish>assuming it works, what happens next?
***scs is now known as Guest33678
***^_ is now known as V
***deltab_ is now known as deltab
***vup2 is now known as vup
***scs is now known as Guest28120
<pder>stikonas: With perl 5.6.2, I tried replacing the config.h you created with one generated from running Configure. miniperl builds but segfaults doing miniperl configpm lib/Config.pm. It actually always crashes. Did you encounter anything like this?
<stikonas>pder: no... maybe you need to take config.sh too?
<pder>Replace config.sh with the generated one?
<stikonas>yes
<pder>I can try that. How did you arrive at the config.h that you used?
<stikonas>well, started with earlier config.h from perl 5.5
<stikonas>tried building
<stikonas>and addign stuff to it until it compiled
<stikonas>so it is very minimal
<pder>something is very strange because I can set a breakpoint in main in gdb and single step and it steps through unrelated code in perly.h
<stikonas>is that with tcc?
<stikonas>hmm, it shouldn't be doing too many optiomizations
<pder>yeah
<pder>if I rebuild perl after the 3rd tcc musl rebuild the build completes and miniperl works
<pder>Oh and autoconf-2.57 now builds
<stikonas>oh good
<stikonas>pder: with full config.h?
<pder>thats with full config.h- so now I can try to update your original config.h with whatever was missing
<stikonas>I tried FORK/VFORK but without musl rebuild...
<pder>Could perl-5.6.2 be moved after tcc-musl v3? Or is it needed for the other autoconf versions?
<stikonas>hmm...
<stikonas>I am not sure
<stikonas>need to test
<stikonas>that means we need to go with older libtool though
<stikonas>to be able to run with older autoconf
<stikonas>pder: if you can try too see what's the newest autoconf that works
<stikonas>newer gawk might need quite a bit newer autoconf
<pder>ok, I will try testing
<stikonas>although, I think new autoconf will also print that gawk error on configure
<pder>It's rather tricky- I think things would be simpler if we just had binutils ar earlier
<stikonas>yeah, that's true...
<stikonas>but binutils is fairly big...
<stikonas>it might be hard to build it without autotools
<pder>I wonder what perl version is needed for autoconf-2.52
<stikonas>it should be in configure.in
<stikonas>pder: autoconf 2.52 does not use perl yet
<stikonas>only automake
<stikonas>pder: looks like quite low requirements on perl version
<stikonas>although, I'm not sure if we install enough things in older versions, but that's fixable\
<stikonas>I think it should work with 5.5
<stikonas>we do install lib directory
<pder>I want to test moving perl-5.6.2 to after tcc musl v3
<stikonas>pder: so I guess try moving build after binutils
<stikonas>yeah...
<stikonas>it looks like it should work
<stikonas>and then I hope I can solve libtool issue
<stikonas>without resolvign to newer autoconf
***scs is now known as Guest72330
<pder>stikonas: I can get build up to autoconf 2.61 by running configure followed by make
<pder>But we would probably need to incrementally build each version running autoconf and/or automake until we get to this version
<stikonas>no, we can't do that
<pder>After 2.61 I start to get gawk errors on configure
<stikonas>2.53 depends on 2.53
<stikonas>we need to rebootstrap it from scratch
<pder>whats the procedure?
<stikonas>well, not sure if it's the same, but besically I used sed to replace placeholder variables
<stikonas>but I don't know if it will work with more complex autoconf
<stikonas>now that it uses perl...
<stikonas> https://github.com/fosslinux/live-bootstrap/blob/master/sysa/autoconf-2.52/stage1.sh
<stikonas>pder: alternative might be to patch out 2.53
<stikonas>not to depend on 2.53
<stikonas>I think it needs them for tests
<stikonas>this might be a bit nicer
<stikonas># We need AC_CONFIG_TESTDIR.
<stikonas>AC_PREREQ([2.53])
<stikonas>then maybe we can bootstrap up
<pder>sounds a little painful
<pder>I was able to move perl 5.6.2 to after tcc musl v3
<pder>And it appears the hang problem has gone away
<pder>But I need to simplify config.h
<stikonas>well, patching that line out might be less painful
<stikonas>than trying to use sed, etc to install autoconf without autotools
<pder>Should we keep every version around just in case for later?
<stikonas>we probably don't need to...
<stikonas>although, it's not hard to keep them
<stikonas>I have one sed liner that makes them coinstallable
<stikonas>we do need some versions though
<stikonas>binutils needed both 2.12 and 2.13
<stikonas>2.61 also needs newer automake than what we have
<stikonas>so we still need some kind of stepping up
***scs is now known as Guest10881
***scs is now known as Guest28001
<stikonas>pder: I have some success with perl
<pder>cool, what did you do?
<stikonas>just added a few HAS_* degfines
<stikonas>just a few
<stikonas>now need to check which one of them does it
<stikonas>I suspect FCNTL
<stikonas>but let's see
<pder>Ah, could be- I had started to narrow it down
<stikonas>yeah, I think it's HAS_FCNTL
<pder>so that fixes the hang?
<stikonas>yes
<stikonas>although, just HAS_FCNTL doesn't work
<stikonas>it depends on something else...
<stikonas>let's see
<stikonas>anyway, these are small diffs...
<stikonas>10 additions max
<stikonas>just FCNTL gives tcc: error: undefined symbol 'do_aspawn'
<stikonas>I think I need fork too
<stikonas>yes those too
<stikonas>HAS_FORK and HAS_FCNTL
<pder>maybe #define I_FCNTL
<stikonas>I have that already
<stikonas>we already had it
***scs is now known as Guest23264
<stikonas>pder: ok, I'll try to move this perl to after musl v3 then
<pder>In your testing, were you building perl before or after musl v3?
<stikonas>hopefully it doesn't affect any checksums
<stikonas>I rebuilt perl after musl v3
<stikonas>I don't know if that is necessary
<stikonas>I can try to first do a run without moving perl
<pder>For some reason it did make a difference using the config.h generated by Configure
<stikonas>if that works, that would be preferable...
<stikonas>oh, but that might be using more stuff
<stikonas>anyway, let's test
<stikonas>oh, we actaully alraedy gave HAS_FORK
<stikonas>so it's just adding FCNTL
<stikonas>anyway, started the run, let's see in 20 minutes
<pder>I dont know if you noticed this, but when getting that hang in autom4te, I would hit Ctrl-C and get a bunch of garbage output
<stikonas>I don't think I noticed this
<stikonas>luckily fcntl is early in the alphabet, so I found it really quickly
<stikonas>especially after you told that it's stuck in read
<stikonas>so I was just going over the headers that have something to do with it
<Hagfish>did the run succeed?
<stikonas>Hagfish: decided to first do rerun with updated perl hash
<stikonas>probably need 10 more minutes
<Hagfish>cool, i look forward to the result :)
<stikonas>but it will work one way or another
<stikonas>it's just a matter of whether we need to move perl to after musl v3 or just keep it where it is
<Hagfish>yeah, that's a weird constraint to manage
<stikonas>that will determine when we can get newer autotools, but it's not a particularly big deal
<stikonas>well, before binutils I still need to insert libtool...
<stikonas>so I guess it affects libtool version
<Hagfish>does libtool have dependencies?
<stikonas>Hagfish: yes, so will be milldly annoying
<stikonas>it obviously needs autoconf/automake
<stikonas>but it does have some checks for ar and ld
<stikonas>which I might be able to replace with tcc -ar and true
<Hagfish>i get the feeling that the further through the bootstrap process, the bigger the targets, and the more dependencies they have
<stikonas>although, it's more of an issue that I've no idea about libtool or how to use it, so need to read some manuals
<Hagfish>yeah, tricky
<stikonas>Hagfish: that's true, but we have more stuff already
<stikonas>so it does not get tricker
<Hagfish>right, it's nice if the two effects cancel each other out
<stikonas>especially when we don't need to write makefiles, find out the right config, etc..
<stikonas>once we have libtool
<stikonas>then autoconf/automake/libtool form the whole GNU autotools build system
<stikonas>right now we only have old autoconf and old automake
<Hagfish>i don't know if there's a community out there that specialises in libtool-related questions
<stikonas>GNU...
<stikonas>but anyway, there are plenty of manuals
<Hagfish>yeah, i guess something so well established should have decent docs that will shed light on any edge case you hit
<stikonas>anyway, it should be doable...
<stikonas>it's a shell script after all
<stikonas>nothing more complex
<Hagfish>yeah, no reason to think it's any harder than the existing steps
<stikonas>Hagfish: pder: so perl can be kept where it is
<stikonas>just adding that define works
<stikonas>there is a warning from perl that might be nice to fix
<stikonas>Use of uninitialized value in concatenation (.) or string at /after/lib/perl5/5.6.2/Errno.pm line 11.
<Hagfish>interesting
<stikonas>but it's just a warning
<stikonas>printed by "$Config{'archname'}-$Config{'osvers'}" eq
<stikonas>I guess we can add those variables to config.sh (?) if we want
<Hagfish>yeah, why not