IRC channel logs

2021-01-26.log

back to list of logs

<stikonas>is there something like -p1 from patch for diff?
<stikonas>hmm, maybe not, manpage is not helpful...
<mid-kid>editing the file manually :P
<stikonas>mid-kid: well, that's what I did, although with M-x replace-string
<mid-kid>Or doing something like `diff -Nur ../dir.orig .`
<mid-kid>Ah, yeah
<stikonas>hmm, I think my lex is still a bit broken, needs more work...
<stikonas>(it compiles though)
<stikonas>but the good news is that yacc seems to work
<OriansJ>xentrac: a 2+ year project to implement RISC-V in 74 logic chips sounds like it isn't that simple of an architecture to implement in hardware. But I am probably missing something because I still don't see it.
<OriansJ>Especially since the Monster6502 was done in less time and at a lower level too.
<OriansJ>bauen1: I could do sha256sum in M2-Planet C (or in M0 assembly if needed earlier); although crc32 would be easier (and I could have that done by tomorrow)
<mid-kid>Is there a way to force GCC to use a certain __DATE__ and __TIME__ or does that require patching any sources that use it?
<OriansJ>stikonas: one thing you might not have noticed is every binary in mescc-tools-seed's bootstrap chain has a checksum in SHA256SUMS
<OriansJ>mid-kid: SOURCE_DATE_EPOCH
<mid-kid>That a flag or env var?
<OriansJ>If this variable is set, its value specifies a UNIX timestamp to be used in replacement of the current date and time in the "__DATE__" and "__TIME__" macros
<OriansJ>so that the embedded timestamps become reproducible
<mid-kid>Ah, nice.
<mid-kid>Thanks.
<OriansJ>always glad to help ^_^
<xentrac>OriansJ: I do think RISC-V is more complex than the 6502! but keep in mind that the Monster6502 was done by somebody who wasn't learning basic EE or struggling with serious depression at the same time, and also didn't have to design the circuits
<xentrac>the original 6502 design *also* took less than 2 years, but it was a group project by some of the best sandbenders in the business
<fossy>ahh, how very nice.
<fossy>tinycc segfaults on hexadecimal numbers in assembly
<xentrac>OriansJ: I think RISC-V is more comparable to the Z80 than to the 6502. but all the buses and registers are four times as wide. fortunately multiply is optional though implementations like the Bumblebee do have it
<OriansJ>xentrac: I don't think learning basic EE is a solid excuse because 2 years is a degree. But I do feel depression is a super power, that keeps you from wasting time on things that don't matter.
<stikonas[m]>fossy: so yacc pr can probably be merged... I think yacc works but lex is a bit broken
<fossy>stikonas[m]: ok, cool
<fossy>finished compiling all of linux 2.4.26
<fossy>now need to figure out linking
<xentrac>OriansJ: yeah, if he were working on it steadily for 2 years, he surely would know a lot about EE, but he says he wasn't. depression definitely has its upsides but it's a hell of a drug; it's killed more of my friends than opiates have
<OriansJ>xentrac: well depression without perspective is dangerous
<OriansJ>but when in the right frame, makes one free to solve every problem in their life and free themselves from the shame and guilt that might trap them otherwise.
<OriansJ>It is only when you are willing to give up everything are you free to get anything you really want.
<OriansJ>Hate your life and want to die => you are now free to do anything to fix your life.
<OriansJ>Relationship making you depressed => leave and find someone who makes you happier.
<OriansJ>Hate your boss and job => sleep with his wife and collect unemployment.
<OriansJ>Life feels like a series of meaningless copies => Punch a shark, run with the bulls and try to seduce The French President's Niece.
<OriansJ>even if it is 99% dangerous, still safer than 100% lethal.
<OriansJ>But perhaps that is because I turned the corner with my depression. Once it clicked, suddenly I was free and now I am "stuck" in happy meaningful relationships with people I like doing things I enjoy. Like interacting with the great people here on this channel (or the bootstrappable matrix channel i setup)
<pabs3> https://collapseos.org/ https://news.ycombinator.com/item?id=25910108
<pabs3>"preserve the ability to program microcontrollers through civilizational collapse"
<siraben>yeah, it's been featured a few times on HN, impressive
<xentrac>OriansJ: hmm, interesting
<xentrac>I'm glad you're doing well!
<xentrac>should we put the matrix channel in the topic? is that permitted on freenode? ISTR some kind of clash with Debian over something like that
<siraben>There's a Matrix channel?
<siraben>am currently bridged via Matrix
***mephista is now known as spicy_icecream
<gio>stikonas[m]: Thanks.
<gio>Great to see you're doing progress!
***mephista is now known as spicy_icecream
<bauen1>OriansJ: the 6502 is a lot less capable than any RISC-V design, and while running something to resemble POSIX-ish on the 6502 is possible (lunix irrc) it's severly limited
<bauen1>OriansJ: could still be a good platform to be used in a bootstrap if you want some tools (e.g. a simple compiler) because you need some blobs in a linux-capable design
<bauen1>OriansJ: crc32 would be a good primitive tool to have, but don't worry too much about the whole hash thing yet, more thinking needs to go into it before doing any sort of implementation
<bauen1>some more thought needs to go into what hash algorithme*s* to use and what can be done if one of these is found to be insecure (or rather soon to be insecure)
<gforce_de1977>fossy: whats to idea of fiddling with linux 2.4.26? just a small kernel?
<stikonas>gforce_de1977: that's what you can build with tcc
<stikonas>building 2.6 is probably harder
<stikonas>at that stage of bootstrap you'll need more syscalls, so more powerful kernel
<stikonas>than bootstrap kernel potentially needs
<stikonas>(we dont have proper bootstrap kernel yet, so just using linux for now)
<stikonas>fossy: if possibly it would be nice to make kernel build step optional...
<stikonas>and kaem does not support conditionals (even though we dot have "test" now), so maybe some step should be offloaded to make
<stikonas>if kernel is optional, then we will not break chroot build
<bauen1>stikonas: are you sure that the bootstrap kernel needs to support many syscalls ? iirc gcc doesn't need too many syscalls to run (comparable to what tinycc needs), and can compile linux
<bauen1>or are there some major components i'm missing
<bauen1>i suppose make might require some timing syscalls, process groups and env related syscalls
<stikonas>bauen1: bash needs quite a few...
<stikonas>in any case we'll probably start using pipes, etc...
<stikonas>in any case, if we can build a proper kernel we can as well do it
<gforce_de1977>stikonas: aaaah, i see: tcc kernel-2.4.26 is at least a good start
<stikonas>I think it's supposed to be mid point later...
<stikonas>i.e. bootstrap kernel-> linux 2.4 -> new linux
<stikonas>fossy: is it much harder to build 2.6.27?
<gforce_de1977>stikonas: for now i'am *not* sure if 2.6 is harder to built (but thats just a feeling)
<stikonas>well, if 2.6 is the same we can try to build first linux-libre version...
<OriansJ>siraben: yes there is matrix chennel. I named it bootstrappable and the Topic is "stage0 bootstrapping of the world. A 250byte hex0 assembler at a time" but thus far it is relatively quiet
<xentrac>OriansJ: #bootstrappable:somewhere.org or something like that?
<OriansJ>xentrac: just bootstrappable:matrix.org
<OriansJ>#bootstrappable:matrix.org as an alias
<OriansJ>or not
<OriansJ>or is that just the default?
<OriansJ>to prefix everything with # for rooms
<OriansJ>I am also on matrix and discoverable with my email address available for lookup
<stikonas>there is also this IRC channel bridge to matrix
<OriansJ>really?
<stikonas>OriansJ: yes, let me find it
<stikonas[m]>#freenode_#bootstrappable:matrix.org
<OriansJ>which looks not to actually be bridged
<stikonas>strange, did I not write from it...
<stikonas>hmm
<stikonas>well, I searched for bootstrappable from neochat client
<stikonas>there were two results, one has 93 people, the other 2
<JeremiahOrians[m>test
<siraben>success!
<siraben>Oh you're coming in from Matrix
<JeremiahOrians[m>good
<siraben>Jeremiah Orians: which client are you using?
<JeremiahOrians[m>the default vector client right now
<OriansJ>sorry "Element"
<stikonas>Element is that web client?
<siraben>Yeah
<siraben>Hmm I still eventually have plans to move to weechat-matrix client but haven't gotten it set up
<stikonas>well, a month or so ago I moved to https://invent.kde.org/network/neochat
<JeremiahOrians[m>nice
<OriansJ>#freenode_#bootstrappable:matrix.org bridge requires one to do !join #bootstrappable in the appservice-irc:matrix.org first
<stikonas>oh ok, maybe my matrix client did that for me...
<JeremiahOrians[m>very possibly
<stikonas[m]>/rainbow matrix test
<stikonas>argh, only matrix is coloured...
<JeremiahOrians[m>yep. IRC will only color if you do ANSI color codes
*stikonas[m] tests me command
<stikonas>ok, /me is working
<qyliss>colour is disabled in this channel
<qyliss>because it's +c
<JeremiahOrians[m>thanks qyliss
<JeremiahOrians[m>the big problem for me on matrix besides having to use the touch screen is how slow it is
<OriansJ>oh well
<xentrac>ah, on matrix.org, cool
<siraben>OriansJ: were you using it on a mobile device?
<JeremiahOrians[m>ssshhh. yes
<xentrac>JeremiahOrians[m: I've found that, among matrix clients, gomuks is nice and responsive
<xentrac>it's not all that full-featured but it sure is fast
<pabs3>JeremiahOrians[m: why do you have [m rather than [m] on your IRC-side nick?
<JeremiahOrians[m>blame my client and me not caring as my name probably hit a char limit
<pabs3>ah, makes sense
***deesix_ is now known as deesix
<stikonas>fossy: did you say sed s/ was broken?
<stikonas>fossy: somehow it works for me
<stikonas>at least this command worked /after/bin/sed 's/yylex/flexscan/g' -i lex.yy.c
<fossy>stikonas: what how !!!!
<fossy>let me try it again shortly
<bauen1>hm, somebody just send a patch for basic atomics support for tinycc, would make my kernel life a lot easier
<bauen1>imo c11 has a lot of small but much needed improvements
<bauen1>so now you just need to wait a couple of decades longer until you can be sure that everything you would want to target supports them ...
<stikonas>fossy: well, I was trying to run that sed command in flex 2.5.1...
<stikonas>I still don't have a properly working lex though...
<stikonas>I think I mis-patched it, need to start from scratch and try to do it more carefully...
<stikonas>(lex does seem to run but generated .c file seems to be missing some stuff, so I think lex exists too early)
<stikonas>fossy: I've split my commit into two, I only left yacc part now https://github.com/fosslinux/live-bootstrap/pull/19
<stikonas>so I think we can merge it
<stikonas>and I'll open lex PR later once it's fully functional
<fossy>stikonas: okey
<stikonas>and in the meantime I'm trying to redo lex...
<stikonas>well, yacc was tested on both lex and flex 2.5.1 and it fully worked
<fossy>yeah ok that's fine
<fossy>once CI finishes ill merge
<fossy>go 20
<fossy>oops