IRC channel logs

2020-12-12.log

back to list of logs

***yt is now known as yt_
***scs is now known as Guest87482
<siraben>pder: out of curiosity what command did you run to apply the patch?
<siraben>to lonely.hs
<pder>I actually just patched it manually
<pder>Then I made a few more changes on those ffi lines
<siraben>I see
<pder>I figured out how to get it to build though. There were some hints in that site directory
<siraben>could you send the new diff?
<pder>Can you fetch from my repo? I just pushed the modified lonely.hs to the ghc-compat branch
<pder> https://github.com/pder/blynn-compiler.git
<siraben>nice, it works.
<siraben>what hints were there in the site folder?
<pder>I did a git grep ioBind and ioPure
<siraben>Ah various wrap*.hs files I see
<pder>and exitSuccess
<siraben>Ben Lynn must have used these to work with the Haskell files
<pder>How close is the precisely (the final stage) of blynn-compiler to Haskell?
<siraben>very close
<siraben>Modules are missing, though
<siraben>it's very idiomatic since now he has guards and equations
<pder>So i wanted to try running lonely in ghci but with redirecting input like < patty.hs. Do you how I could do that?
<siraben>use runhaskell to run something in script mode
<siraben> echo "main s = s;" | runhaskell lonely.hs
<pder>I still wanted to have debugging capabilities. In gdb I would do "set args < patty.hs"
<siraben>pder: it doesn't appear that lonely.hs read any arguments, so you can just use the REPL exclusively
<siraben>Type this at the REPL; `do { x <- Prelude.readFile "lonely.hs"; putStr (compile x) }`
<pder>awesome, thanks
<siraben>Or equivalently, `Prelude.readFile "lonely.hs" >>= putStr . compile`, heh.
***scs is now known as Guest87665
***ChanServ sets mode: +o rekado_
***rekado_ is now known as rekado
<OriansJ>nice to see the haskell side of the equation making good progress.
<OriansJ>yt: I should be done reviewing later today (assuming no other hardware problems expode in my face today)
<yt_>OriansJ: awesome, I'll put up a pull request for kaem once cc_aarch64 is merged
<siraben>9732a8852bf92b4097f275da4ceba3b718138a5e16190cbef43bbd4be42a27dd bin/raw
<siraben>i built blynn-compiler on my phone running i686 using https://ish.app/
<rain1>wow!
<OriansJ>siraben: prefect reproducibility is the goal
<OriansJ>siraben: wait until you discover using M2-Planet and mescc-tools on armv7l/PowerPC/MIPS/etc and the steps inside of go.sh; the generated binaries are identical too
<OriansJ>one needs only to use the armv7l or AArch64 bits in M2-Planet to get working binaries that also produce identical output for bin/raw
<siraben>nice! I have an armv7l-based tablet i could try
<OriansJ>siraben: give me a couple moments and I'll have something special for you
<OriansJ> http://paste.debian.net/1176622/
<OriansJ>warning ./bin/vm is *SLOW* (I'll time it later for raspberryPI)
<OriansJ>and yes bin/raw will also be 9732a8852bf92b4097f275da4ceba3b718138a5e16190cbef43bbd4be42a27dd
<OriansJ>and generated/lonely.c will be b93440e0ee8b01ba173d88f8774717245819512bdf55e48d47f7ac7eb46ea4e4 (identicial to x86 generated output)
***scs is now known as Guest44764
<OriansJ>looks like 8 minutes and 6 seconds to generate bin/raw but in the scheme o things; not half bad
<OriansJ>and ./bin/vm -f lonely.hs -l bin/raw run effectively.hs >> generated/lonely.c on raspberryPI is taking just 3minutes and 20 seconds (when built with M2-Planet and mescc-tools)
<OriansJ>siraben: a similiar patch will work for AMD64 and AArch64
<siraben>OriansJ: Thanks! I'll try the patch tomorrow.
<OriansJ>yt: finished reviewing the DEFINEs and should be done reviewing in the next couple hours
***scs is now known as Guest6425