IRC channel logs

2020-12-11.log

back to list of logs

***scs is now known as Guest54828
<siraben>pder: sure thing, the key is `maybe undefined showInt (mlookup (fst $ last qas) tab)`, this means look up (fst (last qas)) in tab, which is a map. This returns an optional value so the maybe function returns undefined if the value is Nothing, and showInt otherwise.
<siraben>looks like he is using difference lists to represent the strings. This encoding means that a difference list of chars `s` isn't of type String but String -> String, it is a function that prepends the contents of s. This means that concatenation can be done in O(1) time by function composition
<pder>Thanks siraben. I think that we can probably build up to the virtually step of blynn-compiler using our existing vm, and rts.c wont be needed. The only inputs we need for each step are the prog array and the value for rts_reduce. From virtually on, I haven't figured out the best approach. It might mean changing some of the C code generated by the hs files to be suitable for M2-Planet
<siraben>Ok. I understand the how the C code generation works (it's just list traversal and string concatenation), so let me know how you want it transformed.
<pder>Cool, thanks!
<pder>siraben, I tried out your patch for effectively.hs. That works really nicely, and will be very useful. Is there a debugger you use with ghc for tracing through code?
***ChanServ sets mode: +o rekado_
***rekado_ is now known as rekado
<siraben>pder: I usually use the REPL for debugging, try it out with ghci effectively.hs, or ghci then type :l effectively\n to load, then reload with :r
<siraben>you can set breakpoints and such in GHCi https://wiki.haskell.org/Debugging
<pder>thanks. I noticed the output of effectively < lonely.hs is different with respect to prog and the rts_reduce, but I think that is due to the fact that bin/raw is not loaded first
<pder>I tried applying your patch to lonely and was able to fix a few compilation errors, but am not sure how to proceed. https://paste.debian.net/1176506/
<pder>*lonely.hs
<siraben>pder: ah that will require a modified patch
<siraben>i'll take a look tomorrow
<pder>siraben: thanks!
***scs is now known as Guest45799
***scs is now known as Guest76722