IRC channel logs

2020-12-07.log

back to list of logs

<siraben>OriansJ: do you mind if I make a PR to blynn-compiler adjusting the readme to better reflect the purpose of the fork?
<siraben>and build instructions etc.
<OriansJ>siraben: I never mind Pull Requests; the worst that happens is I reject them if they seem wrong and try to explain my reasoning for why.
<OriansJ>Otherwise I will review and merge.
<siraben>OriansJ: I just realized that I was copying the wrong file to /share, it should be ./bin/raw not ./bin/vm
<siraben>i'll fix that in a PR
<siraben>so that explains why the hashes seemed mismatched yesterday
<siraben>9732a8852bf92b4097f275da4ceba3b718138a5e16190cbef43bbd4be42a27dd ./result/share/raw
<siraben>I'll also add a test in the CI workflow to check that the hash is that
<yt>OriansJ: I'm wondering if I could reduce the review load if I use fewer M1 macros. hex2 is bad if you want to review all macros by hand, but cc_aarch64 is going to be a *lot* worse still
<yt>For example, I could replace all SET_X0_FROM_X1 with FROM_X0 SET_X1 (push+pop, or move through a temporary register)
<yt>It'll result in worse machine code, which might be harder to debug, but that wouldn't matter too much as I can do those changes incrementally and mechanically
<yt>Thoughts?
<deesix>I guess those are already reviewed, if they are the same as in M2-Planet. Am I missing something?
<yt>deesix: I think M2-Planet's set of instructions is even smaller than that, it only really uses X0, X1 and a stack machine
<yt>I went more for ease of translation from GNU assembly to M1
<yt>but the number of macros got out of hand a bit :)
<yt>see https://github.com/snnw/mescc-tools-seed/blob/master/AArch64/cc_aarch64.M1
<deesix>OK, we'll see what OriansJ thinks. Thanks for the details.
<yt>deesix: sounds good, thanks for taking a look
<OriansJ>yt: hex2 has been merged.
<OriansJ>siraben: I'll look at that Pull reguest later today; So you'll have time to do a rebase if you wish to hide that mistake.
<siraben>Isn't it generally a bad idea to rewrite history on master?
<siraben>But there may not be many clones around so should be fine
<OriansJ>siraben: only if you have downstreams
<OriansJ>otherwise you can rebase to your hearts content until it is merged upstream.
<OriansJ>yt: opt for easier to debug and understand M1 code; The biggest time delay with reviews is dealing with my son.
<OriansJ>I'd rather deal with 1000 DEFINEs than a block of hard to understand assembly.
<siraben>OriansJ: rebased.
<siraben>after finals i'll take a look at using mescc-tools-seed for bootstrapping and see if I can replicate building blynn-compiler without gcc as a dependency
<siraben>OriansJ: It appears that I can remove gcc as a build-time dependency to blynn-compiler. I'll edit the PR
<yt>OriansJ: understood! here is M0 next: https://github.com/oriansj/mescc-tools-seed/pull/16