IRC channel logs

2020-11-16.log

back to list of logs

<OriansJ>hmm char* s = "hello" "world" "indeed";
<OriansJ>that'll be easy to add to M2-Planet
<OriansJ>fossy: also weren't you going to revert the kaem change I made?
<OriansJ>and boom M2-Planet now supports char* s = "hello" "world" "indeed";
<OriansJ>patches are up
<OriansJ> https://paste.debian.net/1172625/
<OriansJ>probably should address gcc 10 and M2-Planet
<OriansJ>nice, I don't even have to update the checksums
<OriansJ>and patches are up for M2-Planet
<OriansJ>no more GCC 10 issues and we now support multi-strings
<vagrantc>the world is spinning every so slightly more smoothly now. :)
<OriansJ>vagrantc: well, it is easy for me to get backlogged these days
<siraben>samueldr: are you building it with Nix?
<samueldr>yeah, but it's mostly for fun, I'm not actually doing a whole bootstrap
<samueldr>I want to get to the tcc for misc. playing around
<OriansJ>samueldr: well the full bootstrap is a little ugly: https://github.com/oriansj/talk-notes/blob/master/Current%20bootstrap%20map.pdf
<samueldr>yeah :) I was aware of it
<samueldr>right now it really is a means to get a tinycc that I can treat as an opaque step that can be filled-in later by the real good stuff
<OriansJ>samueldr: fair
<samueldr>not a judgement against the work, definitely not :)
<samueldr>but having taken a look at it, and even just today's discussions, it looks like it's still moving along at a nice pace
<OriansJ>samueldr: as long as the judgements provide useful suggestions for improvement (and potentially patches); we welcome that here. ^_^
<samueldr>there might be some patches in the end, that either you'll explain away the weirdness I've seen, or are needed changes
<OriansJ>samueldr: honestly if there is weirdness; we should fix it
<samueldr>yeah, it could be that my fix is not the right fix, that something else needs to be done
<OriansJ>certainly something for us to explore.
<OriansJ>The more precise information; the better the answers and potential solutions can be.
<samueldr>yes, sorry, I'm not trying to be obtuse and unhelpful :)
<samueldr>tinycc's current bootstrap.sh has mes_cpu defined using `uname -m`, but doesn't check for x86_64 and i686... or maybe it's $CC -dumpmachine that has the wrong output
<samueldr>I first need to take some time in understanding which bit first before actually reporting :)
<samueldr>and with that, I added some guards, e.g. in the `case` a `*)` with a failure message, rather than continuing with unconfigured values
<OriansJ>samueldr: and if you are having trouble with MesCC; use the known good setup in mes-m2 with guile for faster compiles
<OriansJ>the smaller the failing test; the easier to track down and fix forever
<samueldr>yeah
<OriansJ>and a new patches for mescc-tools-seed are now up
<samueldr>for the time being, it's been more about wrong assumptions, like thinking the amd64 support was working :)
<OriansJ>samueldr: to be honest; I have a hard time keeping track of where things are with MesCC.
<OriansJ>With M2-Planet and mescc-tools; an architecture isn't even listed until after it is in a "Generally working" state.
<OriansJ>AArch64, armv7l, x86, AMD64, knight-native and knight-posix are all working happy now (Just need to find someone with PowerPC [32/64] and RISC-V to get those ports up and running)
<OriansJ>well I am quite certain I got the mapping wrong: https://paste.debian.net/1172639/
<OriansJ>anyone else want to take a shot at figuring out the mapping between the blobs and the comment lines?
<OriansJ>for some reason they are in a seperate block rather than having a 1:1 mapping in the code
<OriansJ>oh and FYI "foobar" and "foo" /* comment */ "bar" /* more comments */; mean the exact same thing in C
<OriansJ>make vm && ./vm >| raw && sha256sum raw (to test that you didn't change the output) [it should be 9732a8852bf92b4097f275da4ceba3b718138a5e16190cbef43bbd4be42a27dd]
<OriansJ>good night and good luck.
<siraben>samueldr: Ah, cool. Eelco has packaged this up as well https://gist.github.com/edolstra/02bf42400dfd82c885fc2409c618df1d
<samueldr>yeah, had that already; the patch is still in guix's tree
<siraben>samueldr: did you adjust it to build on x86_64-linux?
<fossy>OriansJ: oh crap I forgot
<samueldr>I ended up re-doing it from scratch, siraben, though it will build mes, with mescc, and will build hello world equivalents, it won't build tinycc for the time being
<samueldr>if you read today's backlog of this channel, you'll have all the context I know about x86_64 support
<siraben>samueldr: I see. Do you have this uploaded somewhere?
<samueldr>not at the moment
<samueldr>depending on how the i686 build goes, it'll probably end up somewhere
<samueldr>though it's not done with the goal of a full and proper bootstrap; at the time being it's more as a curiosity thing
<samueldr>might be helpful to use as an opaque "all the lower level parts of the bootstrap are blackboxed away" kind of thing
<samueldr>and later draw the rest of the owl
<siraben>RIght. It'd be nice for Nix to eventually benefit from the same bootstrap reduction as Guix has.
<samueldr>it probably will end up benfiting at some point
<siraben>OriansJ: I'll take a look.
<siraben>OriansJ: looks good to me. As a heuristic if you see == on the right and side, it should correspond to the = combinator on the left.
<siraben>Here's the mapping, roughly.
<siraben>= and ==
<siraben>? and undefiend
<siraben>#c and 'c', where c is a character
<siraben>It will at least help one check that the rough composition looks right. To actually verify it one should compile it to combinators.
<siraben>Not sure if it would be ideal to put the mapping side by side for the next phases, since the line lengths would be quite long. I suppose putting just the function name it corresponds to.
<siraben>TIL that `>|` is a specialized form of the `>` operator in bash
<janneke>siraben: there is also: https://github.com/xwvvvvwx/nixpkgs branch mescc
<samueldr>11 months old, but interesting to see it applied to Nixpkgs
<samueldr>looks like it might be helpful in cleaning up what I understand
<janneke>yes; the way we do it in guix is to use the regular mes and mescc-tools packages (from xwvvvvwx) to build the bootstrap binaries to be used in the bootstrap (from edolstra)
<OriansJ>fossy: no worries; it happens to us all
<OriansJ>siraben: so the source code doesn't map to the comment?
<siraben>OriansJ: it should
<siraben>Ah except for uncurry and (.) of course
<siraben>because those are combinators
<siraben>I'll open a PR to your fork to commit the combinators
<siraben>comment*
<siraben>OriansJ: https://github.com/oriansj/blynn-compiler/pull/1/files
<OriansJ>siraben: thank you; merged
<ythier>hello
<ythier>IMHO it's very suspicious that many non-contributing wiki accounts are created daily on https://bootstrapping.miraheze.org
<ythier>I'd say 1 or 2 per day: https://bootstrapping.miraheze.org/w/index.php?title=Special:Log/newusers&offset=&limit=500&type=newusers&user=
<ythier>I see that as a kind of spam
<rain1>thanks
<rain1>i will see what i can do about it tommorow
<rain1>i thought users were global on miraheze
<ythier>I'm certain that users are local to a Mediawiki instance
<ythier>I've already seen such user-creation-spam on other Mediawiki instances
<ythier>It then evolves to create its own user-page with dubious links, and quickly you're hosting things for bot-nets :-/
<rain1>oh yea i see that they are i just didn't expect that
<ythier>a simple way of preventing such user-creation-spam, is to require an human admin to create accounts... but it's not ideal (bottleneck, etc.)