IRC channel logs

2020-11-12.log

back to list of logs

<OriansJ>xentrac: Not AI but the security problem. As in how to compromise an FPGA such that it can compromise any bitstream given to it.
<xentrac>ahh
<siraben>Took a stab at rewriting one of Ben Lynn's bootstrapping phases in Lisp, and it works! https://github.com/siraben/compiler/blob/lispy/binary.lisp
<siraben>Hopefully when I get a reply on licensing I can combine this with mes-m2
<siraben>Essentially, Ben Lynn's project consists of multiple compilers which compile larger and larger subsets of Haskell. I took one of the earlier compilers, adjusted it to accept Lisp syntax, then wrote the next bootstrap in Lisp instead of Haskell.
<xentrac>awesome!
<rain1>great work
<rain1>how much of it runs on top of what you have implemented?
<rain1>also this stuff looks very similar to some of the cool things `Lion was making
<rain1>just that low level lambda/SK stuff
<Hagfish>okay brain trust, i have an interesting technical design question for you (unrelated to bootstraps, i apologise)
<Hagfish>let's say you want a decentralised system where people can put up documents on the web, and other parties can then aggregate those documents
<Hagfish>but you want there to be only one document per person
<Hagfish>(maybe you are trying to find an average of some values, like a wisdom of the crowds thing)
<Hagfish>further, assume that you are happy to settle for "one document per email account"
<Hagfish>with a centralised system, you could do this by having everyone email their document and getting it signed by the central node
<Hagfish>each user could then host the document wherever they wanted, with the signature attached
<Hagfish>but is there some way to do this in a decentralised way?
<Hagfish>i'm thinking that maybe DKIM signatures could be exploited somehow
<Hagfish>oh, but i want the system not to leak the email addresses of the users
<xentrac>blockchain ;)
<Hagfish>xentrac: you're not wrong ;)
<Hagfish>i was thinking there could be a "proof of burn" system, to at least make it expensive to have multiple accounts
<Hagfish>hmm, actually, in a federated system, each user could send an email to one of the nodes in the system, and that node could publish the hash of the email address for the other nodes to check against
<Hagfish>unfortunately email addresses are low entropy, so the hashes could be cracked, but the published list would only say that a user exists, not what their user ID is
<Hagfish>so even if you could crack the email address, you wouldn't be able to link that to a specific document uploaded by the user
<Hagfish>hmm, some sort of Merkel tree?
<Hagfish>each node could publish the first half of each hash
<Hagfish>then, if two nodes publish the same first half, they can check with each other in secret to determine whether they have the same hash
<Hagfish>i believe that can be solved securely using the socialist millionaire protocol
<Darius>the gitcoin grants also have to solve the problem of one-person-one-vote, so maybe piggyback on whatever they're doing
<Hagfish>Darius: good thinking, thank you
<Darius>welcome